Post by OC_KQA » Fri Dec 05, 2014 9:44 am

When navigating my storefront (as a generic site user) using the category menu(s), the following error code displays at the top of the page:

Code: Select all

Warning: Division by zero in /home/.../catalog/controller/product/category.php on line 349
This appears regardless of which category/sub-category I view, but goes away when I return to either the main/home screen, or browse other parts of the website.

Please advise of any suggestions or fixes.

Thanks.
Last edited by OC_KQA on Sat Dec 06, 2014 9:18 am, edited 1 time in total.

New member

Posts

Joined
Thu Dec 04, 2014 8:03 am

Post by OC_KQA » Sat Dec 06, 2014 3:32 am

To add to this outstanding issue (because I think they are related issues): when logged in to the admin panel, anything I view (excluding dashboard) populates with the following single-line error code above the admin panel, with the corresponding path as follows:

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/category.php on line 271
-- When viewing category lists

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/product.php on line 505
-- When viewing product lists

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/recurring.php on line 286
-- When viewing recurring profiles list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/filter.php on line 250
-- When viewing filters list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/attribute.php on line 253
-- When viewing attributes list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/attribute_group.php on line 250
-- When viewing attributes group list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/option.php on line 250
-- When viewing options list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/manufacturer.php on line 250
-- When viewing manufacturers list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/download.php on line 250
-- When viewing downloads list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/review.php on line 378
-- When viewing reviews list

Code: Select all

Warning: Division by zero in /home/.../admin/controller/catalog/information.php on line 250
-- When viewing information list

This trend continues throughout ALL admin menu/sub-menu items, with the exception of the main dashboard.

Any suggestions or fixes would be greatly appreciated.

Thanks all, and Happy Friday!

New member

Posts

Joined
Thu Dec 04, 2014 8:03 am

Post by rph » Sat Dec 06, 2014 6:27 am

Go to System > Settings > Edit > Option and under the Product heading make sure you have a value entered for "Default Items Per Page (Catalog)" and "Default Items Per Page (Admin)".

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by OC_KQA » Sat Dec 06, 2014 6:54 am

Well, that suggestion uncovered a new problem for me: I'm not able to save ANY changes I make in the admin panel....so, I'll table that suggestion for now until I can get this new problem resolved. Any ideas? For the purposes of minimizing confusion/duplication, I'll post this new issue in a separate thread.

New member

Posts

Joined
Thu Dec 04, 2014 8:03 am

Post by OC_KQA » Sat Dec 06, 2014 9:13 am

Resolved with the following solution:

1. System > Settings > Edit > Store > Meta Title (ensure this field is populated)

2. System > Settings > Edit > Option > and under the Product heading make sure a value is entered for "Default Items Per Page (Catalog)" and "Default Items Per Page (Admin)"

SAVE!

Many thanks to 'rph' for the help.

New member

Posts

Joined
Thu Dec 04, 2014 8:03 am

Post by misspiggy » Sat May 16, 2015 3:04 pm

I think I have the same problem.

Also have these errors.

And want to change the settings but I cannot click on save.


But I don't understand your solution.
How do you go to the System > Settings > Edit > Store > Meta Title (ensure this field is populated) ??

Thanks !


Nevermind solved it with

INSERT INTO `oc_setting` (`setting_id`, `store_id`, `code`, `key`, `value`, `serialized`,`group`) VALUES
(218, 0, 'config', 'config_processing_status', 'a:1:{i:0;s:1:"2";}', 1,'config'),
(219, 0, 'config', 'config_complete_status', 'a:1:{i:0;s:1:"5";}', 1,'config');


now i was able to actually save things

Newbie

Posts

Joined
Fri Nov 18, 2011 7:37 pm

Post by arcovirtual » Thu Jul 07, 2016 2:17 pm

for version 2.2.0.1 me error is opencart don't save changes in product, and redirect home website, my store sold, and worked successfully for many months, but after a repair of the hosting company I fault this and not to do to resolve it, restore databases and nothing, restore files weeks ago and nothing restore all of weeks ago and nothing. restore databases last backups and complete all nada.- modify all files and pass some mistakes and nothing.

New member

Posts

Joined
Thu Jul 07, 2016 9:49 am
Who is online

Users browsing this forum: No registered users and 7 guests