Post by razvanescu » Sun Nov 23, 2014 8:44 pm

Hi guys,
I'm having a bit of an issue with this.

I'm trying to add a space between the value and the currency in the product page, eg. "100 USD" instead of "100USD".
In the previous versions of opencart all I had to do was add an extra space in the "Symbol right" line in Settings->Localisation->Currencies and it all went ok.
However version 2.0 won't let me do that.
Any ideas what can I edit and where?

Kind regards,
Razvan

Newbie

Posts

Joined
Sun Jan 13, 2013 6:44 am

Post by affect » Sun Nov 23, 2014 10:21 pm

Does it get saved to the database without the space or does the saved value look right, but not the one that's being displayed? Also, are you using the default or a custom theme? Adding a leading space to currency symbols works fine for me with the current development version from Git.

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm


Post by razvanescu » Sun Nov 23, 2014 10:59 pm

Actually, no. It doesn't save. I modify it, I click save and when I click "edit" again, it shows it unmodified.
This is why I'm thinking that there's something in the core files that need editing.

I'm using default theme.

Newbie

Posts

Joined
Sun Jan 13, 2013 6:44 am

Post by affect » Mon Nov 24, 2014 1:05 am

You probably want to update the file upload/admin/controller/localisation/currency.php to the latest Git. That should make currency updates work.

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm


Post by razvanescu » Mon Nov 24, 2014 1:36 am

affect wrote:You probably want to update the file upload/admin/controller/localisation/currency.php to the latest Git. That should make currency updates work.
Hi,
First of all, Thank you.

I just updated it.
Took the code from the latest git and replaced the one I had so far.
Still no change.

Newbie

Posts

Joined
Sun Jan 13, 2013 6:44 am

Post by affect » Mon Nov 24, 2014 2:09 am

Must be something else – drop me a PM or an email to martin@multimerch.com with your logs attached and a link to where it happens, if possible – I'll take a look.

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm


Post by affect » Mon Nov 24, 2014 3:29 am

In case anyone's having the same issue – get the latest system/library/request.php from GitHub.

There's an extra trim() call present in 2.0 that trims whitespaces in all request data – it's fixed in the current Git version. 8)

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm

Who is online

Users browsing this forum: No registered users and 7 guests