Page 4 of 4

Re: Warning: You do not have permission to access the API! OC2

Posted: Sun Dec 16, 2018 1:45 am
by xxvirusxx

Re: Warning: You do not have permission to access the API! OC2

Posted: Fri Jan 04, 2019 8:51 am
by abcagency
Go to System > Setting > Edit Your main Store > Click on Option
See here : API User
Select Your API USER

And thats it Solved

Re: Warning: You do not have permission to access the API! OC2

Posted: Sun Jan 13, 2019 3:51 am
by OSWorX
3.0.2.0 is different in handling the IPs and API that is why it is working.
In 2.x simply hit the button to add the IP.

Re: Warning: You do not have permission to access the API! OC2

Posted: Thu Mar 28, 2019 8:17 pm
by thekrotek
Just to sum this up...

Why the API issue happens?
Because since OC 2 OpenCart has absolutely ugly algorithm of editing orders from admin. In my opinion, it doesn't have any excuses or really solid reasons to be implemented. Never seen anything like this in any other platform and hopefully never will.

When it happens?
Sometimes it is indeed an issue with API settings or database structure after OC upgrade, sometimes a server side issue.

How can I fix this?
There're plenty simple solutions right in this topic, which may help, if your case is wrong setup/upgrade. If none of them helped and you're pretty sure, that all settings are correct, then you're, well... fudged. Even if you disable API check, the issue may stay and pop again in different places. For example, when editing an order, a payment/shipping address may be stored in session and not retrieved right in the next API call, when payment/shipping methods are queried. This happens, because session data was lost.

I've seen it personally on a few systems and there was a discussion of StackOverflow a few years ago, where issues with particular version of CentOS (or maybe some other server OS, not sure) were reported. The only way in the case, when no other solution helped, is to get yourself an admin and start digging into the issue.

P.S.: For me this API issue ALWAYS happened on OC 2.3 only, other versions worked just fine. It appears, that OC 2.3 is the most troublesome version, when it comes to API.

Re: Warning: You do not have permission to access the API! OC2

Posted: Fri Mar 29, 2019 4:35 am
by straightlight
P.S.: For me this API issue ALWAYS happened on OC 2.3 only, other versions worked just fine. It appears, that OC 2.3 is the most troublesome version, when it comes to API.
Correct. v3.x releases have been mostly fixed regarding the APIs since.