Post by johnnybravoh » Wed Nov 12, 2014 5:20 am


I have my store installed and configured using 2.0 as a new install, however when I go to my stores url (, I get the home page template but

The page you requested cannot be found!
The page you requested cannot be found.

In the content. I have .htaccess in the web root directory (contents of .htaccess follows)
I have tried setting SEO URLs in admin and it doesn't make a difference.

When clicking on links without SEO URLs enabled in admin takes me to appropriate places - I can view products, categories, info pages, all with no problems (other than that the URLS are full of GET parameters which is not SEO friendly). When I turn ON SEO URLS, I see the same thing on the front page, but ALL links to product pages, category pages, info pages all default to /.

Any ideas?????

------ .htaccess file contents ------
# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.
# 2. In your opencart directory rename htaccess.txt to .htaccess.
# For any support issues please visit:
Options +FollowSymlinks
# Prevent Directoy listing
Options -Indexes
# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]



Fri Jun 29, 2012 11:55 pm

Post by Valentin_ » Tue Dec 09, 2014 3:29 am

I have the same problem only when I click any friendly url and SEO url is activated - ver.
Test with Firefox, IE and Chrome

My shop is not run on the main web folder, is like / becomes /shop/
.httaccess is the same (OK?!).



Fri Apr 12, 2013 4:24 am

Post by chongshengdz » Tue Dec 09, 2014 6:37 pm

If you are using webmin virtualmin to build your site,you need to change
Options +FollowSymlinks to Options +SymLinksIfOwnerMatch
If you are using nginx,rewrite it yourself.

Active Member


Sat Apr 12, 2014 10:18 pm

Post by Valentin_ » Tue Dec 09, 2014 10:49 pm

Thanks, but not work.

cPanel Version 11.44.1 (build 23)
Theme x3
Apache version 2.2.23
PHP version 5.2.17
# Use PHP 5.3
AddType application/x-httpd-php53 .php)

MySQL version 5.1.61-cll
Architecture x86_64
Operating system linux



Fri Apr 12, 2013 4:24 am
Who is online

Users browsing this forum: No registered users and 8 guests