Post by marmax » Fri Oct 17, 2014 8:39 am

I have exactly the same http://forum.opencart.com/viewtopic.php ... 60#p520489 error with Paypal Express Checkout

New member

Posts

Joined
Fri Oct 10, 2014 4:34 am

Post by esmsgateway » Fri Oct 17, 2014 10:57 am

demcboon wrote:Hi!
When I try to enable "bestseller" module I`ve got this bug:

Notice: Undefined index: image_width in /home/......../admin/controller/module/bestseller.php on line 111

Does anybody fix this one?

Thanks!
1. edit line 13 :
before :
$this->model_setting_setting->editSetting('bestseller', $this->request->post['bestseller_status']);
after :
$this->model_setting_setting->editSetting('bestseller', $this->request->post);

2. edit line 111 :
before :
if (!$value['image_width'] || !$value['image_height']) {
after :
if (!$value['width'] || !$value['height']) {


regard,
farid

Newbie

Posts

Joined
Mon Jul 23, 2012 10:04 am

Post by marmax » Fri Oct 17, 2014 7:37 pm

I have set up PayPalPro in Sandbox, order went through well. (I have set status to 'processing' in paypal module.)

In the next step I have opened order and went to 'History' tab. Changed status to 'Shipped' and pressed 'Add History' button. I receive following message in the popup window:
SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data
OK
[EDIT] [SOLVED] - It seems the error occurs when site is in maintenance mode When in live mode is seems to work!
Last edited by marmax on Sat Oct 18, 2014 7:32 pm, edited 1 time in total.

New member

Posts

Joined
Fri Oct 10, 2014 4:34 am

Post by jaysh32 » Sat Oct 18, 2014 4:16 am

Came here to post the same issue regarding JSON.parse.

In Chrome I get "SyntaxError: Unexpected end of input OK"

However, in FireFox the error is a little different....

"SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data OK"

This is happening on a fresh install of OpenCart 2.0...Then modified the setting.php to fix error where I had to add:

Code: Select all

$data['text_edit'] = $this->language->get('text_edit');
and still same results, i'm sure that part is unrelated...

This happened on my old install as well when trying to modify order status, create order in admin, or delete order. (Delete order didn't show error, just reloaded the page and didn't delete)

Any help is much appreciated.

Newbie

Posts

Joined
Sat Oct 18, 2014 3:54 am

Post by delick » Sat Oct 18, 2014 6:33 am

I'm getting the message "Modification requires a unique ID code!" in extension installer, how to solve?

Newbie

Posts

Joined
Mon Apr 22, 2013 6:50 am

Post by allenshea » Sat Oct 18, 2014 9:03 am

Anyone has problem with this?
Notice: Undefined index: customer_group_id in D:\xampp\htdocs\oc2\index.php on line 198

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by goldndelicious » Sun Oct 19, 2014 12:31 am

I'm getting this error on the confirmation stage on the checkout page when using paypal

Notice: Undefined index: option_value in /home/sheetpla/public_html/multistore/catalog/controller/payment/pp_standard.php on line 32Notice: Undefined index: option_value in /home/sheetpla/public_html/multistore/catalog/controller/payment/pp_standard.php on line 32

clean install at http://www.lexanpolycabonate.co.uk

personalised car signs
personalised bedroom door signs
personalised gifts for kids


New member

Posts

Joined
Sun Oct 04, 2009 8:22 am

Post by pm-netti » Sun Oct 19, 2014 1:51 am

goldndelicious wrote:I'm getting this error on the confirmation stage on the checkout page when using paypal

Notice: Undefined index: option_value in /home/sheetpla/public_html/multistore/catalog/controller/payment/pp_standard.php on line 32Notice: Undefined index: option_value in /home/sheetpla/public_html/multistore/catalog/controller/payment/pp_standard.php on line 32

clean install at http://www.lexanpolycabonate.co.uk
You open file catalog/controller/payment/pp_standard.php. Editing in lines 32 and 35 this way:

Code: Select all

if ($option['type'] != 'file') {
						$value = $option['value'];
					} else {
						$filename = $this->encryption->decrypt($option['value']);

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by leeman » Tue Oct 21, 2014 4:19 pm

ive done a clean install of oc2 from github and after hitting storelogo>edit>new folder>. I hit upload>select the file open and a drop down box appears saying the page at (mywebsite) says: hi
why is this

New member

Posts

Joined
Tue May 01, 2012 12:44 am

Post by goldndelicious » Wed Oct 22, 2014 4:32 am

Hi,

I'm really having trouble with layouts and multi store, especially for the home pages. It seems that if i add a sort order to the modules, or have a number of modules (say 4) the shops do not behave as expected. This is too difficult to try and explain, so i have created this screen cast to demonstrate.

the 4 stores also include the default shop (which i am not using) - that doesn't seem to want to play at all!

Sorry, no commentary, but i hope you get the idea of what is going on. "Default" is the only common/home route. I have tried it with "home" and even creating my own specific layouts for common/home but have the same issues

Thanks in advance for any help.
https://www.youtube.com/watch?v=98oGA1mDZq0

personalised car signs
personalised bedroom door signs
personalised gifts for kids


New member

Posts

Joined
Sun Oct 04, 2009 8:22 am

Post by wearcoffee » Wed Oct 22, 2014 6:01 am

New Install not deleting orders, Updating Statuses, or sending Emails.!!!!!!! Someone please help.

I keep getting "SyntaxError: Unexpected end of input
OK"

This is driving me NUTS!!!!

Newbie

Posts

Joined
Thu Jul 11, 2013 7:24 am

Post by jsalazarf » Wed Oct 22, 2014 2:11 pm

I just did a fresh install 2.0 and I am having problems with the filters.

Although I have 16 different filters divided in 4 groups, the Autocomplete on Product>Edit Product>Links shows only 5 filters. However, I may fill it manually with the right filter.

Once in the storefront, it only displays four filters (all included in the 5 previously mentioned) even though I chose manually different ones.
Imagen1.jpg

Imagen1.jpg (164.21 KiB) Viewed 8994 times

I would appreciate any help.

Thanks in advance,

JSF

Newbie

Posts

Joined
Wed Oct 22, 2014 1:37 pm

Post by marmax » Wed Oct 22, 2014 5:30 pm

New Install not deleting orders, Updating Statuses, or sending Emails.!!!!!!! Someone please help.

I keep getting "SyntaxError: Unexpected end of input
OK"
Try to switch off maintenance mode and see if error persists. Worked for me, although I had different error displayed. Let others know if it works for you. If it works, let me know if updating status is substracting stock for you - I got such problem.

New member

Posts

Joined
Fri Oct 10, 2014 4:34 am

Post by fido-x » Wed Oct 22, 2014 8:50 pm

PayPal Pro Iframe
In "catalog/controller/payment/pp_pro_iframe.php", line 145 reads:

Code: Select all

$order_status_id = $this->config->get['pp_pro_iframe_reversed_status_id'];
Should be parentheses not square brackets, as follows::

Code: Select all

$order_status_id = $this->config->get('pp_pro_iframe_reversed_status_id');

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by tinytopey » Thu Oct 23, 2014 2:30 am

I am trying to enable the FTP for my site, but as i filled out all of the settings, the "set order status" section seems to not be working. Im not sure how to move forward.

Attachments

Screen Shot 2014-10-22 at 2.13.03 PM.png

Screen Shot 2014-10-22 at 2.13.03 PM.png (34.94 KiB) Viewed 8923 times


Image

C.J.Martin / Creative Dept.

Fresh Roasted Coffee LLC. Office: 1.570.743.9228 / Fax: 1.570.372.5540
616 South High Street, Selinsgrove PA 17870
http://www.freshroastedcoffee.com/

Facebook Twitter


User avatar
Newbie

Posts

Joined
Thu Oct 23, 2014 2:20 am
Location - Fresh Roasted Coffee LLC

Post by Alexandra Ionela » Thu Oct 23, 2014 5:05 am

HELLO! I HAVE AN ISSUE :-[ WHEN I UPLOAD A PICTURE FROM ADMIN CONTROL PANNEL TO/ON THE SERVER. THE ISSUE IS: SyntaxError: JSON.parse: unexpected character al line 1 column 1 of the JSON data See the picture below, thank you and I hope someone help me with this....

Attachments

19-Oct 23.12.57.jpg

19-Oct 23.12.57.jpg (45.23 KiB) Viewed 8926 times



Posts

Joined
Fri Aug 01, 2014 1:26 am

Post by zedrally » Thu Oct 23, 2014 7:22 am

Text Editor in Products:
Unable to use the Link Function. It just hangs.

Active Member

Posts

Joined
Mon Sep 29, 2014 12:12 pm

Post by fido-x » Thu Oct 23, 2014 11:29 am

Product Special
When there are no products on special, errors occur on the products specials page:

Code: Select all

2014-10-23 2:39:32 - PHP Notice:  Undefined variable: continue in ######/catalog/view/theme/default/template/product/special.tpl on line 106
2014-10-23 2:39:32 - PHP Notice:  Undefined variable: button_continue in ######/catalog/view/theme/default/template/product/special.tpl on line 106
The controller (catalog/controller/product/special.php) needs to have the following lines added (around line 84):

Code: Select all

$data['button_continue'] = $this->language->get('button_continue');
$data['continue'] = $this->url->link('common/home');

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by banners.roughstuff » Thu Oct 23, 2014 12:08 pm

when customer try to upload a artwork file this notice comes up
PHP Notice: Use of undefined constant DIR_UPLOAD - assumed 'DIR_UPLOAD' in /home/roughstu/public_html/banners/catalog/controller/tool/upload.php on line 65


Posts

Joined
Thu Oct 23, 2014 9:38 am

Post by banners.roughstuff » Thu Oct 23, 2014 12:54 pm

I have these errors come up customers can not upload a file
HP Notice: Use of undefined constant DIR_UPLOAD - assumed 'DIR_UPLOAD' in /home/roughstu/public_html/banners/catalog/controller/tool/upload.php on line 65
2014-10-23 4:14:06 - PHP Notice: Use of undefined constant DIR_UPLOAD - assumed 'DIR_UPLOAD' in /home/roughstu/public_html/banners/admin/controller/tool/upload.php on line 273
Can anyone help with this please
Last edited by banners.roughstuff on Tue Oct 28, 2014 9:09 pm, edited 1 time in total.


Posts

Joined
Thu Oct 23, 2014 9:38 am
Who is online

Users browsing this forum: No registered users and 8 guests