Post by MaxPower » Thu Nov 27, 2014 11:15 am

pprmkr wrote:Solution for Admin - Marketing - Contact not sending mail: E-Mail Message required!

Edit admin/view/template/marketing/contact.tpl

After:

Code: Select all

    function send(url) {
Add:

Code: Select all

    $('textarea[name="message"]').html($('#input-message').code());
This solution doesn't work for me. After editing the file and trying to reload the 'mail' page in Admin, it's just a white page.

Newbie

Posts

Joined
Fri Nov 21, 2014 4:09 am

Post by i2Paq » Thu Nov 27, 2014 10:05 pm

MaxPower wrote:
pprmkr wrote:Solution for Admin - Marketing - Contact not sending mail: E-Mail Message required!

Edit admin/view/template/marketing/contact.tpl

After:

Code: Select all

    function send(url) {
Add:

Code: Select all

    $('textarea[name="message"]').html($('#input-message').code());
This solution doesn't work for me. After editing the file and trying to reload the 'mail' page in Admin, it's just a white page.
Then you made a mistake.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by JRmbdl » Fri Nov 28, 2014 9:20 am

Clean manual 2.0 installation, on 2freehostings.com servers when creating, or editing an order i get an error:

SyntaxError; Unexpected end of input

OK

using firefox, chrome and IE i get similar errors, and as well when i go to delete the order i get the confirmation that the order will be deleted but then the order does not delete. i have tried almost everything on the forums. deleted all .htaccess and copied new one from the installation zip, as well as modifying several files but to no success. i have reviewed this post http://forum.opencart.com/viewtopic.php?f=181&t=132699 and the only thing i dont really understand is the dns setting in the host file? as why would you change just your local computers dns it does not solve the issue anyway. Please ANY HELP is help :)

Newbie

Posts

Joined
Fri Nov 28, 2014 8:47 am

Post by pm-netti » Sat Nov 29, 2014 5:34 am

JRmbdl wrote:Clean manual 2.0 installation, on 2freehostings.com servers when creating, or editing an order i get an error:

SyntaxError; Unexpected end of input

OK

using firefox, chrome and IE i get similar errors, and as well when i go to delete the order i get the confirmation that the order will be deleted but then the order does not delete. i have tried almost everything on the forums. deleted all .htaccess and copied new one from the installation zip, as well as modifying several files but to no success. i have reviewed this post http://forum.opencart.com/viewtopic.php?f=181&t=132699 and the only thing i dont really understand is the dns setting in the host file? as why would you change just your local computers dns it does not solve the issue anyway. Please ANY HELP is help :)
Add API user in menu Settings > Users > API

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by JRmbdl » Sat Nov 29, 2014 9:05 am

pm-netti wrote: Add API user in menu Settings > Users > API
This Is What My API Looks like,
Image

Newbie

Posts

Joined
Fri Nov 28, 2014 8:47 am

Post by cargogirl » Sat Nov 29, 2014 11:14 am

hi
Just installed opencart 2.0 and get the setting.tpl on line 29 error below:

Notice: Undefined variable: text_edit in /var/www/vhosts/instamatic.com.au/httpdocs/RBnewsite/admin/view/template/setting/setting.tpl on line 29

can anyone help please

ADG - Design, Development and Hosting in Australia


User avatar
New member

Posts

Joined
Fri Aug 23, 2013 2:11 pm

Post by pm-netti » Sat Nov 29, 2014 4:06 pm

JRmbdl wrote:
pm-netti wrote: Add API user in menu Settings > Users > API
This Is What My API Looks like,
Image
You check database:
http://forum.opencart.com/viewtopic.php ... 99#p529340

How your in database is that field 'api_id'?

Ps. file view/template/sale/order_form.tpl no need to change. 8)

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by marmax » Sun Nov 30, 2014 11:40 pm

Hussar wrote:Entering the website at https://www.opencart.com/ we are faced with a large blue box with Download 2.0. Can someone please say if this is the recommended upgrade? I'm unsure.
Yes, if you want to loose a few years of your life because of stress - upgrade. If you want reliable shopping cart - do not use 2.0 yet.

New member

Posts

Joined
Fri Oct 10, 2014 4:34 am

Post by mitakis2002 » Mon Dec 01, 2014 6:29 am

OK I tried to find the problem I have but I was not able to so I am posting the problem and the solution I found hoping that someone will benefit from it.

1. I had Opencard 1.5.6.4 running OK.
2. I tried to upgrade to 2.0 and nothing worked

Even after I changed to the default theme, removed vqmod and all the plugins and such my store still would not work OK! For example when I tried to update or create a banner it would never save. I saw a couple of sql erros quoted in this topic that I saw in my installation also.

The reason for my troubles: a lot of missing tables and not restructured tables in the DB. The upgrade did not touch the DB at all!
The fix: after some debugging I found out that in model/upgrade.php there is a regex at line 123 that is supposed to extract the table name from the create statement. However this regex does not take into account the IF NOT EXISTS part of the sql statement. This makes it to return no values and so the DB is not touched at all. After I fixed the regex I was clear :)

For those that want to try it:
Original:

Code: Select all

preg_match_all('#create\s*table\s*`(\w[\w\d]*)`#i', $sql, $table);
Fixed:

Code: Select all

preg_match_all('#create\s*table\s*if\s*not\s*exists\s*`(\w[\w\d]*)`#i', $sql, $table);

Newbie

Posts

Joined
Mon Dec 01, 2014 6:20 am

Post by cwswebdesign » Tue Dec 02, 2014 12:16 pm

mitakis2002 wrote:OK I tried to find the problem I have but I was not able to so I am posting the problem and the solution I found hoping that someone will benefit from it.

1. I had Opencard 1.5.6.4 running OK.
2. I tried to upgrade to 2.0 and nothing worked

Even after I changed to the default theme, removed vqmod and all the plugins and such my store still would not work OK! For example when I tried to update or create a banner it would never save. I saw a couple of sql erros quoted in this topic that I saw in my installation also.

The reason for my troubles: a lot of missing tables and not restructured tables in the DB. The upgrade did not touch the DB at all!
The fix: after some debugging I found out that in model/upgrade.php there is a regex at line 123 that is supposed to extract the table name from the create statement. However this regex does not take into account the IF NOT EXISTS part of the sql statement. This makes it to return no values and so the DB is not touched at all. After I fixed the regex I was clear :)

For those that want to try it:
Original:

Code: Select all

preg_match_all('#create\s*table\s*`(\w[\w\d]*)`#i', $sql, $table);
Fixed:

Code: Select all

preg_match_all('#create\s*table\s*if\s*not\s*exists\s*`(\w[\w\d]*)`#i', $sql, $table);
There isn't an upgrade script from v1.5.x to v2.0.x

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by jdurand » Fri Dec 05, 2014 2:45 am

I just went to upgrade from 2.0.0.0 to 2.0.1.0 but the UPGRADE instructions are only for 1.5.4.x. How do I go from 2 to 2+?

Newbie

Posts

Joined
Thu Oct 02, 2014 4:45 am

Post by cwswebdesign » Fri Dec 05, 2014 4:20 am

jdurand wrote:I just went to upgrade from 2.0.0.0 to 2.0.1.0 but the UPGRADE instructions are only for 1.5.4.x. How do I go from 2 to 2+?
Backup your daabase and files and then upload the new files including the install folder. Run the upgrade script and delete the install folder after that.

My guess is the text hasn't been updated in that readme file but I just did the same thing last night with no issues.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by jdurand » Fri Dec 05, 2014 4:35 am

Thanks. I figured that was it but didn't know if there was anything special.

Newbie

Posts

Joined
Thu Oct 02, 2014 4:45 am

Post by morthium » Fri Dec 05, 2014 6:53 am

My "people online" tracking does not work.
If i login with a fake customer account its not tracked. It also dont work if i access with a webproxy.

Can someone tell me how this tracking work?

Newbie

Posts

Joined
Fri Dec 05, 2014 6:44 am

Post by jdurand » Fri Dec 05, 2014 3:21 pm

Well, no error messages in admin, but both my stores give a blank page on the main page now. :(

Any ideas? Is there a way to save my products and customers and such and then do a clean install?

Newbie

Posts

Joined
Thu Oct 02, 2014 4:45 am

Post by pm-netti » Fri Dec 05, 2014 9:01 pm

jdurand wrote:Well, no error messages in admin, but both my stores give a blank page on the main page now. :(

Any ideas? Is there a way to save my products and customers and such and then do a clean install?
One option:
http://www.opencart.com/index.php?route ... n_id=19572

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by cwswebdesign » Fri Dec 05, 2014 10:33 pm

jdurand wrote:Well, no error messages in admin, but both my stores give a blank page on the main page now. :(

Any ideas? Is there a way to save my products and customers and such and then do a clean install?
Can you turn on error reporting either in the admin area or directly in the database? More than likely, it's module related.

If you want, you can email me at websitedesign@evolvewebhost.com for help.

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by webwave » Sat Dec 06, 2014 12:47 am

morthium wrote:My "people online" tracking does not work.
If i login with a fake customer account its not tracked. It also dont work if i access with a webproxy.

Can someone tell me how this tracking work?
You can fix your problem by setting following option to "Yes":
System - Settings - "Edit your shop" - Option - Account - Customer Online -> "Yes"

regards, webwave

Swiss eCommerce Professionals - http://www.webwave.ch
Image


Newbie

Posts

Joined
Sat Dec 06, 2014 12:40 am

Post by mpdmp » Sat Dec 06, 2014 4:48 am

After installation of 2.0, a fresh install, I am unable to login to the admin panel. I know the password is correct and everything, so something is causing it to come back to the login page.

Upon a login attempt, I do get a token, just don't get sent to the panel.

Server is Ubuntu, LAMP, php 5.5

Help please?

Newbie

Posts

Joined
Sat Dec 06, 2014 4:46 am

Post by baozilala » Sun Dec 07, 2014 7:06 pm

Im using 2.0.1.1
when i try to open cart page, it come out this issue, the problem result cart page become to blank.

Code: Select all

2014-12-07 10:02:01 - PHP Notice:  unserialize(): Error at offset 0 of 22 bytes in /var/www/opencart/system/library/cart.php on line 23
2014-12-07 10:02:01 - PHP Notice:  unserialize(): Error at offset 0 of 1 bytes in /var/www/opencart/system/library/cart.php on line 23
i checked on google but i cann't find any same issue.
and
i compaired two cart.php files with 2.0.1.0 they all have same content.
hope someone can help.

Newbie

Posts

Joined
Sat Dec 06, 2014 10:27 pm
Who is online

Users browsing this forum: No registered users and 4 guests