Post by ivailo_georgiev » Wed Jun 01, 2022 1:28 pm

Hello!

I have OC 2.0.3.1. А few months ago I updated PHP 5.5 to 7.3. Yesterday I tried to install Facebook Business for OC Extension, but I can't. In installer I had popup error message. After that I try to install other extension - free fast checkout and again the same message. Maybe I can't install any extensions in intstaller. :(

The error is:

Code: Select all

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
OK
<br />
<b>Fatal error</b>:  Uncaught Error: Call to undefined function zip_open() in /home/mysite/public_html/vqmod/vqcache/vq2-system_modification_admin_controller_extension_installer.php:125
Stack trace:
#0 /home/mysite/public_html/vqmod/vqcache/vq2-system_modification_system_engine_action.php(65): ControllerExtensionInstaller-&gt;upload(Array)
#1 /home/mysite/public_html/system/engine/front.php(34): Action-&gt;execute(Object(Registry))
#2 /home/mysite/public_html/system/engine/front.php(29): Front-&gt;execute(Object(Action))
#3 /home/mysite/public_html/admin/index.php(175): Front-&gt;dispatch(Object(Action), Object(Action))
#4 {main}
  thrown in <b>/home/mysite/public_html/vqmod/vqcache/vq2-system_modification_admin_controller_extension_installer.php</b> on line <b>125</b><br />

http://gigadesign.bg/
http://220volta.bg/



Posts

Joined
Wed Jan 22, 2014 8:44 pm


Post by straightlight » Wed Jun 01, 2022 5:33 pm

PHP version needs to be put up-to-date to at least 8.1. Upgrading to OC V4 while using PHP 8.1 would be the best option at this time.

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ivailo_georgiev » Wed Jun 01, 2022 5:54 pm

Thank you for advise. I understand that, but hosting not provide newer version of PHP and now I can't upgrade to OC v4. And every other solutions wold me help me.
straightlight wrote:
Wed Jun 01, 2022 5:33 pm
PHP version needs to be put up-to-date to at least 8.1. Upgrading to OC V4 while using PHP 8.1 would be the best option at this time.

http://gigadesign.bg/
http://220volta.bg/



Posts

Joined
Wed Jan 22, 2014 8:44 pm


Post by straightlight » Wed Jun 01, 2022 11:32 pm

ivailo_georgiev wrote:
Wed Jun 01, 2022 5:54 pm
Thank you for advise. I understand that, but hosting not provide newer version of PHP and now I can't upgrade to OC v4. And every other solutions wold me help me.
straightlight wrote:
Wed Jun 01, 2022 5:33 pm
PHP version needs to be put up-to-date to at least 8.1. Upgrading to OC V4 while using PHP 8.1 would be the best option at this time.
You could always create a new service request in the Commercial Support section of the forum to have this issue investigated as a custom job.

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ADD Creative » Thu Jun 02, 2022 5:23 pm

Looks like your PHP is missing the zip extension. Ask your host to install it.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom
Who is online

Users browsing this forum: No registered users and 1 guest