Post by kriteach » Thu Aug 25, 2016 9:32 am

After upgrading to 2.3.0.2 I'm getting this error on the frontend.

Notice: Undefined index: english in /home/www/website/catalog/controller/startup/startup.php on line 106

Everything was fine until the upgrade but this error is preventing the page from being viewed with all my products. I haven't been able to fine any topics specifically related to this and I assume its a language issue. I'm only running one language at the moment (en) even though the module install with the upgrade is (en-gb) and the previous one (english) I can no longer select under localisation.

Any help would be truly appreciated.

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by florinsith » Thu Aug 25, 2016 5:16 pm

Did you run the upgrade script? Also try clearing your cookies.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by kriteach » Fri Aug 26, 2016 11:57 am

Yes, the upgrade script runs fine and I have tried from multiple computers and several that have never been the site. Cache has been cleared from all of my office computers. Under IE I also get the "Cannot modify header information" error along with the english error.

I've also tried uploading the files again via ftp (running the upgrade script once uploaded) and still the same error

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by florinsith » Fri Aug 26, 2016 2:17 pm

Post a link to the website.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by kriteach » Sat Aug 27, 2016 12:36 pm


Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by linards » Sat Aug 27, 2016 2:17 pm

Something went wrong with your upgrade process. You have the language files missing. Opencart 2.3.0.2 changed the directory structure for languages and extensions. I would recommend you to check and re-upload the language folders for admin and catalog.

Newbie

Posts

Joined
Wed Feb 12, 2014 7:18 pm

Post by pm-netti » Sun Aug 28, 2016 1:12 am

kriteach wrote:After upgrading to 2.3.0.2 I'm getting this error on the frontend.

Notice: Undefined index: english in /home/www/website/catalog/controller/startup/startup.php on line 106

Everything was fine until the upgrade but this error is preventing the page from being viewed with all my products. I haven't been able to fine any topics specifically related to this and I assume its a language issue. I'm only running one language at the moment (en) even though the module install with the upgrade is (en-gb) and the previous one (english) I can no longer select under localisation.

Any help would be truly appreciated.
Maybe your language code is wrong, are you go to admin > system > localisation > language > english and updated valid language code (en-gb)?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by kriteach » Sun Aug 28, 2016 8:00 am

Ok, I ended up deleting the old english language folder that was in the controller and admin language directories along with the en-gb folder. after removing these and then uploading the install folder again I was able to run the upgrade again. So far no errors and all the catalog is now showing up properly. Hopefully nothing changes...Thanks!!!

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by kriteach » Mon Aug 29, 2016 4:45 am

Spoke to soon. Even though the error message is gone. I can't see the dashboard on the admin side. The Categories and products don't show up in the admin side even though you can see them on the front end. Tried clearing cache and different browsers, but ends up withe the same thing. Also I get this strange thing through the admin side I get "text_enabled" "text_filter" "text_button"

Is this another upgrade issue?

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by cyclops12 » Mon Aug 29, 2016 5:08 am

these are still language problems, best to check with what language files you have installed compared with the language files in the 2.3.0.2 download folder

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by kriteach » Mon Aug 29, 2016 12:44 pm

All language files have been removed except "en-gb" from the upgrade.

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by kriteach » Wed Aug 31, 2016 1:15 pm

Still not very successfully I may just have to bite the bullet and move the site to a different platform all together.

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by cyclops12 » Wed Aug 31, 2016 4:45 pm

Do you have an admin/language/en-gb folder in your store ?

You may need to check that all relevant subfolders are installed as well

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by kriteach » Tue Sep 06, 2016 1:28 am

From what I can seen the files from the download match what was uploaded to my server.

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by uhhmnet » Sun Oct 09, 2016 2:10 am

I wanted to provide a solution for anyone facing this same issue as I had.

after a clean install of opencart 2.3.0.2 I changed the settings from the admin panel to remove UK and set my store up for USA.

upon doing this, I remember setting language to "english" from "en-gb".

suddenly my google results started showing this error:
opencart Notice: Undefined index: english in /path-to-my-opencart/public_html/catalog/controller/startup/startup.php

and every button inside of the admin panel was showing things like [text_enabled] [text_button] etc.

even after changing the language code back to "en-gb" the problem persisted.

SOLUTION:
you will need to feel comfortable editing your database directly or find someone who can do this for you if you are unable to perform direct database edits yourself.

i used phpMyAdmin via cPanel.

Code: Select all

go to the "oc_setting" table.

locate these 2 fields:
"config_language"
"config_admin_language"
note: for me it was page 6 of the results in "oc_setting" table, or "setting_id" 3876 and 3877

Code: Select all

edit the "value" field in both "config_language" and "config_admin_language"

change "value" to "en-gb" (without the quotes) for both "config_language" and "config_admin_language"

click "Go"
now check your admin panel and you should see "[text_enabled]" is now simply "Enabled" and so on and so forth.

good luck!

ps. here are two sample MySQL statements you can modify and run if you know how, replace "your_db_name" with your actual opencart database name.

Code: Select all

UPDATE  `your_db_name`.`oc_setting` SET  `value` =  'en-gb' WHERE  `oc_setting`.`key` ='config_language';
UPDATE  `your_db_name`.`oc_setting` SET  `value` =  'en-gb' WHERE  `oc_setting`.`key` ='config_admin_language';

Newbie

Posts

Joined
Wed Jan 07, 2015 4:04 am

Post by kriteach » Thu Oct 13, 2016 9:20 am

I tried your steps and mine still appears the same.

Newbie

Posts

Joined
Thu Aug 25, 2016 9:26 am

Post by 4430704@gmail.com » Thu Oct 13, 2016 5:25 pm

Registered to this foum only to thank you. It worked for me. I got this error when installed additional language(ukraininan). Folders with language pack and database entries had different names an it caused to errors in both english and ukrainian languages. After editing in database values for ukrainian settings all worked fine - english and ukrainian interface.


Posts

Joined
Thu Oct 13, 2016 5:15 pm

Post by mrnet » Fri Oct 21, 2016 1:35 am

Thank you so much for this uhhmnet.

It worked perfectly for me and I appreciate a lot when people returns to a forum and post the solution for others!!

New member

Posts

Joined
Thu Dec 08, 2011 8:16 am

Post by rhorne » Fri May 26, 2017 3:25 pm

I had the exact same issue after upgrading. For some reason English and en-gb were set as language options and there seems to be some confusion between the two. This fix appears to have solved the issue. Great work.

Active Member

Posts

Joined
Wed Jan 18, 2012 3:07 am

Post by the-mikael-johansson » Mon Jan 11, 2021 5:23 am

Hi!

For me it was the config_language setting that was changed from "sv-se" to "swedish". And my error was "Undefined index swedish...". I manually changed the value in the database (back to sv-se) and the site started to work agian.

Best regards,
Mikael


Posts

Joined
Mon Jan 11, 2021 4:04 am
Who is online

Users browsing this forum: No registered users and 17 guests