Post by d77 » Sun Sep 23, 2007 3:35 am

i've written a little rss mod, creates a feed of the latest products added to your shop.

doesn't really fit into the existing contribution categories, so i'll post it here. please feel free to make any changes/suggestions and post them here. if there is some way to make this type of thing fit into the opencart model better, let me know.

installation instructions are included in install.txt
works with opencart 0.7.6.1

Attachments

Last edited by d77 on Sun Sep 23, 2007 3:38 am, edited 1 time in total.

User avatar
d77
Active Member

Posts

Joined
Sat Apr 14, 2007 8:04 am

Post by carlo » Sun Sep 23, 2007 8:07 am

Just installed it mate, good stuff! :)

User avatar
Newbie

Posts

Joined
Sat Sep 22, 2007 7:30 am
Location - UK

Post by rutgerontwerp » Tue Nov 13, 2007 5:18 am

Thanks, this works like a charm. Lovely!

Newbie

Posts

Joined
Mon Nov 12, 2007 8:18 am

Post by ogun » Tue Nov 13, 2007 6:05 am

nice one, d/l'ing :)

Active Member

Posts

Joined
Tue Aug 14, 2007 6:04 am

Post by tchemis » Tue Nov 13, 2007 11:19 pm

Anyone have this working on the current version (0.7.7)? I am not getting any posts/products in the feed. Good Job it worked great in y previous installation.

Active Member

Posts

Joined
Tue Aug 21, 2007 9:23 am

Post by d77 » Wed Nov 14, 2007 2:56 am

sorry, i haven't updated to 0.7.7 so i'm not sure if it works yet.

User avatar
d77
Active Member

Posts

Joined
Sat Apr 14, 2007 8:04 am

Post by rutgerontwerp » Wed Nov 14, 2007 7:06 am

just checked, works fine with latest version. :)

Newbie

Posts

Joined
Mon Nov 12, 2007 8:18 am

Post by tchemis » Wed Nov 14, 2007 9:16 am

rutgerontwerp wrote: just checked, works fine with latest version. :)

???, not for me, maybe I messed with something in my installation I will have a look.

It does work with the current version.
Last edited by tchemis on Wed Nov 14, 2007 4:24 pm, edited 1 time in total.

Active Member

Posts

Joined
Tue Aug 21, 2007 9:23 am

Post by gabibv » Mon May 05, 2008 5:36 pm

Hello i test rss on last version of opencart and after i add a last products rss give a error

"The XML page cannot be displayed
Cannot view XML input using XSL style sheet.
Please correct the error and then click the Refresh button, or try again later.
An invalid character was found in text content. Error processing resource 'http://audio-car.ro/rss.php'. Line 105, Positio...
Track â"

Any ideea what it is

Newbie

Posts

Joined
Tue Oct 09, 2007 4:50 am

Post by d77 » Mon May 05, 2008 8:34 pm

search the rss source for that text and you'll see the problem.

looks like some bad/unrecognized character data in one of your product listings.

User avatar
d77
Active Member

Posts

Joined
Sat Apr 14, 2007 8:04 am

Post by gabibv » Tue May 06, 2008 3:20 am

Problem solved ther is a " . " dot in the rss script in line 58 that cause the problem.

$prod_desc . = htmlentities('
resize($result['filename'], 100, 100) . '" />');

and must be:

$prod_desc = htmlentities('
resize($result['filename'], 100, 100) . '" />');

Now is ok

Thank you

Newbie

Posts

Joined
Tue Oct 09, 2007 4:50 am

Post by d77 » Tue May 06, 2008 8:25 pm

i'm pretty sure the change you just made will exclude the product text from the RSS and will only show the product image in the feed.

the problem is in your product data. by making the above change you are just "working around" the problem by not including that data.

User avatar
d77
Active Member

Posts

Joined
Sat Apr 14, 2007 8:04 am

Post by gabibv » Fri May 09, 2008 3:13 am

Now the problem is fix i find the trouble i copy description from a file that have diacritics and in products description it show "?" and i replace the missing caracter and all ok .
;D
Last edited by gabibv on Fri May 09, 2008 6:53 pm, edited 1 time in total.

Newbie

Posts

Joined
Tue Oct 09, 2007 4:50 am

Post by mcphearson » Tue Jun 10, 2008 3:29 am

Works great for me.
check it out i have a rss button next to my search bar, and an information page for rss feeds!

http://www.ourusedunderwear.com/

User avatar
Newbie

Posts

Joined
Mon Jun 09, 2008 2:05 am


Post by Telefax » Tue Jun 17, 2008 4:50 am

Hi mcphearson, would it maybe be possible to post the code you use for your RSS Feed in:

http://ourusedunderwear.com/index.php?c ... tion_id=15

It's so cool and I can hardly wait to implement the same "look" on my own Opencart... if you changed the allready posted RSS code, feel free to post it too  ;D

Mmmm... sweet addons....

New member

Posts

Joined
Sun Apr 06, 2008 4:47 pm

Post by lev » Fri Jun 27, 2008 10:18 pm

mcphearson your http://ourusedunderwear.com/index.php?c ... tion_id=15 page has some broken images, 'SPONSORS' is spelled wrong, shows no image.... so i can tell you still got work to do there, but I'm more curious in 2 things...

where did u get the code for all the different bookmaring engines and are u actually planning on selling used panties  :o

lev
New member

Posts

Joined
Wed Apr 30, 2008 10:47 pm

Post by inbox » Mon Oct 27, 2008 10:18 pm

d77 wrote: i've written a little rss mod, creates a feed of the latest products added to your shop.

doesn't really fit into the existing contribution categories, so i'll post it here. please feel free to make any changes/suggestions and post them here. if there is some way to make this type of thing fit into the opencart model better, let me know.

installation instructions are included in install.txt
works with opencart 0.7.6.1
it dont work in diferent language :(

Newbie

Posts

Joined
Mon Oct 27, 2008 9:34 am

Post by hm2k » Tue Oct 28, 2008 5:48 am

This was included into the core, if you are having problems with the rss.php included in the core, please report it in the bugs section.

What language issues are you having?

UK Web Hosting


User avatar
Global Moderator

Posts

Joined
Tue Mar 11, 2008 9:06 am
Location - UK

Post by inbox » Tue Oct 28, 2008 10:54 pm

hm2k wrote: This was included into the core, if you are having problems with the rss.php included in the core, please report it in the bugs section.

What language issues are you having?
Latvian language and russian

Attachments

???
er.gif

Newbie

Posts

Joined
Mon Oct 27, 2008 9:34 am

Post by lsgxtremes » Sun Jan 25, 2009 5:04 pm

Hey d77,
Please help with this, I tried your extension and got this error when I tried using feedreader to build an rss

"The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 23: The entity "acirc" was referenced, but not declared."

When I tried using it with a module in joomla that just asks you for your rss url to display the contents on a web page, I got an error there too. It said "Error loading feed data."

So whats wrong exactly? BTW this is on 0.7.7 version of OpenCart

Hope you could suggest a fix.

Visit http://www.LSGLive.com - an Xciting hub for the gaming cult and the urban creed!


User avatar
Newbie

Posts

Joined
Thu Jan 15, 2009 7:01 pm
Location - mumbai, India
Who is online

Users browsing this forum: No registered users and 6 guests