Post by straightlight » Mon Mar 19, 2018 8:05 pm

This section does try to cover the most common and answered FAQ's.

IMPORTANT:
DO not ask questions here!!! This section is for READ ONLY and operate voluntarily by knowledgeable community members ONLY!
It is also important that you keep in mind, that all solutions/links offered here are given in good faith but that Opencart shall not be held responsible for any consequence arising by adopting such community member's advice!

Finally, we would like to extend our gratitude, to such members, that dedicate their time to continually support our community.

The Opencart Team

---------------------------------------------------------------------------------------------------------------------------------


There seem to be persistent posts regarding cache issues with OC v3.x releases when users selects the automatic settings from the OC admin security modal window. In order to avoid many issues, do NOT select the automatic settings.

This unknown integrated option is for decoration purposes only!

Update: This decoration works well with dedicated servers.

Followed are both options provided in case of problematic configurations of the security modal window in the future:

- Automatic settings that has been selected and the cache no longer responds: viewtopic.php?f=202&t=202985&p=717777#p717777

- Manual settings and the admin is not sure of the next on how to proceed afterwards: viewtopic.php?f=202&t=201745#p713479

- VQMod Cache Instructions:

viewtopic.php?f=202&t=203050&p=717980#p717958

Update - Fix security route: https://github.com/opencart/opencart/pull/6847

Update: June 24 2019 - viewtopic.php?f=202&t=212478&p=758316#p758314 .
Last edited by straightlight on Tue Aug 13, 2019 8:34 am, edited 3 times in total.

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Fri Mar 23, 2018 12:19 am

Before posting an inquiry about making changes and no effect are being taken, ensure to have clear your OC cache from your OC admin (v3x releases) in your:

- admin - > dashboard - > blue icon on the right
- admin - > extensions - > modifications - > refresh button

Then, notice the changes on your reflected page.

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Jul 03, 2018 12:11 am

Another additional reason why it is important to read the forum rules before posting: viewtopic.php?f=190&t=205100&start=20#p728046

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Jul 25, 2018 6:27 pm

There has been a wide number of posts recently regarding the best ways to upgrade. Followed is a post that explains the step-by-step procedures: viewtopic.php?f=202&t=205805&p=729542#p729542 . As an alternative, you can always submit a new service request in the Commercial Support section of the forum to get this done as a custom job.

Resolution confirmation: viewtopic.php?f=201&t=205890#p730092

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MrPhil » Fri Aug 03, 2018 10:55 pm

ohmashoes wrote:
Thu Apr 19, 2018 6:06 pm
I have cleared the cache in modification and refresh.
I have also cleared cache in the Dashboard.
But still changes are not saving on the theme.
Please help.
In addition to possibly several OC caches holding data (depending on the version), don't forget to clear your browser's cache too! Browsers cache pages for a while, and until a cached page ages out, it won't be refreshed from OC on your server -- you have to force it. Also, some hosts have page caches of their own, to lessen server load. You'll have to talk to them to see if you can (or should) force a page refresh. Once you have cleared all caches, a request from your browser should result in the latest and greatest version of the requested page.

Most browsers will also permit you to clear one page at a time from the cache, such as by pressing F5 or Ctrl+F5. This is forcing a reload of a page, regardless of its cache status or age. However, you would have to do this for each page that might be affected.

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by straightlight » Mon Aug 13, 2018 4:47 am

There has been a large report over the past year regarding language code issues which outputs: text_ everywhere in the admin when playing with language packs. Followed is a posted solution on how to resolved those issues when that happens from OC v2.x and OC v3.x releases: viewtopic.php?f=190&t=206359#p731762 .

Resolution confirmation: viewtopic.php?f=190&t=206359#p731763

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sun Aug 26, 2018 1:04 am

A post covering an example on why the error / server access logs must be provided when creating new topics about technical issues: viewtopic.php?f=199&t=206616#p732805

Fundamental concepts of understanding based on the first post of this topic about the error / access logs: viewtopic.php?f=199&t=206616#p732810

Feedback of the understanding: viewtopic.php?f=199&t=206616#p732811

[Update: June 08 2019] - Followed is another example on following the forum rules: viewtopic.php?f=202&t=212140&p=756961#p756961 .
Last edited by straightlight on Sat Jun 08, 2019 10:57 pm, edited 1 time in total.

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Aug 28, 2018 9:23 pm

There has been a great mount of topics in the past regarding multiple use of the same coupons. Followed is a posted solution by a forum user who indicates his workaround (non-technical knowledge required): viewtopic.php?f=190&t=201935#p732994

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Oct 03, 2018 6:01 pm

Prior to v3.1.0.0a release, there has been countless posts about Google Sitemap output issues on the forum. Followed is the solution to fix the issue: https://github.com/opencart/opencart/commit/728e555

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ADD Creative » Wed Oct 03, 2018 10:48 pm

straightlight wrote:
Wed Oct 03, 2018 6:01 pm
Prior to v3.1.0.0a release, there has been countless posts about Google Sitemap output issues on the forum. Followed is the solution to fix the issue: https://github.com/opencart/opencart/commit/728e555
Doesn't look right to me. Will lead to double escaping like & and ".

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by straightlight » Thu Oct 04, 2018 4:28 am

Tell that to the creator who referenced this article on Github.

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sat Oct 13, 2018 9:58 pm

There seem to be countless posts about the language cache when using OC v3.x releases. Followed is the solution: viewtopic.php?f=202&t=207581&p=737012#p736994

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sun Mar 24, 2019 7:44 pm

There seem to be multiple postings about the catalog.language error and also with the file library cache. Followed is the solution: viewtopic.php?f=202&t=200896&start=20#p710221
Last edited by straightlight on Fri Jan 10, 2020 8:56 am, edited 1 time in total.

Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Jun 25, 2019 1:52 am


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Wed Dec 25, 2019 10:10 pm

SEO URLs configuration: viewtopic.php?f=202&t=215297#p772484

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sun Jan 19, 2020 10:27 pm

There seem to be an increased amount of postings regarding the sub-total, total extension modules not returning the right results either from the admin or during checkout. Followed is the bug-fix solution: viewtopic.php?f=202&t=215693#p774443

In addition, reviewing the entire Github referred commit discussion would be highly recommended to entirely fix this issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Jan 21, 2020 10:37 pm

Followed are instructions on how to configure SEO / Canonical links with Opencart: viewtopic.php?f=202&t=215728&p=774684#p774636

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Tue Jan 21, 2020 11:40 pm

Followed are guidance on how the extensions works as well as knowing where the extension files are being handled from: viewtopic.php?f=184&t=215740&p=774700#p774694

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Thu Jan 30, 2020 6:27 am

MrPhil wrote:
Fri Aug 03, 2018 10:55 pm
ohmashoes wrote:
Thu Apr 19, 2018 6:06 pm
I have cleared the cache in modification and refresh.
I have also cleared cache in the Dashboard.
But still changes are not saving on the theme.
Please help.
In addition to possibly several OC caches holding data (depending on the version), don't forget to clear your browser's cache too! Browsers cache pages for a while, and until a cached page ages out, it won't be refreshed from OC on your server -- you have to force it. Also, some hosts have page caches of their own, to lessen server load. You'll have to talk to them to see if you can (or should) force a page refresh. Once you have cleared all caches, a request from your browser should result in the latest and greatest version of the requested page.

Most browsers will also permit you to clear one page at a time from the cache, such as by pressing F5 or Ctrl+F5. This is forcing a reload of a page, regardless of its cache status or age. However, you would have to do this for each page that might be affected.
MrPhil's post would be correct regarding the enforcement. I was able to reproduce the event on a custom job for a client as it seem that JSON response in the OC admin might originate from other pages. For instance, a user could try to clear the error logs but the JSON response would only appear in the admin - > extensions - > extensions page to see the results.

To temporarily rectify that situation, see this post: viewtopic.php?t=205357&start=20#p739757 . However, take note that this solution should only be used for temporary reasons and NOT as a permanent solution. This workaround can remove security on backward compatibility APIs in Opencart and is not suggested to be used on a permanent basis. If the server is encountering issues with Cache Controls, better to contact your host to rectify the situation. If your host cannot assist you on this matter, it is better to look for another web hosting service since this issue is not specifically related to web browsers.

Also take note that the provided solution does not reflect to rectify domain cache issues situations. Those events might require advanced troubleshooting on the file server.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Fri Jan 31, 2020 2:34 am

There has been numerous posts in the past regarding orders not showing up on the dashboard. See this post for the solution: viewtopic.php?f=190&t=184381#p675037

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 4 guests