Post by quentin3d » Mon Feb 03, 2020 8:55 pm

OpenCart 3.0.3.2
Na localhost ok, na serwerze developerskim ok. Po przekopiowaniu na produkcję:

Code: Select all

Fatal error: Uncaught Twig_Error_Loader: Unable to find template "common/column_left.twig" (looked into: /home/opencart/domains/nazwadomeny.art.pl/public_html/sklep/catalog/view/theme). in...
Panel administracyjny działa ok. Ścieżki w plikach kongifuracyjnych też ok. OpenCart jakby nie pobierał z bazy nazwy katalogu szablonu.

Szablon dodany jako rozszerzenie wg: https://www.antropy.co.uk/blog/how-to-c ... t-3-theme/

Jakies sugestie?

Newbie

Posts

Joined
Mon Feb 03, 2020 8:05 pm

Post by DannyM » Mon Feb 03, 2020 10:55 pm

Odsiweżyć modyfikacje i sprawdzić czy plik faktycznie jest w tej lokalizacji

✯ Professional OpenCart Support [UK-based] ✯
https://opencart.tipshttps://opencart.com.plhttps://facebook.com/opencarttips ✯ Live-chat: http://pixly.me/livechat


User avatar
Active Member

Posts

Joined
Sun Jan 03, 2010 4:23 am
Location - Bournemouth, UK

Post by quentin3d » Mon Feb 03, 2020 11:48 pm

Odświeżyłem modyfikację, kasowałem cache przez panel i przez ftp. Pliki znajdują się w:

Code: Select all

/home/opencart/domains/nazwadomeny.art.pl/public_html/sklep/catalog/view/theme/defaulut
/home/opencart/domains/nazwadomeny.art.pl/public_html/sklep/catalog/view/theme/antropy
z jakiś jednak powodów Twig nie otrzymuje informacji o katalogach szablonów: default/antropy i próbuje załadowac pliki z katalogu:

Code: Select all

/home/opencart/domains/nazwadomeny.art.pl/public_html/sklep/catalog/view/theme
a tam ich rzeczywiście nie ma.

Hosting na linuxcom.pl.

Newbie

Posts

Joined
Mon Feb 03, 2020 8:05 pm

Post by DannyM » Mon Feb 03, 2020 11:51 pm

Opcja 1. wgrać brakujące pliki
Opcja 2. skontaktować się z autorem szablonu celem pomocy
Opcja 3. wyłączyć w dashboard pamięć podręczną
Serwer nie ma nic do tego

P.S. Nie wiem dlaczego wszyscy używają OC3 skoro to taka wczesna Beta bez bata w nazwie :D Niestety nie wszystko co ma wyższy numer jest lepsze i tutaj niestety jest dobry przykład ;)

✯ Professional OpenCart Support [UK-based] ✯
https://opencart.tipshttps://opencart.com.plhttps://facebook.com/opencarttips ✯ Live-chat: http://pixly.me/livechat


User avatar
Active Member

Posts

Joined
Sun Jan 03, 2010 4:23 am
Location - Bournemouth, UK

Post by quentin3d » Tue Feb 04, 2020 4:24 am

ad 1. Plików nie brakuje. Open Cart szuka ich z jakiś powodów w katalogu głównym: theme, a nie w katalogu szablonu: theme/default
ad 2. Ja jestem autorem szablonu :)
ad 3. Wyłączałem, włączałem, kasowałem i ni cholery (swoją drogą te dwa przyciski sa tak mało czytelne).

Wykasowałem wszystko. Wgram z ciekawości czysta wersję.

Newbie

Posts

Joined
Mon Feb 03, 2020 8:05 pm
Who is online

Users browsing this forum: No registered users and 4 guests