Post by quentin3d » Mon Feb 03, 2020 8:17 pm

OpenCart 3.0.3.2
Własny motyw zbudowany w oparciu o https://www.antropy.co.uk/blog/how-to-c ... t-3-theme/

Na localhost działa idealnie, po zainstalownaiu na serwerze developerskim działa idealnie. Dzisiaj zainstalowałem jednak na serwerze docelowym i:

Code: Select all

common/column_left
Fatal error: Uncaught Twig_Error_Loader: Unable to find template "common/column_left.twig" (looked into: /home/nazwa/domains/domena.pl/public_html/sklep/catalog/view/theme). in /home/nazwa/domains/domena.pl/public_html/sklep/system/library/template/Twig/Loader/Filesystem.php:215 Stack trace: #0 /home/nazwa/domains/domena.pl/public_html/sklep/system/library/template/Twig/Loader/Filesystem.php(139): Twig_Loader_Filesystem->findTemplate('common/column_l...') #1 /home/nazwa/domains/domena.pl/public_html/sklep/system/library/template/Twig/Environment.php(312): Twig_Loader_Filesystem->getCacheKey('common/column_l...') #2 /home/nazwa/domains/domena.pl/public_html/sklep/system/library/template/Twig/Environment.php(378): Twig_Environment->getTemplateClass('common/column_l...', NULL) #3 /home/nazwa/domains/domena.pl/storage/modification/system/library/template/twig.php(43): Twig_Environment->loadTemplate('common/column_l...') #4 /home/nazwa/domains/domena.pl/public_html/sklep/ in /home/nazwa/domains/domena.pl/public_html/sklep/system/library/template/Twig/Loader/Filesystem.php on line 215
Panel administracyjny działa. Czyściłem cache. Ściezki dostępu w pliku konfiguracyjnym wydają się OK.
Z tego co widze to Twig nie dysponuje dalszą ścieżką (nazwą katalogu z plikami theme):

Code: Select all

/home/nazwa/domains/domena.pl/public_html/sklep/catalog/view/theme [b][tutaj mu brakuje antropy/default][/b] /common/column_left
Jakieś sugestie?

Newbie

Posts

Joined
Mon Feb 03, 2020 8:05 pm
Who is online

Users browsing this forum: No registered users and 1 guest