Post by siteadvice » Fri Apr 12, 2013 11:39 pm

Add to Cart is not working with the latest version of IE10 on my Windows 7 computer.

This might not be a widespread issue, but if it's happened to me, you can bet I'm not the only one.

I first noticed it when setting up a version of my own, but I get exactly the same result when I view the demo on the Opencart website (http://demo.opencart.com/index.php?route=common/home)

I can't add anything to the shopping cart at all.

It doesn't work on the home page (featured product carousel) category pages or product pages.

It's fine in other browsers, of course.

HOWEVER - as soon as I switch IE10 to "compatibility view", the Add to Cart buttons start working.

But of course, most people won't ever figure that out and Compatibility View is not the default setting.

My version of IE is 10.0.9200.16540 Update Versions 10.0.4

I have searched the forums and this doesn't appear to be a known bug.

Any thoughts, people?

inframes.com Website Design with Opencart, Coldfusion, Railo and Concrete5


User avatar
New member

Posts

Joined
Mon Oct 24, 2011 8:12 pm

Post by siteadvice » Mon Apr 15, 2013 1:24 am

I have come up with a workaround for this problem.

Add this code immediately after the opening <head> tag before any other meta tags:

Code: Select all

<?php if(strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE 10.') !== false) { ?>
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9">
<?php } ?>

inframes.com Website Design with Opencart, Coldfusion, Railo and Concrete5


User avatar
New member

Posts

Joined
Mon Oct 24, 2011 8:12 pm

Post by ronnieb » Fri May 10, 2013 9:49 pm

on which file ?

New member

Posts

Joined
Tue May 24, 2011 3:44 pm

Post by AliceH » Fri Nov 21, 2014 3:44 pm

Good Question. On which file?

https://www.embroidery-allsorts.com/


User avatar
Active Member

Posts

Joined
Sun Jan 09, 2011 11:00 am
Location - Australia
Who is online

Users browsing this forum: No registered users and 12 guests