Page 1 of 1

Product Tags Search don't work

Posted: Sat Mar 02, 2013 7:34 pm
by R3aver
Hi,

When I click a product tag I get no results for search, any idea? I have Opencart 1.5.5.1.

Thanks!

Re: Product Tags Search don't work

Posted: Sat Mar 02, 2013 8:46 pm
by Johnathan
I just found this bug the other day. It's fixed in the next version of OpenCart that will be released, but if you want to fix it now, make this edit:

Code: Select all

IN:
/catalog/controller/product/search.php

REPLACE ALL INSTANCES OF:
['filter_tag']

WITH:
['tag']

Re: Product Tags Search don't work

Posted: Sat Mar 02, 2013 10:26 pm
by cheepnis
Should this line (#207) remain the same or should it be changed as well?

Code: Select all

'filter_tag'          => $tag, 

Re: Product Tags Search don't work

Posted: Sun Mar 03, 2013 8:09 pm
by Johnathan
It should remain the same.

Re: Product Tags Search don't work

Posted: Sun Mar 03, 2013 8:20 pm
by cheepnis
Thanks!

Re: Product Tags Search don't work

Posted: Sat Oct 05, 2013 1:57 am
by nnnhi
not working on 1.5.4.1 :(

Re: Product Tags Search don't work

Posted: Sat Oct 05, 2013 3:06 am
by Johnathan
This fix is for 1.5.5.x only.

Re: Product Tags Search don't work

Posted: Thu Nov 21, 2013 4:45 pm
by garywinner
I am using 1.5.6 OC.
When I click on the tag, it comes with result of product with matched tag.
This search don't include the product name?

for example, I click on "apple" tag.
product "green apple" is not shown.

Thanks.

Re: Product Tags Search don't work

Posted: Fri Nov 22, 2013 12:37 am
by Johnathan
When you click a tag, only products with that specific tag are searched. If you want the "Green Apple" product to be found, you'll need to tag it with "apple"

Re: Product Tags Search don't work

Posted: Tue Jan 28, 2014 9:13 am
by DragonJ
This fix isn't working for my v1.5.5.1 installation. I suppose I should have posted here first. Without thinking I started a new topic. :-\ http://forum.opencart.com/viewtopic.php?f=20&t=118636

Re: Product Tags Search don't work

Posted: Mon Jul 21, 2014 7:29 pm
by bakku
Thank you for this fix (1.5.5.1) O0

Re: Product Tags Search don't work

Posted: Fri Feb 27, 2015 9:52 pm
by Agathon
Is there any solution on 1.5.4.1 version ?

*** Finally i found solution here http://forum.opencart.com/viewtopic.php?f=20&t=84599