Page 1 of 1

[SOLVED] help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 1:38 am
by world-of-satellite
Anyone able to help with this please?

Cart version I'm using is 1.5.3.1, upgrade right now is not really an option due to theme etc..

Not sure when this started. I'm getting wrong unit rates values when a customer purchased more than one item. Single goods are fine. See screenshots attached. I do not understand why the rates are wrong when a customer orders 2 or more of the same item.

The sub-total, VAT and Total are all correct. Unit price and line total are wrong.

Anyone please able to help with this?

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 1:39 am
by world-of-satellite
Another attachement.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 2:04 am
by world-of-satellite
Another issue I've found is that if any discounted rates are set for volume quantities they are not being picked up.

For instance I have a product that is £5 each. I've set a discount that if 5 units are purchased it becomes £4.50 each. The standard rate of £5 is still being used.

Desperate for help with this one please.

I'll pay for whoever can fix.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 2:17 am
by world-of-satellite
Cart version I'm using is 1.5.3.1, upgrade right now is not really an option due to theme etc..

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 4:32 am
by world-of-satellite
This issue is something to do with VAT.

The unit rate of the TM-5402 in screenshots above is £115.8333 + VAT.

So it looks the unit rate when you view an order is adding 20% for a single item, then 20% for two items.

If I edit an order all the rates are correct. The issue only occurs when simply viewing an order and printing an invoice.

Heres a screenshot from edit an order.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 4:40 am
by world-of-satellite
On my set site I've set one Geozone for United kingdom > All zones.

I've got one UK VAT Tax rate 20% for UK.

I've got one UK tax class set to store address which is UK.

Sreenshot of Settings > Option > Taxes attached.

I'm willing to pay for whoever can fix this please.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 1:37 pm
by world-of-satellite
I've just removed all products from my test site and remove all geo zones, tax classes etc..

Setup one geo zone for UK, one VAT rate.

Add one test product, basic not options etc...

The problem as stated above is only occurring when viewing an order or printing invoice. Insert and edit order show correct figures.

This is what is happen: -

Single item: -

Product selling price 1.00 + VAT
View order or invoice shows unit rate as 1.20, should show as £1.00. Line Total = £1.20, should be £1.00.
VAT should not be added to unit rate.

Two of the same item: -
Product selling price 1.00 + VAT
View order or invoice shows unit rate as 1.40, should show as £1.00. Line Total = £2.80, should be £2.00
40% VAT added to unit rate/

Three of the same item: -
Product selling price 1.00 + VAT
View order or invoice shows unit rate as 1.60, should show as £1.00. Line Total = £4.80, should be £3.00
60% VAT added to unit rate.

This pattern carries on throughout, adding an additional 20%, if 5 items are added, 100% VAT is added to unit rate.

Sub total, VAT and Invoice/order total are 100% correct though. These are calculated from the correct prices, not the unit rates shown on view order or invoice. See posted screenshots above.

Please can anyone provide commercial support to fix this issue.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 2:44 pm
by world-of-satellite
After a sleepless night I found the fix for the VAT issue http://forum.opencart.com/viewtopic.php ... 20#p329382 Thank you to ADD Creative for posting the fix, I should have looked in the bug thread 1st ::)

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 2:47 pm
by world-of-satellite
Fix for post three found here http://forum.opencart.com/viewtopic.php?f=131&t=38147 Thank you to UKsitebuilder, woohoo all sorted again :)

Now need some sleep lol!

Re: Urgent help needed, units rates wrong for multiple items

Posted: Tue Aug 21, 2012 10:26 pm
by bigchili
You just had an entire conversation with yourself in this thread. :crazy:

Awesome.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Wed Aug 22, 2012 12:42 pm
by world-of-satellite
world-of-satellite wrote:After a sleepless night I found the fix for the VAT issue http://forum.opencart.com/viewtopic.php ... 20#p329382 Thank you to ADD Creative for posting the fix, I should have looked in the bug thread 1st ::)
Still need help on this please.

This fix only works if the order is put through manually through the back-end. If a customer places an order it still comes through wrong. We need to then manually edit the order, deleting the products and re-adding them manually.

Anyone please?

Re: Urgent help needed, units rates wrong for multiple items

Posted: Thu Aug 23, 2012 10:34 am
by Qphoria
I cannot reproduce this. I see the same thing with both normal confirm and uber checkout.They are using the same base code for order saving.

The order is stored in YOUR default currency set in your store.
Perhaps you edited the order or something with the order editor and it is to blame
I tried both standard and uber with default currency of USD
I added 5 x $100 items to my cart
Switched to GBP which was like 68.83
When I checkout, both show me the order in the backend as 5 x 100 which is correct because you, as the admin, would want to see totals in your own currency to know how much you made.

So I'm guessing maybe a bug in the order edit or something

Re: Urgent help needed, units rates wrong for multiple items

Posted: Thu Aug 23, 2012 12:33 pm
by world-of-satellite
Qphoria wrote:I cannot reproduce this. I see the same thing with both normal confirm and uber checkout.They are using the same base code for order saving.

The order is stored in YOUR default currency set in your store.
Perhaps you edited the order or something with the order editor and it is to blame
I tried both standard and uber with default currency of USD
I added 5 x $100 items to my cart
Switched to GBP which was like 68.83
When I checkout, both show me the order in the backend as 5 x 100 which is correct because you, as the admin, would want to see totals in your own currency to know how much you made.

So I'm guessing maybe a bug in the order edit or something
Manual order edit and insert order in backend are fine now.

As I've posted this bug is present in my cart using UBER Checkout when a customer places a multiple order through the front end using UBER checkout. With uber disabled all is fine. Your more than welcome to have access to my cart, but the bug is 100% there and reproducible.

Re: Urgent help needed, units rates wrong for multiple items

Posted: Thu Aug 23, 2012 12:54 pm
by world-of-satellite
Examples of the orders in the backend: -

Correct order with standard checkout
correct-order.PNG

correct-order.PNG (19.34 KiB) Viewed 4292 times

wrong order with UBER Checkout
wrong-order.PNG

wrong-order.PNG (19.13 KiB) Viewed 4292 times

Can be 100% reproduced, as I've said I'm more than willing to give you access Q.

Neither of the above orders have been edited, they are EXACTLY how the come through to the back end.

As I've already posted above this is what is happens: -

Single item: -

Product selling price 1.00 + VAT
View order or invoice shows unit rate as 1.20, should show as £1.00. Line Total = £1.20, should be £1.00.
VAT should not be added to unit rate.

Two of the same item: -
Product selling price 1.00 + VAT
View order or invoice shows unit rate as 1.40, should show as £1.00. Line Total = £2.80, should be £2.00
40% VAT added to unit rate/

Three of the same item: -
Product selling price 1.00 + VAT
View order or invoice shows unit rate as 1.60, should show as £1.00. Line Total = £4.80, should be £3.00
60% VAT added to unit rate.

This pattern carries on throughout, adding an additional 20%, if 5 items are added, 100% VAT is added to unit rate.

Sub total, VAT and Invoice/order total are 100% correct though. These are calculated from the correct prices, not the unit rates shown on view order or invoice. See posted screenshots above.

The fix posted here http://forum.opencart.com/viewtopic.php ... 20#p329382 fixed the backend issue, but this bug is still ocuring with UBER enabled

Re: Urgent help needed, units rates wrong for multiple items

Posted: Thu Aug 23, 2012 1:08 pm
by world-of-satellite
I've found the issue what is causing this Q.

Uber Original: -

Code: Select all

				
				//'tax'        => $this->tax->getTax($product['price'], $product['tax_class_id']),
				'tax'        => $xtax,
My change that fixes the issue: -

Code: Select all

				'tax'        => $this->tax->getTax($product['price'], $product['tax_class_id']),
				//'tax'        => $xtax,

Re: Urgent help needed, units rates wrong for multiple items

Posted: Fri Aug 24, 2012 2:12 am
by world-of-satellite
Any comment on the above fix Q?

Re: Urgent help needed, units rates wrong for multiple items

Posted: Sat Aug 25, 2012 4:16 pm
by world-of-satellite
@ Q i'm rather disappointed that you couldn't comment on the above, considering I purchased your UBER checkout and my bug report was deleted from your extensions release.

Is this going to be fixed for future versions?

Re: [SOLVED] help needed, units rates wrong for multiple ite

Posted: Sun Aug 26, 2012 6:17 pm
by world-of-satellite
Marked solved, but still no help or comment ::)

Re: [SOLVED] help needed, units rates wrong for multiple ite

Posted: Thu Nov 29, 2012 7:36 pm
by R_D
Hi,

I encounter this problem also, I don't have UBER but do you know how I can get the rates correct?

Thanks!

Re: Urgent help needed, units rates wrong for multiple items

Posted: Fri Nov 30, 2012 3:25 am
by R_D
solved