Post by suhanto » Mon Oct 05, 2009 9:10 pm

I found the email content is rather messy when there are multiple products in there. This happens when customer buy some products, and he/she will get email confirmation. Example email:
Produk:
1x Jualan Online dengan Quick.Cart (PDF) (Artikel (PDF)) Rp2.000 1x Jualan Online dengan PrestaShop (PDF) (Artikel (PDF)) Rp2.000 1x Cara Instal Magento di Komputer Sendiri (PDF) (Artikel (PDF)) Rp3.000 1x Magento Commerce untuk Jualan Online (PDF) (Artikel (PDF)) Rp2.000 1x Cara Instal WordPress di Komputer Sendiri (PDF) (Artikel (PDF)) Rp5.000 1x Mengubah Tema Standar WordPress (PDF) (Artikel (PDF)) Rp2.000 1x Cara Pakai WordPress untuk Jualan Online (PDF) (Artikel (PDF)) Rp2.000 1x Jualan Online dengan WordPress (PDF) (Artikel (PDF)) Rp2.000
I was testing this, login as customer and buy 10 products from my online store. Look at the email content above, we don't know how many products in there because all are written as single line.

http://suhanto.net


User avatar
New member

Posts

Joined
Sat Sep 19, 2009 2:57 pm
Location - Jakarta, Indonesia

Post by Qphoria » Mon Oct 05, 2009 10:19 pm

That shouldn't be how it comes out.

I get:
Payment Method:
PayPal

Shipping Method:
Free Shipping

Products:
1x Product 1 (product_1) $5.00
1x Product 2 (product_2)$25.00
1x Product 3 (product_3)$20.00
1x Product 4 (product_4)$30.00

Totals:
Sub-Total: $80.00
Free Shipping: $0.00
Total: $80.00

I may have improved it with the enhanced email mod, but even before that they've always listed.
http://forum.opencart.com/viewtopic.php?f=23&t=6314

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by suhanto » Tue Oct 06, 2009 8:47 am

Yes I know source code doesn't lie. I saw "\n" in the source code of email content to mark the end of line of every product in product listing.

And you are right. That's the output that should be displayed.

This is a kind of weird, because I got it messed-up. I'm showing you the email content in an image:
Image

But then I suspect that the problem doesn't belong to OpenCart, but somewhere else. My primary suspect is my Outlook 2007.

Then I opened my gmail account to view the email inside its browser email viewer. And it look good.

So, it's my Outlook 2007 that doesn't display the text message properly.

:)

http://suhanto.net


User avatar
New member

Posts

Joined
Sat Sep 19, 2009 2:57 pm
Location - Jakarta, Indonesia

Post by suhanto » Tue Oct 06, 2009 8:53 am

It's clear now that Outlook 2007 threat some line-breaks as extra line-breaks, so it removes all extra line-breaks automatically.

Now I can see the proper message in Outlook 2007 by restoring all extra line-breaks.

Hmmm, it's a kind of weird behavior of Outlook 2007, trying to act smart, but it turns out to be so dumb.

:D

http://suhanto.net


User avatar
New member

Posts

Joined
Sat Sep 19, 2009 2:57 pm
Location - Jakarta, Indonesia
Who is online

Users browsing this forum: No registered users and 13 guests