Post by ADD Creative » Thu Nov 22, 2012 11:01 pm

Daniel wrote:update to the latest colorbox
Still a problem with the latest version. The datepicker can also trigger the bug.

I believe you can see the bug in IE tester (http://www.my-debugbar.com/wiki/IETester/HomePage) as that uses older versions of IE7 and IE8.

I have made a pull request that shows another way to workaround it. https://github.com/opencart/opencart/pull/248

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by ADD Creative » Thu Nov 22, 2012 11:03 pm

rafaelbxavier wrote:Anyone knows how to use the code below at IE 6 to 8 without problem:

<script type="text/javascript"><!--
$('.colorbox').colorbox({
overlayClose: true,
opacity: 0.5
});
//--></script>

What is the correct code to use with Internet Explorer without problems?

Thanks.

Regards.
Rafael
Try

Code: Select all

<script type="text/javascript"><!--
$(document).ready(function() {
	$('.colorbox').colorbox({
		overlayClose: true,
		opacity: 0.5
	});
});
//--></script>

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by rph » Fri Nov 23, 2012 12:48 am

ADD Creative wrote:
Daniel wrote:update to the latest colorbox
Still a problem with the latest version. The datepicker can also trigger the bug.

I believe you can see the bug in IE tester (http://www.my-debugbar.com/wiki/IETester/HomePage) as that uses older versions of IE7 and IE8.

I have made a pull request that shows another way to workaround it. https://github.com/opencart/opencart/pull/248
Has anyone tested this on a VM (official IE Compatibility VHDs)? I use IETester too but it's my understanding it can't be entirely trusted on issues like this.

A also wonder if a "see no evil" approach is best for users with insecure browsers.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by OpenCart Addons » Fri Nov 23, 2012 12:51 am

ADD Creative wrote:
rafaelbxavier wrote:Anyone knows how to use the code below at IE 6 to 8 without problem:

<script type="text/javascript"><!--
$('.colorbox').colorbox({
overlayClose: true,
opacity: 0.5
});
//--></script>

What is the correct code to use with Internet Explorer without problems?

Thanks.

Regards.
Rafael
Try

Code: Select all

<script type="text/javascript"><!--
$(document).ready(function() {
	$('.colorbox').colorbox({
		overlayClose: true,
		opacity: 0.5
	});
});
//--></script>
Thanks a lot for the help! I was having issues with IE not adding products to the cart when on the product page (v1.5.4.1). Replaced the colorbox script mentioned in your post and everything is working again.

Cheers,
Joel.

Canada's Leading Expert In OpenCart Development & Certified OpenCart Development Partner Image


User avatar
Active Member

Posts

Joined
Thu Nov 24, 2011 10:51 am
Location - Canada

Post by rph » Fri Nov 23, 2012 4:25 pm

Looks like that confirms it. IE is just never going to stop being a problem. :bang:

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by ADD Creative » Fri Nov 23, 2012 6:25 pm

Looks like the official IE VHDs are patched so should not have the error, although the Visa IE7 one (over 4GB download) might be worth testing. Only patched to March 2011 which might late enough not to suffer from the problem.

I've test on an actual XP SP3 PC that somehow managed not to get the latest IE7 patches via Windows Update and took 4 goes manually install it, the Windows 7 Pro XP Mode VHD and a XP SP3 in VirtualBox on a Mac. All work fine if fully patched, but if missing the more recent versions of the Cumulative Security Update for Internet Explorer, all have problems.

So it all comes down to how many customers you think may have unpatched versions of IE. We had a few calls from customers trying yo use IE6 which our payment gateway doesn't support. ;D
Agreed that IE will always be a problem. With no IE9 on XP I can see IE8 becoming the new IE6. :bang:

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by rph » Fri Nov 23, 2012 7:47 pm

ADD Creative wrote:We had a few calls from customers trying yo use IE6 which our payment gateway doesn't support. ;D
When I get forwarded a call from someone with a problem on a website it's almost guaranteed to not be fun.

Me: "Can you tell me what internet browser you're using? Internet Explorer, Firefox, Chrome, Safari?"

User: "I use Google."

Me: "Google Chrome? Does the icon you click to get on the internet look like a little red, green, and yellow ball?"

User: "No, I use Google."

Me: "Can you tell me if you have Windows or a Macintosh computer?"

User: "I don't know."

Me: "Look on your desktop. Did you click on the big blue 'E' to get here?"

User: "Yes, that's the one!"

:bang:

I swear some days it's just a race to the bottom.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by Daniel » Tue Dec 11, 2012 2:23 pm

isd this problem still happing even wiht the fix or not?

i want to cross this off the bug tracker

https://github.com/opencart/opencart/issues/247

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by yuhong » Sun Jan 20, 2013 8:09 am

FYI, the IE cumulative patch that fixed this is MS10-018:
http://support.microsoft.com/kb/980182
http://support.microsoft.com/kb/974322
More details on the problem at the IEBlog:
http://blogs.msdn.com/b/ie/archive/2008 ... orted.aspx

Newbie

Posts

Joined
Sun Jan 20, 2013 7:59 am
Who is online

Users browsing this forum: No registered users and 4 guests