Post by weedecs » Sat Feb 11, 2012 8:11 pm

Dear Opencart Administrators,

I have three 1.5.1.3 opencart website in hosted 2 different companies.

And all of these website do not send mails to customers when a account created, an order placed or a newsletter sended.

But receive mails to admin by account creations, placing orders or using contact form.

All 3 websites' scripts downloaded from opencart.com and all features are working accept above problems.

I have 2 different websites too, using 1.4.9.x and they are all working on these subjects with just setting the general settings shop mail address on general tab.

I wrote this problem in this section because i think it is caused from this version or wrong written file and it is a general bug. Because there is so many topics about this subject for all 1.5.x versions.

Can you please tell me how to fix this problem/bug?

Web Design: http://www.websanati.com
Personel Blog: http://www.alperheper.com


User avatar
Newbie

Posts

Joined
Sat Feb 11, 2012 6:58 pm

Post by Renato Frota » Sun Feb 12, 2012 12:09 am

are you using MAIL() or SMTP?

SMTP actually means fsockopen() use and it's not allowed in some webhosts.

You can set MAIL and still fill the fields below to configure SMTP settings.

Leave the mail parameters field (the first field below mail protocol selecbox) BLANK unless you understand about mail headers.

New member

Posts

Joined
Wed Aug 31, 2011 1:21 pm

Post by weedecs » Sun Feb 12, 2012 4:35 pm

thanks for replying me Renato Frota

but i have tried both smtp and php and my host compitable both them.

fill the blanks as you told but there no any change at outgoing problems ??? ??? ???

Web Design: http://www.websanati.com
Personel Blog: http://www.alperheper.com


User avatar
Newbie

Posts

Joined
Sat Feb 11, 2012 6:58 pm

Post by weedecs » Sun Feb 12, 2012 6:13 pm

i think i have solve the problem

the problem causes from our server ip. my 2 different hotmail accounts couldn't get mails but gmail and yahoo get all mails without any problem

hotmail has been banned my hosting ip address

now i have post this subject to my hosting company and waiting for an solution or i will change my host...

Web Design: http://www.websanati.com
Personel Blog: http://www.alperheper.com


User avatar
Newbie

Posts

Joined
Sat Feb 11, 2012 6:58 pm

Post by i2Paq » Sun Feb 12, 2012 11:38 pm

Maybe you should smoke less weed O0

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Daniel » Tue Feb 14, 2012 1:38 pm

try the latest mail class from the svn.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 10 guests