Post by Daniel » Sat Nov 05, 2011 12:34 am

JohanKoers wrote:Hi,

There is a bug in the products/extra images. When i copy a product main image is copied right but extra images are not copied. Only the first letter of the path of file in copied. Ive tried a new install with new database and still same problem.
See sceenshot. http://www.hcl.nl/image.png
This error appears in log
2011-11-04 11:48:17 - PHP Notice: Error: Could not load library json! in /mnt/web9/63/28/52259528/htdocs/shop/vqmod/vqcache/vq2-system_engine_loader.php on line 24

Thanks,

Johan

just fixed this. will be on svn soon.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Qphoria » Sat Nov 05, 2011 1:11 am

werepair wrote:Hi, and thanks for the update,not sure if its a bug but i have the following errors in my error logs

2011-10-02 20:26:11 - PHP Notice: Undefined index: shipping_address_id in /home/wwwxxxxx/public_html/catalog/controller/checkout/shipping.php on line 11
2011-10-02 20:41:09 - PHP Notice: Undefined index: payment_address_id in /home/wwwxxxxx/public_html/catalog/controller/checkout/payment.php on line 11

THIS IS line 11

Code: Select all

$shipping_address = $this->model_account_address->getAddress($this->session->data['shipping_address_id']);
best regards
1. EDIT: catalog/controller/checkout/shipping.php

2. FIND:

Code: Select all

if ($this->customer->isLogged()) {
3. REPLACE WITH:

Code: Select all

if ($this->customer->isLogged() && isset($this->session->data['shipping_address_id'])) {
4. EDIT: catalog/controller/checkout/payment.php

5. FIND:

Code: Select all

if ($this->customer->isLogged()) {
6. REPLACE WITH:

Code: Select all

if ($this->customer->isLogged() && isset($this->session->data['payment_address_id'])) {

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by javiecastillo » Sat Nov 05, 2011 4:47 am

Daniel wrote:try reuploading the files. maybe something missing.
I have tried uploading the files again, but to no avail. I even tried deleting all of the theme files, downloading fresh OC install files, and then uploading them again.. didn't work. ???

Maybe all that's left is a completely new install? It would be a pain, but I don't want that to be the only solution... what if this happens again after I've finished adding all of the products? :crazy:

The sample page isn't working for you either, right? Do you have any suggestions for what might be missing?

Newbie

Posts

Joined
Fri Dec 31, 2010 2:27 am

Post by ecn » Sat Nov 05, 2011 3:24 pm

OPENCART 1.5.1.3
admin->system->settings->edit:

Notice: Error: Could not load model localisation/order_status! in /hsphere/local/home/braindumps1/ecn88.websitehostings.us/system/engine/loader.php on line 37

ecn
Newbie

Posts

Joined
Sat Nov 05, 2011 3:17 pm

Post by JNeuhoff » Sat Nov 05, 2011 7:30 pm

ecn wrote:OPENCART 1.5.1.3
admin->system->settings->edit:

Notice: Error: Could not load model localisation/order_status! in /hsphere/local/home/braindumps1/ecn88.websitehostings.us/system/engine/loader.php on line 37
It would be useful if you provided more details as nobody else can reproduce your error.

This is true with many bug reports here.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Maansy » Sat Nov 05, 2011 11:45 pm

not a bug. its just inline style in .tpl file thing

in register.tpl line 76
better we use

Code: Select all

<div class="pagination">
instead of the inline style

Code: Select all

<div style="clear: both; padding-top: 15px; border-top: 1px solid #EEEEEE;">

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by ccM » Mon Nov 07, 2011 10:32 am

No big deal but the 'remove' buttons on the returns page are not showing up. Just missing the span tags to make the right hand part of the button visible.

In catalog/view/theme/default/template/account/return_form.tpl

Around line 121 Find:

Code: Select all

<div class="return-remove"><a onclick="$('#return-product-row<?php echo $return_product_row; ?>').remove();" class="button"><?php echo $button_remove; ?></a></div>
Replace with:

Code: Select all

<div class="return-remove"><a onclick="$('#return-product-row<?php echo $return_product_row; ?>').remove();" class="button"><span><?php echo $button_remove; ?></span></a></div>
Around line 177 Find:

Code: Select all

html += '    <div class="return-remove"><a onclick="$(\'#return-product-row' + return_product_row + '\').remove();" class="button"><?php echo $button_remove; ?></a></div>';
Replace with:

Code: Select all

html += '    <div class="return-remove"><a onclick="$(\'#return-product-row' + return_product_row + '\').remove();" class="button"><span><?php echo $button_remove; ?></span></a></div>';
Sorry if this has already been pointed out somewhere else - couldn't find it. :)

ccM
New member

Posts

Joined
Fri Aug 19, 2011 6:51 am
Location - QLD, Australia

Post by Maansy » Mon Nov 07, 2011 3:48 pm

today i saw this error on top of the product page:

Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31


knowing i have tax turned off for all products

opencart v1.5.1.3.1 fresh copy + vqmods (but nothing for tax system)

any clue?

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by i2Paq » Tue Nov 08, 2011 1:55 am

Maansy wrote:today i saw this error on top of the product page:

Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31


knowing i have tax turned off for all products

opencart v1.5.1.3.1 fresh copy + vqmods (but nothing for tax system)

any clue?
What steps to (re)-produce this as it does not happen to me.

Clean install + Dutch language.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Maansy » Tue Nov 08, 2011 4:00 am

i2Paq wrote:
Maansy wrote:today i saw this error on top of the product page:

Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31


knowing i have tax turned off for all products

opencart v1.5.1.3.1 fresh copy + vqmods (but nothing for tax system)

any clue?
What steps to (re)-produce this as it does not happen to me.

Clean install + Dutch language.
Just when I view a product, only once in a while.

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by neyzel » Tue Nov 08, 2011 7:43 am

Hello, again, the comma.


admin\model\sale\order.php

Line: 348
$sort_data = array(
'o.order_id',
'customer',
'status',
'o.date_added',
'o.date_modified',
'o.total',
);

Newbie

Posts

Joined
Sun Sep 11, 2011 2:37 am

Post by i2Paq » Tue Nov 08, 2011 3:08 pm

Maansy wrote:
i2Paq wrote: What steps to (re)-produce this as it does not happen to me.

Clean install + Dutch language.
Just when I view a product, only once in a while.
I cannot reproduce this, could be a vQmod issue(?).

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Maansy » Tue Nov 08, 2011 3:20 pm

i2Paq wrote:
Maansy wrote:
i2Paq wrote: What steps to (re)-produce this as it does not happen to me.

Clean install + Dutch language.
Just when I view a product, only once in a while.
I cannot reproduce this, could be a vQmod issue(?).
it might be a vqmod issue.

today i saw lots of these:

2011-11-07 7:45:03 - PHP Notice: Undefined index: country_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 17
2011-11-07 7:45:03 - PHP Notice: Undefined index: zone_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 17
2011-11-07 7:45:03 - PHP Notice: Undefined index: country_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 31
2011-11-07 7:45:03 - PHP Notice: Undefined index: zone_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 31


and few of:

2011-11-08 5:00:14 - PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cookie - headers already sent by (output started at /home/xxx/public_html/opencartstuff.com/index.php:49) in /home/xxx/public_html/opencartstuff.com/system/library/session.php on line 11
2011-11-08 5:00:14 - PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /home/xxx/public_html/opencartstuff.com/index.php:49) in /home/xxx/public_html/opencartstuff.com/system/library/session.php on line 11
20


and:

2011-11-08 5:00:14 - PHP Notice: Undefined index: HTTP_HOST in /home/xxx/public_html/opencartstuff.com/system/library/currency.php on line 45
2011-11-08 5:00:14 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/opencartstuff.com/index.php:49) in /home/xxx/public_html/opencartstuff.com/system/library/currency.php on line 45

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by Daniel » Tue Nov 08, 2011 5:48 pm

Maansy wrote:today i saw this error on top of the product page:

Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31


knowing i have tax turned off for all products

opencart v1.5.1.3.1 fresh copy + vqmods (but nothing for tax system)

any clue?

this only happens if you delete a customer while logged in as this customer. i fixed this on svn but this will not show to normal customers.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Tue Nov 08, 2011 5:50 pm

Maansy wrote:

it might be a vqmod issue.

today i saw lots of these:

2011-11-07 7:45:03 - PHP Notice: Undefined index: country_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 17
2011-11-07 7:45:03 - PHP Notice: Undefined index: zone_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 17
2011-11-07 7:45:03 - PHP Notice: Undefined index: country_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 31
2011-11-07 7:45:03 - PHP Notice: Undefined index: zone_id in /home/xxx/public_html/opencartstuff.com/system/library/tax.php on line 31


and few of:

2011-11-08 5:00:14 - PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cookie - headers already sent by (output started at /home/xxx/public_html/opencartstuff.com/index.php:49) in /home/xxx/public_html/opencartstuff.com/system/library/session.php on line 11
2011-11-08 5:00:14 - PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /home/xxx/public_html/opencartstuff.com/index.php:49) in /home/xxx/public_html/opencartstuff.com/system/library/session.php on line 11
20


and:

2011-11-08 5:00:14 - PHP Notice: Undefined index: HTTP_HOST in /home/xxx/public_html/opencartstuff.com/system/library/currency.php on line 45
2011-11-08 5:00:14 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/opencartstuff.com/index.php:49) in /home/xxx/public_html/opencartstuff.com/system/library/currency.php on line 45

HTTP_HOST is if you visit your site from an ip. set some redirect in your .htaccess.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by i2Paq » Wed Nov 09, 2011 3:13 am

Maansy wrote:today i saw this error on top of the product page:

Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31


knowing i have tax turned off for all products

opencart v1.5.1.3.1 fresh copy + vqmods (but nothing for tax system)

any clue?


I have seen this to!

I was working on a store from a Dutch owner and there it was!
Plus some more.

Code: Select all

Notice: Undefined index: country_id in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/library/tax.php on line 23Notice: Undefined index: zone_id in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/library/tax.php on line 23

Code: Select all

Warning: Cannot modify header information - headers already sent by (output started at /home/deb52024/domains/horlogevoorjou.nl/public_html/index.php:100) in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/engine/controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /home/deb52024/domains/horlogevoorjou.nl/public_html/index.php:100) in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/engine/controller.php on line 29
I think it has to do with rights on folders and files or an incorrect server setup/
This because I have no such issues on my server/installs[/s]

BUG!

When a customer has NO address in his/her account this error will occur during checkout etc.!
Instead there should be a message saying: "no order/shipping address".

Probably an account created via the Admin.

Make also sure your GEO-zones, VAT and Shipping zones etc. are setup correctly or you will have another issue that checkout will not proceed AFTER step 3 with that same account.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by cantykiwi » Wed Nov 09, 2011 4:29 am

i2Paq wrote:
Maansy wrote:today i saw this error on top of the product page:

Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 17
Notice: Undefined index: country_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31
Notice: Undefined index: zone_id in /home/xxxx/public_html/opencartstuff.com/system/library/tax.php on line 31


knowing i have tax turned off for all products

opencart v1.5.1.3.1 fresh copy + vqmods (but nothing for tax system)

any clue?


I have seen this to!

I was working on a store from a Dutch owner and there it was!
Plus some more.

Code: Select all

Notice: Undefined index: country_id in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/library/tax.php on line 23Notice: Undefined index: zone_id in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/library/tax.php on line 23

Code: Select all

Warning: Cannot modify header information - headers already sent by (output started at /home/deb52024/domains/horlogevoorjou.nl/public_html/index.php:100) in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/engine/controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /home/deb52024/domains/horlogevoorjou.nl/public_html/index.php:100) in /home/deb52024/domains/horlogevoorjou.nl/public_html/system/engine/controller.php on line 29
I think it has to do with rights on folders and files or an incorrect server setup/
This because I have no such issues on my server/installs[/s]

BUG!

When a customer has NO address in his/her account this error will occur during checkout etc.!
Instead there should be a message saying: "no order/shipping address".

Probably an account created via the Admin.

Make also sure your GEO-zones, VAT and Shipping zones etc. are setup correctly or you will have another issue that checkout will not proceed AFTER step 3 with that same account.
Actually was having the same problem myself, and thanks to this thread solved my issue. In my case the only thing missing was the postcode from the default address which is a required field. I put that in and it then worked correctly, but was scratching my head for a while to find out why it was not working. This was an upgrade from v1.4.9.6 but is still on my test server. Agreed some sort of error message would have been nice!

New member

Posts

Joined
Mon Sep 13, 2010 12:37 pm

Post by MaxxTechz-Erick » Wed Nov 09, 2011 5:15 am

Hi wen i go to
System>Localisation>Taxes>Tax Classes
i get and cant edit tax classes :/
Notice: Error: Unknown column 'title' in 'order clause'
Error No: 1054
SELECT * FROM techno2_tax_class ORDER BY title ASC LIMIT 0,20 in /home/techno2/public_html/opencart/system/database/mysql.php on line 49


Posts

Joined
Wed Nov 09, 2011 4:58 am

Post by i2Paq » Wed Nov 09, 2011 5:15 am

i2Paq wrote: BUG!

When a customer has NO address in his/her account this error will occur during checkout etc.!
Instead there should be a message saying: "no order/shipping address".

Probably an account created via the Admin.

Make also sure your GEO-zones, VAT and Shipping zones etc. are setup correctly or you will have another issue that checkout will not proceed AFTER step 3 with that same account.

I see that this is solved in the SVN 1.5.2!

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by i2Paq » Wed Nov 09, 2011 5:16 am

MaxxTechz-Erick wrote:Hi wen i go to
System>Localisation>Taxes>Tax Classes
i get and cant edit tax classes :/
Notice: Error: Unknown column 'title' in 'order clause'
Error No: 1054
SELECT * FROM techno2_tax_class ORDER BY title ASC LIMIT 0,20 in /home/techno2/public_html/opencart/system/database/mysql.php on line 49
I cannot reproduce this.

Clean install or upgrade?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands
Who is online

Users browsing this forum: No registered users and 8 guests