Page 10 of 11

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 1:13 am
by opencartisalright
Daniel wrote:
the only pages changed are the install.sql, the product compare controller and the length class.
Could you give me the file paths to both the product compare controller and the length class? I would like to update those files manually but not sure where they are located.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 2:19 am
by eka7a
oc 1.5.1.1 catalog/model/catalog/product.php

written twice

Code: Select all

'model'            => $query->row['model'],
'model'            => $query->row['model'],

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 2:29 am
by Daniel
eka7a wrote:oc 1.5.1.1 catalog/model/catalog/product.php

written twice

Code: Select all

'model'            => $query->row['model'],
'model'            => $query->row['model'],
thx

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 3:00 am
by tyjthomas
There were some previous reports in the 1.5.0.5 bug thread about the CSS formatting not coming through to some email carriers. Was this a bug (and if so, was there a way to fix it)? If so, did it carry over to 1.5.1? I have been testing with gmail -- it displays the information but strips the formatting. I am using 1.5.1. Sorry if I'm wasting anyone's time.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 4:41 am
by eka7a
reward_points.png

reward_points.png (89.44 KiB) Viewed 7070 times

showing the wrong reward points on shopping cart page

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 7:34 am
by Xsecrets
eka7a wrote: showing the wrong reward points on shopping cart page
actually no it's showing the correct one. It's showing the cost reward points not the earned since you are in the shopping cart where you intend to purchase the item so it shows you how many reward points it would cost to purchase it.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 8:40 am
by eka7a
Xsecrets wrote:
eka7a wrote: showing the wrong reward points on shopping cart page
actually no it's showing the correct one. It's showing the cost reward points not the earned since you are in the shopping cart where you intend to purchase the item so it shows you how many reward points it would cost to purchase it.
This may mislead customers. I think earned points will be more accurate to show

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 9:35 am
by merry
Fresh 1.5.1.1 install AND visible in demo: http://demo.opencart.com/index.php?rout ... e/register

The affiliate "I have read and agree to the ABOUT US" has crept back in, linking to index.php?route=information/information/info&information_id=4

Should be "I have read and agree to the TERMS AND CONDITIONS" and link to index.php?route=information/information/info&information_id=5.

Kerry

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 11:30 am
by amdev
I use svn At revision: 503
Goto admin->catalog->Options and Edit.
Get this error

Code: Select all

Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154
I think that image field in option_value table was missing.

Thanks and sorry for my bad english.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 11:59 am
by Daniel
amdev wrote:I use svn At revision: 503
Goto admin->catalog->Options and Edit.
Get this error

Code: Select all

Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154Notice: Undefined index: image in C:\AppServ\www\151\upload\admin\model\catalog\option.php on line 154
I think that image field in option_value table was missing.

Thanks and sorry for my bad english.

you are using the svn version. do not report bugs here. report them on google code.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 12:00 pm
by Daniel
Xsecrets wrote:
eka7a wrote: showing the wrong reward points on shopping cart page
actually no it's showing the correct one. It's showing the cost reward points not the earned since you are in the shopping cart where you intend to purchase the item so it shows you how many reward points it would cost to purchase it.
no i think they are right it should be reward points earned maybe.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 12:19 pm
by eka7a
merry wrote:Fresh 1.5.1.1 install AND visible in demo: http://demo.opencart.com/index.php?rout ... e/register

The affiliate "I have read and agree to the ABOUT US" has crept back in, linking to index.php?route=information/information/info&information_id=4

Should be "I have read and agree to the TERMS AND CONDITIONS" and link to index.php?route=information/information/info&information_id=5.

Kerry
admin/system/setting/ edit your store Options Tab

information page select for Affiliate Terms

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 12:30 pm
by opencartisalright
Daniel updated the database in SVN r504

Could someone tell me how to insert a row into a table in mysql? I know I should use the INSERT command, but i'm not sure the correct syntax to use.

This is what I need to do.

Insert

Code: Select all

`image` varchar(255) COLLATE utf8_bin NOT NULL,
into table

Code: Select all

`oc_option_value`
Any help would be greatly appreciated. (Basically I'm looking for someone to give me the SQL command to run in my database :) )

Thanks!

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 12:53 pm
by opencartisalright
Ok, nevermind about the above. I just ran the following command in myPHPadmin and it seems it worked. I had no idea if it would or not, so I was crossing my fingers my db wouldn't burst into flames. ;D

Code: Select all

DROP TABLE IF EXISTS `oc_option_value`;
CREATE TABLE `oc_option_value` (
  `option_value_id` int(11) NOT NULL AUTO_INCREMENT,
  `option_id` int(11) NOT NULL,
  `image` varchar(255) COLLATE utf8_bin NOT NULL,
  `sort_order` int(3) NOT NULL,
  PRIMARY KEY (`option_value_id`)
) ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

--
-- Dumping data for table `oc_option_value`
--

INSERT INTO `oc_option_value` (`option_value_id`, `option_id`, `sort_order`) VALUES
(43, 1, 3),
(32, 1, 1),
(45, 2, 4),
(44, 2, 3),
(42, 5, 4),
(41, 5, 3),
(39, 5, 1),
(40, 5, 2),
(31, 1, 2),
(23, 2, 1),
(24, 2, 2),
(46, 11, 1),
(47, 11, 2),
(48, 11, 3);

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 12:56 pm
by opencartisalright
Is there a difference between the OC 1.5.1.1.zip file that Daniel uploaded 15 hours ago and the one qphoria uploaded 7 hours ago?

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 1:02 pm
by eka7a
catalog page -> index.php?route=feed/google_base

Code: Select all

<b>Notice</b>: Undefined index: weight_class in <b>C:\wamp\www\oc1511\catalog\controller\feed\google_base.php</b> on line <b>78</b><b>Notice</b>: Undefined index: weight_class in <b>C:\wamp\www\oc1511\catalog\controller\feed\google_base.php</b> on line <b>78</b><b>Notice</b>: Undefined index: weight_class in <b>C:\wamp\www\oc1511\catalog\controller\feed\google_base.php</b> on line <b>78</b><b>Notice</b>: Undefined index: weight_class in 
catalog\controller\feed\google_base.php
FIND

Code: Select all

weight_class
REPLACE

Code: Select all

weight_class_id

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 2:19 pm
by happychai
i try again to installed 1.5.1 and import data from 1.5.0

Once i import the data and i load the main page it show the error at the error log
What is the different of 1.5.1 compare to 1.5.0?

2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_left.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_left.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_left.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_right.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_right.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_right.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_top.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_top.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_top.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_bottom.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_bottom.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_bottom.php on line 49

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 6:59 pm
by i2Paq
opencartisalright wrote:Is there a difference between the OC 1.5.1.1.zip file that Daniel uploaded 15 hours ago and the one qphoria uploaded 7 hours ago?

I believe that Q uploaded the 1.4.9.6.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 8:41 pm
by Daniel
happychai wrote:i try again to installed 1.5.1 and import data from 1.5.0

Once i import the data and i load the main page it show the error at the error log
What is the different of 1.5.1 compare to 1.5.0?

2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_left.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_left.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_left.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_right.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_right.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\column_right.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_top.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_top.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_top.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_bottom.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_bottom.php on line 49
2011-07-24 8:14:48 - PHP Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\op151b\catalog\controller\common\content_bottom.php on line 49

resave your settings for your extension > modules.

Re: OpenCart 1.5.1 Bug Thread

Posted: Sun Jul 24, 2011 9:19 pm
by i2Paq
Adding a new product will automatically ad a Special Price of 90.00 to it.

I believe this is a BUG that was solved but has returned?