Post by Rhoa » Fri Jul 08, 2011 12:20 am

Hello,

I have a customer who placed an order yesterday 7/6/2011. I checked on the database and it shows 7/6/2011. However, when I go to the admin, the date is displaying as 6/7/2011. This issue only seems to show up on the "Date Added" field. It shows incorrectly everywhere Date Added is located. This includes the invoice. It also shows on the customer's order history. Could someone please guide me on how to fix this issue? Thanks!

Newbie

Posts

Joined
Sun Jun 05, 2011 11:25 am

Post by Qphoria » Fri Jul 08, 2011 12:23 am

Did you change the date format in your admin/language/english/english.php file
The limeys use "DD/MM/YYYY"
The yanks use "MM/DD/YYYY"
it can be confusing in the single digit months when 7/6 and 6/7 are both actual dates

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Rhoa » Fri Jul 08, 2011 12:38 am

This solved the issue for me. Thanks!

Newbie

Posts

Joined
Sun Jun 05, 2011 11:25 am

Post by businessprnews » Thu Sep 08, 2011 3:15 am

Hi, I tried and the invoices still has the other format.

The format on english.php:
line 5 has: $_['date_format_short'] = 'd/m/Y';
line 6 has: $_['date_format_long'] = 'l dS F Y';


I changed:
$_['date_format_short'] = 'm/d/Y';

I still have the date on the invoices come up as:

Date Added: 07/09/2011
Should be: 09/07/2011
(Sept. 7th, 2011)

I even changed it to: MM/DD/YYYY
And still get the date, month then year on our invoices.

Should change the long format too? And if yes, what should be it?

Thanks!


Posts

Joined
Thu Sep 08, 2011 3:02 am

Post by Daniel » Thu Sep 08, 2011 11:05 am

i think some one reported this. just one date did not have the date format take from the language files. its fixed in the svn version.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 3 guests