Page 8 of 8

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 12:29 am
by i2Paq
I'm using Tortoise but it creates annoying .svn directories.
How do I avoid that?

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 3:23 am
by asphole
Not sure if you can avoid the svn directories from being created but if you export your folder to a new location it will export everything but the .svn files.

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 3:59 am
by i2Paq
asphole wrote:Not sure if you can avoid the svn directories from being created but if you export your folder to a new location it will export everything but the .svn files.
Aha, I was doing it wrong. Thanks!

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 5:44 am
by my.shop1390
Pleas add moudol for Description for all product in home page (len to 20 charecter)

and

moduol for change View Product list to 1 product in 1 line + Description(20 charecter)
and line 2 next product and ....

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 11:16 am
by Daniel
i2Paq wrote:I'm using Tortoise but it creates annoying .svn directories.
How do I avoid that?

use export instead.

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 11:59 am
by JasonSGN
Daniel wrote:
JasonSGN wrote:I've run through most of the features in RC2 and Revision 314 and have been very happy with the results. A lot of the issues that have been mentioned are now fixed and work perfectly.

I did find one minor issue: I've updated both english.php files in /catalog/language/english/ and /admin/language/english so that the data_format_short is m/d/y but it it still displays as d/m/y when viewing a customer's rewards and transactions history on the catalog side. It displays the correctly in the admin area.
fixed.
Just discovered the same issue with Affiliate Transactions. The Transcation.php file in catalog/controller/affiliate/ needs the same fix you provided for rewards and customer transactions.

Line 70:

Change:

'date_added' => date('d/m/Y', strtotime($result['date_added']))

to:

'date_added' => date($this->language->get('date_format_short'), strtotime($result['date_added']))

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 3:37 pm
by ifyouseek
When you update a guests order history with an email notification the email contains a link to an invoice the customer will never be able to view.

Also the email content doesn't look complete, i have inserted the email below.

Also another thing i noticed is when any customer follows the link - eg. http://store.com/index.php?route=accoun ... order_id=2 to view the invoice it should present a login page rather than "The page you requested cannot be found!"

Code: Select all

Subject: text_subject
 
text_order 3
Date Added: 30/05/2011
 
Order Status:
Refunded
 
text_link
http://store.com/index.php?route=account/invoice&order_id=2
 
text_footer

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 4:18 pm
by ifyouseek
When i try to duplicate a product it gives the message below on a blank white page

Code: Select all

Error: Duplicate entry '48-51' for key 1
Error No: 1062
INSERT INTO product_related SET product_id = '48', related_id = '51'
The product copies successfully after reloading the page, but after comparing the two products i have noticed that in the orignal one there is only 2 specials but in the new product there is 3 specials? May this is where the problem lies.

.....Now i've tried it again on another product with 1 special, same thing happens but now there are 3 special options, one even has dates filled and different values for the special price.

This was all done on a fresh install, if you can't replicate the problem i'd be happy to let you see it. Maybe its only a problem with my server but i dont think so i saw someone else mentioning it.

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 7:29 pm
by Daniel
thanks for letting me know the latest bunch of bugs. going to update svn in a bit. also just one thing left to do with IE6 which is to find a decent png fix.

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 7:34 pm
by Daniel
ifyouseek wrote:When i try to duplicate a product it gives the message below on a blank white page

Code: Select all

Error: Duplicate entry '48-51' for key 1
Error No: 1062
INSERT INTO product_related SET product_id = '48', related_id = '51'
The product copies successfully after reloading the page, but after comparing the two products i have noticed that in the orignal one there is only 2 specials but in the new product there is 3 specials? May this is where the problem lies.

.....Now i've tried it again on another product with 1 special, same thing happens but now there are 3 special options, one even has dates filled and different values for the special price.

This was all done on a fresh install, if you can't replicate the problem i'd be happy to let you see it. Maybe its only a problem with my server but i dont think so i saw someone else mentioning it.

there is no product with an ID of 51.

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 7:37 pm
by Daniel
ifyouseek wrote:When i try to duplicate a product it gives the message below on a blank white page

Code: Select all

Error: Duplicate entry '48-51' for key 1
Error No: 1062
INSERT INTO product_related SET product_id = '48', related_id = '51'
The product copies successfully after reloading the page, but after comparing the two products i have noticed that in the orignal one there is only 2 specials but in the new product there is 3 specials? May this is where the problem lies.

.....Now i've tried it again on another product with 1 special, same thing happens but now there are 3 special options, one even has dates filled and different values for the special price.

This was all done on a fresh install, if you can't replicate the problem i'd be happy to let you see it. Maybe its only a problem with my server but i dont think so i saw someone else mentioning it.
are u using the latest version from SVN?

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Mon May 30, 2011 7:47 pm
by opencartisalright
Daniel wrote:also just one thing left to do with IE6 which is to find a decent png fix.
Here's a nice fix... http://www.ie6nomore.com/

:)

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Tue May 31, 2011 1:40 am
by daniel1
Firstly thanks for the new release it looks good and has new features its appreciated.

1.

I understand there is a new options feature which is just what I was looking for and also includes file uploads. Now the problem is that when I edit a product and go to Option tab I am presented with a text box and a green plus + image. I added an option value for file and named it test. I can only presume this is for adding the options? Unless I am really missing something.

2.

This has probably already been reported but when items are added to the basket etc and then I got o checkout the new/existing customer page loads and then the item added is quickly removed from the basket. I have tried this in FF and IE with the same effect.

Daniel

Re: Offical OpenCart v1.5.0 RC2 Bug Thread

Posted: Tue May 31, 2011 5:58 am
by i2Paq