Post by CChris » Fri Feb 13, 2009 3:28 am

Hello!

I have some of the Sample-Products and one self-added product in the shop.
Now, i can add the sample products ti the cart without any problems, but the product i've added, doesn't "work"...
The product is "in Stoc", Quantity is > 0, and it is enabled...

I can't find any errors... ?!

New member

Posts

Joined
Tue Feb 10, 2009 8:36 am

Post by Daniel » Fri Feb 13, 2009 5:39 am

Hi this is a new feature in 1.x. You can set a products out of stock status.

In the admin product page you can seee a field called stock status where you can set a status when it runs out. You need to set the statu sto out of stock or set it to 5 - 10  day delivery.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by CChris » Fri Feb 13, 2009 6:42 am

hm - notihng changed...

the same problem when the product is set to "out of stack" or "2-3 Days"
I can't add the Product to my cart

New member

Posts

Joined
Tue Feb 10, 2009 8:36 am

Post by Daniel » Fri Feb 13, 2009 7:18 am

What exactly is going worng?

You the product won't go in the cart?

Do you have a url I can test this?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Blueforce » Fri Feb 13, 2009 12:08 pm

Hi Guys!

The problem here is the same that I pointed out in my post: http://forum.opencart.com/index.php/topic,3019.0.html

When I add a new product the "date available" automatically gets todays date "now()".
And the cart.php (system/library/cart.php) use "date_available < NOW()" when it select/search for products, which make the product unavailable the same day!
To be able to ad a product the same day as It's added you have to set the "date available" one day backwords. Or...
Change this part in line 28 of cart.php (system/library/cart.php):
p.date_available < NOW()
to this:
p.date_available <= NOW()

I think you also want to change the same thing in review.php (catalog/model/catalog/review.php) on lines: 8, 14, 20, 26, 42 and 48

Or wait for an updated package!

/Leffe
Last edited by Blueforce on Fri Feb 13, 2009 12:10 pm, edited 1 time in total.

New member

Posts

Joined
Thu Feb 12, 2009 7:11 am
Location - Sweden

Post by CChris » Fri Feb 13, 2009 2:20 pm

Yes!

Now it works fine... but one thing for ToDo list:

If you wrote a review and it is waiting for activating from the admin, the user should get a message!

Because at the moment the user does not know if the review was sent or not...
Last edited by CChris on Fri Feb 13, 2009 4:14 pm, edited 1 time in total.

New member

Posts

Joined
Tue Feb 10, 2009 8:36 am

Post by Daniel » Fri Feb 13, 2009 7:08 pm

It should say:

Thank you for your review. It has been submitted to the webmaster for approval.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by CChris » Fri Feb 13, 2009 7:42 pm

Jep - and this does not work!

I've tested it again, and with the fixe above the review doesn't work to...
I was a little bit confused, because i've had a review in admin-panel - but when i wrote another, nothings happen.

New member

Posts

Joined
Tue Feb 10, 2009 8:36 am
Who is online

Users browsing this forum: No registered users and 6 guests