Post by gaudi » Thu Feb 05, 2009 7:02 pm

Hi!

The store front layout is scrambled in Firefox (the middle column is aligning in the left part of the screen, instead of the center) and in Internet Explorer 7.0 (the middle column is displayed below the left sidebar column).

In Safari for Windows, Chrome the store front layout is displayed correctly.

Hope this could be resolved with some CSS fixes.
Last edited by gaudi on Thu Feb 05, 2009 7:15 pm, edited 1 time in total.

Newbie

Posts

Joined
Thu Feb 05, 2009 6:53 pm

Post by Daniel » Thu Feb 05, 2009 11:01 pm

it works fine on mine. What version of IE are yiou using?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by JNeuhoff » Thu Feb 05, 2009 11:30 pm

From what I can see, the basic CSS for the container and the 3 columns looks like this:

Code: Select all

#container {
	width: 960px;
	position: relative;
	left: 50%;
	margin-left: -480px;
	background: #FFFFFF;
}
....
#column_left {
	float: left;
	width: 180px;
	margin-right: 10px;
	display: inline-block;
}
#column_right {
	float: right;
	width: 180px;
	margin-left: 10px;
	display: inline-block;
}
#content {
	display: inline-block;
	width: 580px;
	margin-bottom: 10px;
}
This can indeed cause problems in some web browsers.

I think it would be better to use something like this for the #container:

Code: Select all

#container {
	width: 960px;
	position: relative;
	margin-left: auto;
	margin-right: auto;
	background: #FFFFFF;
}
This makes the whole container centered-aligned and more robust for rendering in different browsers IMHO.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by gaudi » Thu Feb 05, 2009 11:58 pm

Firefox screenshot

Attachments

???
firefox.jpg
???
firefox.jpg

Newbie

Posts

Joined
Thu Feb 05, 2009 6:53 pm

Post by gaudi » Fri Feb 06, 2009 12:00 am

Internet Explorer screenshot

Attachments

???
internet_explorer.jpg
???
internet_explorer.jpg

Newbie

Posts

Joined
Thu Feb 05, 2009 6:53 pm

Post by Daniel » Fri Feb 06, 2009 12:01 am

ok i've added the changes in the next release.

I'm going to start using SVn so people can get fixes straght away.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by gaudi » Fri Feb 06, 2009 7:07 pm

Hi Daniel!

The layout display problems don't appear in Firefox 3 (I checked on another computer with the latest Firefox browser installed and OpenCart layout rendered correctly)

It’s seems the layout problems appear on Firefox v2.0 (my Firefox version is 2.0.0).

Thank you!

Newbie

Posts

Joined
Thu Feb 05, 2009 6:53 pm
Who is online

Users browsing this forum: No registered users and 9 guests