Post by Xsecrets » Thu Aug 05, 2010 10:06 am

check your payment module I bet the order status is set to canceled in there.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by didikajah » Thu Aug 05, 2010 2:42 pm

Xsecrets wrote:check your payment module I bet the order status is set to canceled in there.
many thanks for your assistant :-*

Newbie

Posts

Joined
Wed Aug 04, 2010 7:03 pm

Post by fido-x » Fri Aug 06, 2010 12:41 am

In "admin/language/english/localisation/stock_status.php", line 16:

Code: Select all

$_['error_permission'] = 'Warning: You do not have permission to modify stock statues!'; 
Should be:

Code: Select all

$_['error_permission'] = 'Warning: You do not have permission to modify stock statuses!'; 

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Qphoria » Fri Aug 06, 2010 2:26 am

but we like to modify our statues! :)

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JAY6390 » Fri Aug 06, 2010 10:15 am

While doing an install today I noticed that the magic_quotes_gpc is required in the list, but that's not actually true. Just wondering why it says it's needed when it isn't, it's just desirable. magic quotes get handled in the startup.php file if they're turned on

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by Qphoria » Fri Aug 06, 2010 9:36 pm

I think the startup magic quotes was added after the fact.

1.4.9 update:

I've gone through the full 14 pages of bugs now
- I've fixed all the spelling typos mentioned
- I've fixed all the bugs in the first post
- I've fixed a few other odds and ends listed.
- Some of the smaller things like the total text in the wrong language is a bigger job than I want to tackle for 1.4.9 so I'm leaving it

I've fined tuned the new paypal a bit and am working on the add/edit stuff now. Be sure to get any last minute bugs in here asap so they can be fixed. I'm already later than I wanted but hopefully I can finish up the edit/add stuff this weekend and have an RC ready for early next week

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JAY6390 » Fri Aug 06, 2010 11:02 pm

Excellent, sounds good. Just wondering are you releasing the PP as a new module or is it overwriting the old one? Just thinking about compatibility for upgrades if it would make more sense to separate the two, and have something like pp_standard_improved as the name or something like that

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by Qphoria » Fri Aug 06, 2010 11:21 pm

JAY6390 wrote:Excellent, sounds good. Just wondering are you releasing the PP as a new module or is it overwriting the old one? Just thinking about compatibility for upgrades if it would make more sense to separate the two, and have something like pp_standard_improved as the name or something like that
I had pondered what would be easier.

New Name Pros:
- People know they have the latest version
New Name Cons:
- People will have 2 versions and it could get confusing
- When people upgrade, the old pp_standard.php will still be there and again could be confused when making edits.

Old Name Pros:
- It's a hot swap. It's like the old bad version was never there
- No double files on upgrades
Old Name Cons:
- People need to be sure that they edit the configuration section to update the new parameters (i could probably force the status to disabled in the upgrade script to ensure they have to go back and edit it)

So I'm leaning towards the old name only because there was confusion initially back when paypal.php was renamed to pp_standard.php in 1.3.x

Any other thoughts are appreciated.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JAY6390 » Fri Aug 06, 2010 11:26 pm

Ah I see. I was thinking more when it comes to troubleshooting if there is any that it might get confusing knowing which pp version they have, if they've upgraded to the newest pp standard etc, but I guess that can be worked out fairly easily. I guess either way there will be confusion, but at least those coming to OC after this version will have only the latest

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by Qphoria » Fri Aug 06, 2010 11:45 pm

Plus a simple way to tell is all the new fields. If they exist, then you have the new version.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JAY6390 » Fri Aug 06, 2010 11:54 pm

Well we know that, but have to rely on the non technical peeps to know that too :laugh:

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by i2Paq » Sat Aug 07, 2010 12:30 am

Would it not be easier to have the version in the Admin backend, so from BO -> Extensions -> Payment -> PayPal Improved 1.4.9?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by JAY6390 » Sat Aug 07, 2010 12:36 am

Well that was my thinking but as Q pointed out above, it could make more confusion for new users having two of them, plus giving newer versions a less secure version can't be a good idea really :)

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by i2Paq » Sat Aug 07, 2010 12:46 am

I still think that no visual recognition is a BAD idea. How do people who just operate a store see from the BO what version they are using?
The need to go into phpMyAdmin to find out?

I absolutely disagree on and vote against this!

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Qphoria » Sat Aug 07, 2010 2:13 am

The admin will still say v1.4.9 in the footer. This way there is no mistake that they are using the OLD paypal with NEW opencart. If we renamed it they could overlook that and use the old one. But if we just keep the same name, then 1.4.9 only comes with this new paypal

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JAY6390 » Sat Aug 07, 2010 2:17 am

Is it possible to have the minor details of the code in the admin area too just so that say we have another 1.4.8 and 1.4.8b that they show which of the two it is, not just the 1.4.8

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by i2Paq » Sat Aug 07, 2010 2:30 am

You are not getting it.

I mean:

Code: Select all

// Heading
$_['heading_title']      = 'PayPal';
 
Should change into:

Code: Select all

// Heading
$_['heading_title']      = 'PayPal Improved';
 
So when a user reads this and tells us then we know which version he/she uses.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Xsecrets » Sat Aug 07, 2010 2:38 am

as long as they tell us what version of opencart they are using the only way we wouldn't know which version of paypal they are using is if they are one of the few who actually downloaded the test version from the forum and they should let us know this.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by Qphoria » Sat Aug 07, 2010 2:42 am

Ok then for the final version that actually comes with 1.4.9 I'll change the text to "Paypal Standard" as opposed to just "Paypal". But I won't change it on the RC versions that I release in the RC thread. Or maybe I'll add RC4 to the title for the RC version

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by i2Paq » Sat Aug 07, 2010 3:10 am

Qphoria wrote:Ok then for the final version that actually comes with 1.4.9 I'll change the text to "Paypal Standard" as opposed to just "Paypal". But I won't change it on the RC versions that I release in the RC thread. Or maybe I'll add RC4 to the title for the RC version
Are you planning to release it as replacement for 1.4.8 and earlier versions of OC as well?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands
Who is online

Users browsing this forum: Google [Bot] and 5 guests