Post by burrito » Tue Oct 14, 2014 10:49 pm

when using SEO URLs there is an issue with the categories. It doesn't load the child category links correctly if the parent has a seo-alias and the child does not
example:

category_id 22 has alias 'dogs'
category_id 23 is child of 22 without alias

store.com/index.php?route=product/category&path=22_23
should become
store.com/dogs?path=23
actually becomes
store.com/dogs

so it looses the child path.
an easy fix for now is to remove all aliases or enter them all, but in the long run, this is not a viable option for my customer.

Does anybody have a quick fix for this?
Last edited by burrito on Wed Oct 15, 2014 2:19 am, edited 1 time in total.

Image
Opencart specialist | Our website | Our modules


User avatar
Active Member

Posts

Joined
Tue Dec 15, 2009 6:10 pm
Location - Amsterdam, The Netherlands

Post by burrito » Tue Oct 14, 2014 11:35 pm

ok, just fixed it with some code from 2.0
in catalog/controller/common/url_alias.php

line 84 is:

Code: Select all

if ($query->num_rows) {
	$url .= '/' . $query->row['keyword'];
}
after this add:

Code: Select all

else {
	$url = '';
	break;
}
That'll fix the issue.

Image
Opencart specialist | Our website | Our modules


User avatar
Active Member

Posts

Joined
Tue Dec 15, 2009 6:10 pm
Location - Amsterdam, The Netherlands

Post by rishiraj » Mon Apr 18, 2016 5:49 pm

hie!!!

when i click on my product takes me to another product information , for example there are many products in my page P1, P2, P3, P4, P5.

when i click on P1 product it takes me to P5 product.

please help.

Newbie

Posts

Joined
Mon Apr 18, 2016 3:22 pm
Who is online

Users browsing this forum: No registered users and 3 guests