Post by misscaprice » Mon Jul 07, 2014 8:58 pm

Hi,

Pagination in brands section is generating new urls for products ending in ?page=2, ?page=3, etc and is causing duplicates. For example in brand SampleBrand page 2
http://www.site.com/SampleBrand?page=2

all products have ?page=2 appended to the end of the url:
http://www.site.com/productOne?page=2
http://www.site.com/productTwo?page=2
http://www.site.com/productThree?page=2
etc
all products on page 3 have ?page=3 appended to the end and so on, and so forth.
This is causing duplicates of virtually all products. Sure enough canonical is in place, but I've got all urls indexed TWICE in search engines and this is causing problems. On the other hand pagination is working just fine in categories.
OC version 1.5.6.4, with seo urls turned on
Would really appreciate if somebody could advise how to fix that issue.

New member

Posts

Joined
Sat Jan 22, 2011 6:47 pm

Post by misscaprice » Tue Jul 08, 2014 8:11 pm

Any thoughts on this are appreciated!

New member

Posts

Joined
Sat Jan 22, 2011 6:47 pm

Post by labeshops » Tue Jul 08, 2014 8:30 pm

Just disallow /?page in your robots.txt file.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by misscaprice » Tue Jul 08, 2014 9:05 pm

That will cause indexing issues as pagination of categories would be disavowed as well. :-\

Product URLs in categories are generated properly, maybe similar code for manufacturers would do?

New member

Posts

Joined
Sat Jan 22, 2011 6:47 pm
Who is online

Users browsing this forum: No registered users and 9 guests