Post by dsb802 » Tue Jan 14, 2014 9:07 pm

Hi,

I am getting following error after updating my store to 1.5.6 I think I am getting this error after re installation of override engine

Error -
Fatal error: Call to undefined method ControllerSaleOrder::hasAction() in /public_html/admin/controller/sale/order.php on line 1915
Steps for the error
Login to admin ---> Sales ---> Orders --- > when I click on view then getting above error

Please please help me to fix it

Newbie

Posts

Joined
Fri Mar 02, 2012 3:25 pm

Post by cwswebdesign » Wed Jan 15, 2014 12:25 am

Are you using the newest version of vqmod?

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by butte » Tue Jan 21, 2014 2:20 pm

Did you rerun installation of override engine or vqmod or both after upgrading? Upgrading brought in a new, virgin index.php pair along with other files from the upgrade fileset.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by remanos » Fri Dec 18, 2015 7:12 am

Simple;

replace the file "controller.php" on the folder system/engine/ for the original file from your opencart version.

You can download the original version here;

http://www.opencart.com/?route=download/download

Not here, we solve it!


User avatar
Newbie

Posts

Joined
Fri Dec 18, 2015 7:02 am
Who is online

Users browsing this forum: No registered users and 9 guests