Post by bluebikerboy2 » Sun Nov 24, 2013 7:06 pm

When a customer uses a gift voucher it wont let them check out. when you try to complete order a red bar comes up saying payment method not selected please contact owner

what gives?

gi joe and action figures www.jasonsjoesandmore.com


New member

Posts

Joined
Sun May 13, 2012 5:18 am
Location - marysville, ca

Post by florinsith » Mon Nov 25, 2013 5:52 pm

Enable Free Checkout payment method, if the voucher covers all total value, the other payment methods wont show up, so you need to enable free checkout (it shows up when the total is 0).

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by strato » Tue Nov 26, 2013 1:31 pm

I'm having the same problem. I've enabled the Gift Voucher, and a customer has purchased two gift vouchers for two separate people. Neither one got their emails.
I purchased a gift voucher and had it sent to my husband. He never received anything. So I found that you have to go in and manually send them.
So.. thennn.. he was unable to use it. I've read on here that the gift voucher must be set to the same level of processing as it is set to in the Store Settings. So I made sure that from now on all purchases within the store are set to "Processed." And that Gift Vouchers require that the purchase of them are set to "Processed".. that's a setting found in several different places..BTW.. what a pain!! I also enabled Free Checkout in Payments within the Admin on the Extensions drop-down.
Thennn... my husband tried it again. It now accepts the Gift Voucher code.. but puts him through he entire Checkout process, including choosing a shipping method in entering a payment option and entering credit card information.. for a $0 purchase!!
Anybody have any other ideas??? I'm stumped..

Newbie

Posts

Joined
Sat Apr 20, 2013 5:33 am

Post by florinsith » Tue Nov 26, 2013 6:38 pm

I do not understand why you think this is somewhat broken, seems pretty functional to me.

The voucher is only sent and active if the person who purchased it allready paid it.When a person uses it , he must go trough checkout, is normal, the shipping address and method are required, not to mention that the voucher could be used to partially pay for an order, not allway will be 100%.

So what is the problem?

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by strato » Wed Jan 22, 2014 7:20 am

My issue was the custom payment module I I'm using. It needed to be changed in the coding to a lower price for it to show (or rather not show) during the Checkout Process. It was coded to $1.00. Lowering it to .01 cent fixed the issue, and I can now have Free Shipping enabled so that it shows up for any purchases less then 1 cent and my other processing extension does not show up. That being said... the gift voucher functionality in OpenCart has other major issue (IMO).. such as not automatically disabling after the use.

Newbie

Posts

Joined
Sat Apr 20, 2013 5:33 am
Who is online

Users browsing this forum: No registered users and 6 guests