Post by Lybex » Tue Feb 18, 2014 4:31 pm

Hi,

I have installed 1.5.6.1 oc and now having some issues with shopping cart !
I add product to shopping cart it goes fine at first !
Then I tried to delete product from shoping cart, it deleted. BUT when I pointed my mouse over shoping cart again it was back.
I tried to add more items to cart and they added fine, but when I pointed my mouse over cart it again went back to first product I added erlier. (example : first i added 5 products. then deleted them(still there if mouse pointed at cart). After i added for example 30 more products, it shows there are 30+ products in cart. when pointed on cart it went back to 5, BUT in "view cart" there are "no products in shopping cart")


what could be the problem ?

Newbie

Posts

Joined
Tue Feb 18, 2014 4:15 pm

Post by JNeuhoff » Wed Feb 19, 2014 12:12 am

Since no one else can reproduce your problem, your best bet is to look into the server's error_log (ask your webhost for it), or OpenCart system/logs/error.txt. Also check your PHP settings, could be an issue with session handling.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by CodeSpace » Sun Mar 02, 2014 8:49 pm

I'm sorry, but I do not understand why you take reported bugs from old versions in new versions.
---
Ok, after I read a few posts, I understand why the bugs from one version pass over to the next . But i find it nevertheless bad.
---
editSettingValue

Code: Select all

$this->db->query("UPDATE " . DB_PREFIX . "setting SET `value` = '" . $this->db->escape(serialize($value)) . "'WHERE `group` = '" . $this->db->escape($group) . "' AND `key` = '" . $this->db->escape($key) . "' AND store_id = '" . (int)$store_id . "', serialized = '1' ");
correct:

Code: Select all

$this->db->query("UPDATE " . DB_PREFIX . "setting SET `value` = '" . $this->db->escape(serialize($value)) . "', serialized = '1' WHERE `group` = '" . $this->db->escape($group) . "' AND `key` = '" . $this->db->escape($key) . "' AND store_id = '" . (int)$store_id . "'");

OpenCart Error Update

Code: Select all

Uncaught exception 'ErrorException' with message 'Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' serialized = '1'' at line 1
(error log for Google)

User avatar
Active Member

Posts

Joined
Mon Aug 06, 2012 9:26 pm

Post by paladinzhy » Sat Mar 08, 2014 7:02 pm

Hi,

I just purchased the adv order module. I get some issues with that.
I have two "text" type options, which are "first name" & "last name". When I export the "all details" report, I could not find these two options in the option column. Another two options(size and location, which are "select" types.) can be found in option column. I'm just wondering if this is a bug or I need to change some configurations.

If you need some screenshot, could you please give me your email, and I can send you that.

Cheers,
Ryan

Newbie

Posts

Joined
Sat Mar 08, 2014 6:52 pm

Post by dfumagalli » Sun Mar 09, 2014 6:53 am

Hello,

I know this is a long, epic OpenCart topic but it's happening to us now and I have no idea (left) about how to fix it or even how to further debug it.

Basically we have a new 1.5.6 install + vQMod (newest) + Override Engine (newest).
Contact Us emails get sent.
New account emails notices get sent.
Order emails do not get sent at all to anyone. I have tested Paypal Standard and Bank Transfer options.

Everything including orders works and gives no error, no warning. Only order emails don't give any warning yet don't work.

I am using the Mail delivery method, with and without -f additional option.

I am the sys admin of our server. I have checked Postfix log and contact us / new account generated mails get queued and delivered like the other mails, order emails never get to Postfix at all. It's like something chokes before sending the email. No warnings, nothing in the OC error log.
All our other PHP software send mails with no problem, our domain has all the various DNS records setup so that gmail etc. all receive our emails with no problem.

Of course I have tested the PHP mail "tester" scripts posted on these forums in these years and they all work.

I have tried the "remove second newline" suggestion on the mail.php line 97 (or so), I have tried switching $crlf to "\n" and others but none work.
By the way, no mail (even contacts and new account) take into account the additional 3 comma separated email addresses (all to different ISPs) I have put in the appropriate field. Maybe this detail can ring some bell.

Please provide me some clues about where I could work my way out of this dead end.
I can do a lot of debugging just please tell me a systematic approach.

Server is Ubuntu 12.04 LTS, PHP 5.5, OC 1.5.6, MySQL 5.6, Nginx 1.4.5.

Thanks in advance.

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by JNeuhoff » Mon Mar 10, 2014 2:28 am

paladinzhy wrote:Hi,

I just purchased the adv order module. I get some issues with that.
I have two "text" type options, which are "first name" & "last name". When I export the "all details" report, I could not find these two options in the option column. Another two options(size and location, which are "select" types.) can be found in option column. I'm just wondering if this is a bug or I need to change some configurations.

If you need some screenshot, could you please give me your email, and I can send you that.

Cheers,
Ryan
This forum thread is for OpenCart 1.5.6 bug reports only. Yours is most likely an issue with the 3rd party adv order module, so you should get in touch with the author of that module for support and bugfixes.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Mon Mar 10, 2014 2:38 am

dfumagalli wrote:Hello,

I know this is a long, epic OpenCart topic but it's happening to us now and I have no idea (left) about how to fix it or even how to further debug it.

Basically we have a new 1.5.6 install + vQMod (newest) + Override Engine (newest).
Contact Us emails get sent.
New account emails notices get sent.
Order emails do not get sent at all to anyone. I have tested Paypal Standard and Bank Transfer options.
To start with a simple process of elimination: Have you also tested it with a plain OpenCart 1.5.6 install (without vQmod and without the Override Engine)?

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by dfumagalli » Mon Mar 10, 2014 3:29 am

JNeuhoff wrote:
dfumagalli wrote:Hello,

I know this is a long, epic OpenCart topic but it's happening to us now and I have no idea (left) about how to fix it or even how to further debug it.

Basically we have a new 1.5.6 install + vQMod (newest) + Override Engine (newest).
Contact Us emails get sent.
New account emails notices get sent.
Order emails do not get sent at all to anyone. I have tested Paypal Standard and Bank Transfer options.
To start with a simple process of elimination: Have you also tested it with a plain OpenCart 1.5.6 install (without vQmod and without the Override Engine)?
At the moment I have not had the time for that. I'd need to replicate the same testbed (the whole sum of operating system etc. etc.) and making two OpenCarts working like that with Nginx is not a trivial effort.

What I have done instead, is to create an Unit Test (you know I like them ;D ):

Code: Select all

require_once ('FW_OpenCartTest.php');

class SystemMailTest extends FWOpenCartTest {

    public function testMail() {
        $mail = new Mail();
        $mail->protocol = $this->config->get('config_mail_protocol');
        $mail->parameter = $this->config->get('config_mail_parameter');
        $mail->hostname = $this->config->get('config_smtp_host');
        $mail->username = $this->config->get('config_smtp_username');
        $mail->password = $this->config->get('config_smtp_password');
        $mail->port = $this->config->get('config_smtp_port');
        $mail->timeout = $this->config->get('config_smtp_timeout');
        $mail->setTo($this->config->get('config_email'));
        $mail->setFrom('dfumagalli@XXXX.XX);
        $mail->setSender('Test sender');
        $mail->setSubject(html_entity_decode(sprintf($this->language->get('email_subject'), 'Test subject'), ENT_QUOTES, 'UTF-8'));
        $mail->setText(strip_tags(html_entity_decode('Mail text', ENT_QUOTES, 'UTF-8')));
        print_r($mail);
        $mail->send();
        
        ...
This thing sends the mail to the intended recipient. Due to the print_r() I get this (anonymized):

Code: Select all

Mail Object
(
    [to:protected] => info@domain.tld
    [from:protected] => dfumagalli@XXXX.XX
    [sender:protected] => Test sender
    [subject:protected] => email_subject
    [text:protected] => Mail text
    [html:protected] =>
    [attachments:protected] => Array
        (
        )

    [protocol] => mail
    [hostname] =>
    [username] =>
    [password] =>
    [port] => 25
    [timeout] => 5
    [newline] =>

    [crlf] =>

    [verp] =>
    [parameter] => -finfo@domain.tld
)
.
Tomorrow I'll try recreating a proper order HTML email and see what happens.

This is worth noting:
[subject:protected] => email_subject

Because in mail.php the translation is used in a sprintf(). A side effect is, in there's no translation (I don't know why it does not get English by default) the subject gets replaced by the "email_subject" string.

Finally, I have noticed that the nice System configuration option: "Additional Alert E-Mails" whose related database entry is: config_alert_emails is only actually implemented in the orders and new user PHP code.
It'd be nice if it was also implemented in the other notifications. Nothing impossible to code and VQMod by myself but imo it should be in the core for consistency.
Last edited by dfumagalli on Mon Mar 10, 2014 5:37 am, edited 2 times in total.

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by dfumagalli » Mon Mar 10, 2014 4:55 am

@JNeuhoff

You'll also notice how the unit test is not using Override Engine's allocator. That is basically what you asked about excluding it from the tests.

I also noticed another thing about OE (sorry for the off-topic in here): it looks like you "OE-ed" order.php but $email gets allocated in other places as well. Do I think wrong if I believe that an overridden mail.php would not apply in those other PHP files that still allocate $mail the "original way"?

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by Coelho-d » Mon Mar 10, 2014 11:04 pm

Hello everyone!!

I have this problem ( I think that other people too ) in version 1.5.6.1 .
I can't create a third level of category.
The pictures show better the problem.

Image
There are 3 categories that I created. It's okay until the second. The third category needs to be the third level of the second category ( Clothing > Men > Shirt ), but it stays only as second level ( Clothing > Shirt ) of the first.

Image
Here, I am editing (trying) the third category (Shirt) in the third level. See the auto complete, it only shows the first level category ( Clothing >). The second level ( Clothing > Men ) it doesn't show.

Image
I completed the first ( Clothing ) and I went to the second, but it keep without shows the second level ( Men ). If I write this mannually ( Clothing > Men ) it saves in the second level ( Clothing > Shirt ) and no in the third that I need.

The examples in the Opencart has some categories registered in third level, but I can't modify they too. They don't change and don't save.

Some idea to solve the problem? Somebody with the same problem?

Thank you for any suggestions or help!

Newbie

Posts

Joined
Mon Mar 10, 2014 10:31 pm

Post by butte » Tue Mar 11, 2014 1:07 am

Try doing this. Where it says Clothing overwrite that with Men and be sure to assign Shirt to parent Men (where Men itself is a child of Clothing and not a Top Parent) -- and to Save. Be sure to let it complete each task before you give it the next one.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Coelho-d » Tue Mar 11, 2014 8:18 am

butte wrote:Try doing this. Where it says Clothing overwrite that with Men and be sure to assign Shirt to parent Men (where Men itself is a child of Clothing and not a Top Parent) -- and to Save. Be sure to let it complete each task before you give it the next one.
Thank you very much. Really simple and it worked fine. ;D

Newbie

Posts

Joined
Mon Mar 10, 2014 10:31 pm

Post by gilsonpina » Sat Mar 15, 2014 10:41 am

Multi-Store
installed opencart clean, and created a second store.
I copied all the necessary files and folders to the second store with exepção the images folder.
When opening the second store will not appear in the images that are the main store folder.
The config.php is redirecting to the main store but opencart loads the images of the secondary store that folder does not exist, the folder where it should go read the images have to be the main folder of the store, because the image is centered in only one paste

Newbie

Posts

Joined
Sat Mar 15, 2014 10:28 am

Post by butte » Mon Mar 17, 2014 4:13 pm

Coelho-d, welcome, glad it was easy on you.

gilsonpina, which OC version do you have? Since "config.php is redirecting to the main store but opencart loads the images of the secondary store that folder does not exist" it appears that you have three ready ways out:

a/ reword the redirection in BOTH of the two config.php files for the 2nd shop;

b/ make an /image/ tree with no files other than either
b/1/ a .htacess redirecting temp 302 to the other image tree
b/2/ or index.html with meta refresh going to the other image tree;

c/ make an extra copy of /image/, subdirectories and files both.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Cue4cheap » Mon Mar 17, 2014 8:36 pm

gilsonpina wrote:Multi-Store
installed opencart clean, and created a second store.
I copied all the necessary files and folders to the second store with exepção the images folder.
When opening the second store will not appear in the images that are the main store folder.
The config.php is redirecting to the main store but opencart loads the images of the secondary store that folder does not exist, the folder where it should go read the images have to be the main folder of the store, because the image is centered in only one paste
Multi-store and a bug reporting BUT you wrote
I copied all the necessary files and folders to the second store
For Multi-store you don't copy any files. I think you might have created your own bug.

Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by jlowe » Wed Mar 19, 2014 3:23 am

Greetings,

I have attempted edwin86's fix for the Paypal Express bug, but unfortunately to no avail.
edwin86 wrote:

edwin86 wrote:I have made a clean install of opencart 1.5.6.
I have enabled paypal express checkout and it works fine with amount lesser than 1,000 (etc 999),
but as long as it is above 1,000, regardless of currency, as long as it is more than 4 digits.
it will throw the below error msg,

"The totals of the cart item amounts do not match order amounts."

anyone faced this issue? please assist on this.
Thanks!

regards,
Edwin

to reply to myself, i have found a solution,
in catalog > model > payment > pp_express.php
i updated all the number_format($item_total, 2) to number_format($item_total, 2, '.', '')
i hope this helps someone out there
So here's the error I get when checking out:

"Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home1/columbt2/public_html/catalog/model/payment/pp_express.php on line 266"

Anyone else run into this issue? Any help is much appreciated!

Thanks,
Jeff

Newbie

Posts

Joined
Tue Jan 07, 2014 12:51 am

Post by dfumagalli » Wed Mar 19, 2014 5:47 pm

In case warnings are enabled, you can get a blank page (page compression turned on) or a warning if something goes bad with the PHP session and there's little the end user can do:

Here's the admin page, the front end looks just blank unless compression is turned off.

Image

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by butte » Wed Mar 19, 2014 7:38 pm

gilsonpina, are you trying to set up a separate second store as such or a multi-store as such within the original admin? If former, sever the two. If latter, set it up within admin and let OC do it.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by dfumagalli » Tue Apr 15, 2014 4:41 pm

In reference to my bug report (OpenCart not sending order emails) and to the only reply I have received:
JNeuhoff wrote: To start with a simple process of elimination: Have you also tested it with a plain OpenCart 1.5.6 install (without vQmod and without the Override Engine)?

Introduction
I have found the bug. It's a true bug, I have verified it's in the official OpenCart 1.5.6 trunk and it's also a "blocking bug", that is, it prevents a whole feature from being executed.

That is, the hundreds of reports about the OpenCart 1.5.6 orders emails just plainly not working at all were correct, and not (just) due to configuration and mail server issues as it has always been suggested.
This raises some non technical related concerns about OpenCart which will be covered later.


What's the bug about
It's spurious code left in probably from a beta release. It causes an end user interface invisible error:

Code: Select all

PHP Fatal error:  Call to a member function orderNew() on a non-object

The error is located in this OpenCart 1.5.6 [stable] trunk file at line 213 and 214:

Code: Select all

213 if(!isset($passArray) || empty($passArray)){ $passArray = null; }
214 $this->openbay->orderNew((int)$order_id);
This excerpt pops out to the eye because it does not even follow the indentation used for the code above and below it.

No code after these lines gets EVER executed, that is, it's not some complex condition code, it's a 100% thing. Hundreds of lines get completely skipped because of this bug.
This raises another concern about OpenCart, discussed later.


The fix

All it's needed is to remove those two lines of code.
For the less experienced users, I have provided a vQMod file to make the process relatively painless and without having to change the OpenCart core code.

As soon as the offending code is removed, the orders emails immediately begin to work.

To those who don't know what a vQMod file is: it's a nice OpenCart unofficial patching system consisting of an addon (vQMod) that takes little XML snippets and non destructively patches them against the OpenCart code. Please google for it for better explanations and instructions about how to download and install it.


Non technical considerations and concerns

I have decided to not post them in a bug thread, I'll create a specific topic for them.

Attachments


Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by IP_CAM » Wed Apr 16, 2014 1:01 am

@dfumagalli: I have been working with Matt Hahnfeld's rather basic EveryAuction OpenSource Perl Software for 15 Years, before getting engaged with Opencart past January, therefore, doing work 'under full CSS templated PHP' is not yet truly familiar to me, using <table> and empty gif's instead of <div> for so long, to keep the stuff in place ...

Still, I found a rather familiar Scene around OpenCart, it reminds me of the time, when uncounted Numbers of Fan's and Freak's tried to get rich quick, using THE then very popular software, and many fine Contributors offered free Add-On's and Assistance to thousand's of suppost-to-be Auctioneers around the Globe.

Eventually, the EveryAuction Project fell a sleep and died out - not because it lacked on Add-On Contributors, but mainly because the Scene lacked on honest Users, most of them never really cared to understand a thing about how HTML works, and even more of them never understud the simplest Perl routines, all they wanted was to get a fully enhanced working platform, enabling them to make lots of money as fast as possible.

As a consequence of this (regular human) behaviour, some of the EveryAuction Add-On Contributors decided to create their own Auction Software in order to offer turnkey Systems against Cash. But because of that, other former Contributors decided to either leave the scene, having their Enhancments deleted from Everysoft's Add-On List, and nasty discussions and a widespread verbal War, mainly about GPL Interpretations and 'stolen' Software, followed at the User-Forum, finally killing the EveryAuction User-Forum Scene.

Why am I writing this here?

The Opencart Project is, in many ways, quite similar to the former EveryAuction Project. Peoples come to the Opencart Site because they are looking for a MONEYMAKER SOFTWARE for FREE, enabling them in their Plans to get a modern Online Store, without the need to spend a lot on money to start with. More, I assume that a Majority of Fellows don't even have any money to spend, in Contrary, for Many, it's more like one of the few chances for them to (hopefully) get some...

So, building a store by using everything available, they eventually end up with a , more or less, functionable Web Site, but since they never had any Money to start with, they have nothing to offer on their Site. So, instead of offering Hardware as planned, they start to offer what they have downloaded and possibly modified in some parts, and, as a Result of this, hundred's of different Mod's are beeing offered, priced at a few Bucks each, to Newcomers, again, trying to repeat what other have experienced already in the past. To avoid beeing 'ripped of 25 percent' of the price charged by Daniel, the Founder of the OC Project, some Peoples offer their own Mod's on their own Site, and to get the Audience, they still offer 'free' Mod's on the PC Site.

Compared with what I read here from a while ago, requiring 'PHP'-specific Newbie-Assistance at the OC Forum today, one can be lucky to receive a really usable Reply. But why should assist anyone someone new, why should one assist others to eventually get successfull, for free??! In contrary, in many cases, posters where lucky to even receive a helpfull reply, other than the stereotype DISABLE VQMOD's and empty the Cache-Section.

I am not so sure why, but I imagine, that there are just not very many 'PHP-Source-competent' Peoples anymore at this Forum, willing to assist others, or then, they wait until one offer's Money to receive Help. Whatever the reason may be, to me, it's a rather clear sign that this place is on the verge of 'drying' out, possibly because many think of the Money Daniel and a few Others may make, while they just come away empty-handed.

I don't know how (small) the OpenCart Project once started, all I know is, that OC 1.5.6.x has grown into a very comprehensive Piece of Software. it's an 'Eierlegende Wollmilchsau', as we would call it here, an 'egg-laying wool milk pig', universally adaptable, unspecificly 'broad-built', 'templated' down to the last possible function, but more or less 'ununderstandable' for Anyone not familiar with deeper ways of CSS-styled PHP Template based Coding.

To make it even more complicated, the software is written WITHOUT any Section Description Lines. For OpenSource Software, this is called an absolutely NO-GO. So, beeing confronted with a Million of variables instead of 'real' figures, PHP Beginners are unable to figure out anything without having Forum-Assistance. But if this Assistance is not available at a Forum, they have to stay with what they have, and for enhancements, they have to add (at some places incompatible) VQMOD's instead of Advises how to add SIMPLE Lines into the right places in order to make the Thing work as it should.

Not enough. As soon as one finally has a working Online Shop based on OpenCart, one finds him/herselfs confronted with another OC-UPDATE, possibly destroying all one had before, because of changes or mods not existing in the older Version OC. And again, very little Information on how and what IMPORTANT has changed with a new Version released, without the need to click trough uncounted Pages in order to finally find what one is looking for.

TO MAKE IT CLEAR, I do NOT want to criticize the OpenCart Project in any way, personally, I have no Problems, I find my Solutions, there are 1'000+ downloaded Mod's on my PC, I check everyone of them, trying to find out, where to do what in order to get what I want. By Nature, I have less Problems than others, because I am around Scripting since BASIC has got popular 35+ Years ago and I have been writing handcoded HTML/Perl/CSS/Website stuff for the last 18 Years.

I admit, I had a rather 'poor' start at the OC Forum, I got a 'less' friendly 'hi' as reply to my first posts here. Possibly, because I was not used to the -habit's- at this Forum. Nevertheless, I required lot's of Information, so I decided to stay instead of just leaving it. As not beeing a friend of 'two-liner' Postings, my postings are usually a little longer, like this one, but I feel, that this is what a Forum should be about. If others do not like this, they are free not to read it.

It is possibe, that a lot of Information about OC exists somewhere, it's my fault not searching for it or reading it before posting my garbage here. But I'm doing what the Majority of Persons is doing when they come onto a Forum to seek assistance. Everybody should be aware of this, a lot of Peoples just don't have the Time to spend uncounted Hours, trying to find out how a 'relatively simple' Shop-Sotware works, before beeing able to use it as planned and according their individual needs.

I am fully aware, that creating a NON-Standard-OC Shop is not a 'one-night stand'-adventure, it's a full 'some-hundred' hour time investment. But to reach the Goal, a User-Forum is also very important, but this depend's on helpfull Others, willing to share their knowledge, not just waiting to make a buck, ignoring more or less most other PHP Newbie-Postings related to specific Problems.

I don't plan to give any advise, I just wrote above what my impressions are after beeing around OpenCart for a few months now. It's a very interesting universal Platform Design, but technically, it's success bases on professional Source. If BASIC Errors, like the one 'dfumagalli' mentioned, exist, they NEED to to be CORRECTED by Danial or then someone else in charge of such matters, as soon as the Fault is detected and published. Otherways, the Script is of little or NO USE for anyone expecting and depending on SECURE Shop-Software, no Professional can afford to depend on half-baken Equipment...

Daniel's Idea is great, thousand's of hours have been invested into this Product, it would be a shame if it would fail because of a very few solveable Problems. I hope, the beautyfull HK Harbor-View will encourange Daniel to continue in the best possible ways, and I wish him lot's of luck. Thank you!

No offense, excluse my english, I am (an old) Swiss and have not learned it in School.

Ernie :D

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 7 guests