Post by PaskSant » Sat Sep 25, 2021 10:06 pm

I have a question for my website:
http://ferramentaevernici.it/index.php? ... ommon/home
I have an OpenCart 3.0.2.0 with Journal3.
The problem is that in the search page of my website the products appear too much large as shown here:
http://ferramentaevernici.it/index.php? ... ption=true
I think the problem is NOT related to the image dimentions becouse changing the height and weight, the images appear only more or less blurry without any change in their dimentions.
Since I am sure that I doesn't change anything related to product/search.twig file, i think that some changing in the journal settings were made.

Could you suggest a way to reduce it?

Newbie

Posts

Joined
Sun Sep 05, 2021 6:06 pm

Post by by mona » Sat Sep 25, 2021 10:19 pm

It is due to your theme not Opencart

Since you were kind enough to provide both your OC version and a web address, I will suggest a way to reduce it
in your stylesheet product-card change from 100% to 50%

Code: Select all

   .product-thumb .product-img img {
        width: 50%;
    }
  
but I suspect this will cause other issues all over the place

The issue is caused by the theme x2 directive
There probably is a setting or something, but you will have to ask your theme developer.

It also looks like some other issues are going on there - not Opencart related either.

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by Gergely » Mon Sep 27, 2021 6:44 pm

by mona wrote:
Sat Sep 25, 2021 10:19 pm
It is due to your theme not Opencart

Since you were kind enough to provide both your OC version and a web address, I will suggest a way to reduce it
in your stylesheet product-card change from 100% to 50%

Code: Select all

 
 .product-thumb .product-img img  {
        width: 50%;
    }
  
but I suspect this will cause other issues all over the place

The issue is caused by the theme x2 directive
There probably is a setting or something, but you will have to ask your theme developer.

It also looks like some other issues are going on there - not Opencart related either.
Or to limit the effects to the search page only (probably), add this new rule:

Code: Select all

 
  .search-form ~ .main-products-wrapper .product-thumb .product-img img  {
        width: 50%;
    }
  
But please bear in mind that both CSS tricks are hacky, best effort "solutions".
The recommended course of action as suggested by mona, would be to get in touch with the theme developer.

Active Member

Posts

Joined
Wed Sep 30, 2020 7:58 pm

Post by Gergely » Mon Sep 27, 2021 9:39 pm

Additionally:
I don't think this is the appropriate forum for this question.
I also don't think it's appropriate to double post. (Interestingly, you got the forum right the first time...)
Further, it would be advisable to react to suggested solutions (in the other thread where you posted this exact same question, and the same direction to a solution has been suggested)

Active Member

Posts

Joined
Wed Sep 30, 2020 7:58 pm
Who is online

Users browsing this forum: No registered users and 9 guests