Post by shrinidhi » Sat Apr 03, 2021 6:52 pm

Is opencart 3.0.3.7 version support MySQL 8.0?

Newbie

Posts

Joined
Sat Apr 03, 2021 6:20 pm

Post by johnp » Sun Apr 04, 2021 5:46 pm

I've got a copy running on PHP 8 fine. I installed it on 7.4 then switched over. I haven't done an install on PHP 8 from scratch. It's a default setup apart from having the Vqmod Manager extension installed.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.4 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by johnp » Sun Apr 04, 2021 5:52 pm

Sorry, I misread the OP's post. I mistook the question for PHP 8. I'll put my glasses on next time. :)

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.4 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by JNeuhoff » Mon Apr 05, 2021 10:48 pm

Yes, it should run just fine on MySQL8.

The only change you may have to do is in the system/library/db/mysqli.php where the line

Code: Select all

$this->connection->query("SET SESSION sql_mode = 'NO_ZERO_IN_DATE,NO_ZERO_DATE,NO_ENGINE_SUBSTITUTION'");
should be replaced with

Code: Select all

$this->connection->query("SET SESSION sql_mode = 'NO_ZERO_IN_DATE,NO_ENGINE_SUBSTITUTION'");

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 1 guest