Post by Kakur007 » Sat Apr 19, 2014 1:13 am

I have installed Rich Snippets vqmod. Now my review stars are gone and reviews cannot be inserted, captcha not correct. Never experienced any of those problems. I noticed You mentioned how to fix stars and I have made neccessery changes on all files I came up: category, special, product. Still not showing correctly. ???

Are anyone experienced this and maybe can help me out with this? Appreciate any help given.

King Regards,
Kaur

Best consumer electronics online store - Digital Trade
http://www.digitaltrade.eu


New member

Posts

Joined
Sun Nov 17, 2013 8:44 pm

Post by Kakur007 » Sun Apr 27, 2014 5:18 pm

I managed to fix the captcha, fixed the getCode function on captcha.php. But still stars not showing up ??? Looking forward to some help fixing those stars.

Best consumer electronics online store - Digital Trade
http://www.digitaltrade.eu


New member

Posts

Joined
Sun Nov 17, 2013 8:44 pm

Post by OC2PS » Fri May 02, 2014 9:52 pm

Are you sure you have the latest version 2.0 of the extension?

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Kakur007 » Sun May 04, 2014 4:32 pm

Well yes, xml shows 2.0 version. I belive its latest.

Best consumer electronics online store - Digital Trade
http://www.digitaltrade.eu


New member

Posts

Joined
Sun Nov 17, 2013 8:44 pm

Post by DavKan » Sat May 10, 2014 8:25 pm

OC2PS wrote:It should work already if all your stores use the Default theme.

I will work on a version for stores that use different themes. But don't hold your breath.
Hello OC2PS

When i used this MOD, the stars were not visible. so as per your forum post:

i replaced below code in (mytheme/product/product.tpl)

Code: Select all

<div><img src="catalog/view/theme/mytheme/image/stars-<?php echo $rating; ?>.png" alt="<?php echo $reviews; ?>" />
with below code:

Code: Select all

<div><img src="catalog/view/theme/greetathon/image/stars-<?php echo round($product['rating']); ?>.png" alt="<?php echo $reviews; ?>" />
But now i see 1 error in my error logs as below

Code: Select all

PHP Notice:  Undefined variable: product in public_html/catalog/view/theme/mytheme/template/product/product.tpl on line 295
Can you please assist with this. Thanks in advance.

New member

Posts

Joined
Thu Jan 23, 2014 7:06 pm

Post by billynoah » Mon May 12, 2014 12:06 am

@DavKan

1) You're not using default theme so don't expect this extension to work out of the box. It's possible, but chances are you'll need to customize for your theme.
2) Looks like you replaced the wrong bit of code - that patch is for a module or related products within an array loop where $product is defined, not meant to replace the main product review as you did.
3) You've private messaged me twice now but I can't respond since you have pm replies disabled in your account here. Not sure if you realized that.

Image


User avatar
Active Member

Posts

Joined
Tue Jan 15, 2013 12:46 pm

Post by DavKan » Mon May 12, 2014 12:19 am

billynoah wrote:@DavKan

1) You're not using default theme so don't expect this extension to work out of the box. It's possible, but chances are you'll need to customize for your theme.
2) Looks like you replaced the wrong bit of code - that patch is for a module or related products within an array loop where $product is defined, not meant to replace the main product review as you did.
3) You've private messaged me twice now but I can't respond since you have pm replies disabled in your account here. Not sure if you realized that.

I apologize for this. Now i have enabled the replies. I was not aware of that.

request you respond..Thanks in advance.

New member

Posts

Joined
Thu Jan 23, 2014 7:06 pm

Post by OC2PS » Tue May 13, 2014 3:19 pm

To any folks having issues with the extension in OC 1.5.6.4 : I'll be releasing an update in a day or two. Thanks for your patience.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by Kakur007 » Thu May 15, 2014 2:59 am

Just problem with getting review stars displaying again. ???

Best consumer electronics online store - Digital Trade
http://www.digitaltrade.eu


New member

Posts

Joined
Sun Nov 17, 2013 8:44 pm

Post by Kakur007 » Tue May 20, 2014 9:13 pm

OC2Ps, any updates? Would like to get this fixed, seems like it happens even with default Opencart, not only custom themes.

Best consumer electronics online store - Digital Trade
http://www.digitaltrade.eu


New member

Posts

Joined
Sun Nov 17, 2013 8:44 pm

Post by Kakur007 » Tue May 27, 2014 1:43 am

Are there any information how to fix those review stars? Looking forward to hear back about this quesiton :-\

Best consumer electronics online store - Digital Trade
http://www.digitaltrade.eu


New member

Posts

Joined
Sun Nov 17, 2013 8:44 pm

Post by rocky.ajwani » Sat Jul 12, 2014 3:56 pm

Hello i'm using pavo opencart theme will you please tell me how to make this extension work with this template? i was having problem of not displaying the ratings on my website as well as on the google, let me tell you website is under construction but its open for all means users can use the website. should i do this task after completing my website or its cool to just the way its going on? Not only this i wasn't able to see reviews n price on google search....

Thanks in advanced :)

User avatar
Newbie

Posts

Joined
Mon May 05, 2014 2:05 am

Post by dfumagalli » Tue Jul 22, 2014 4:57 pm

Hello,

The mod works great, but Google Structured Data Tool shows prices in Sterling. I want them in US dollars or Euros instead, any way to do that?

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by i2Paq » Tue Jul 22, 2014 9:55 pm

Do you use the latest release?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by dfumagalli » Wed Jul 23, 2014 4:30 pm

i2Paq wrote:Do you use the latest release?
I am upgrading it right now from 1.9.7. Comparing it with DIFF, the only additions your latest version got for OpenCart 1.5.6 which I didn't have are:

Related products star rating fix

a search.tpl string

and a "if ($profile)" in another XML clause.


Regarding the currency schema microcode, my version is the same as the latest.

Edit:

Actually, the "Close price div" section in the "catalog/view/theme/*/template/product/product.tpl" file section has this in your latest version:

Code: Select all

<?php if ($profiles): ?>
It returns zero matches found.

The original:

Code: Select all

<?php if ($options) { ?>
is found (2 occurrences) instead.

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by Oostebloem » Wed Jul 23, 2014 8:52 pm

Hallo,

I am using Opencart 1.5.4 now, having the same problem with rating image loading. Somehow the rating image name has 4 decimals, for example 3 reviews with 2 of 5 stars and 1 of 3 stars, the average rating is 4.3333. Is there an easy solution available?

I have tried to replace catalog/view/theme/default/template/product/product.tpl
<div><img src="catalog/view/theme/default/image/stars-<?php echo 'rating'; ?>.png" alt="<?php echo $reviews; ?>"
with
<div><img src="catalog/view/theme/default/image/stars-<?php echo round($product['rating']); ?>.png" alt="<?php echo $reviews; ?>"

But it is not working.


Also VQmod file vq2-catalog_controller_product_product.php
'rating' => (int)$result['rating'], replaced with 'rating' => (round)$result['rating'],

not working as well.

Anybody can give me a hint how to do it? Many thanks to all developers for this brilliant software. I start to learn all from 0 background. Now I can get my webshop working although it requires a lot of improvements still.

Ooste

Newbie

Posts

Joined
Tue Jul 22, 2014 4:51 pm

Post by anuraggarg621 » Wed Sep 17, 2014 9:21 pm

i am new in opencart...kindly explain the steps for installing this module...i tried installing this module and checked in the give link but it is not working...may be i am not implementing correctly...please guide me...

Newbie

Posts

Joined
Wed Sep 17, 2014 9:18 pm

Post by s.pasith » Fri Nov 28, 2014 1:12 am

r u planning to make this module for opencart 2.0?

Newbie

Posts

Joined
Fri Nov 28, 2014 1:10 am

Post by OC2PS » Mon Dec 01, 2014 10:57 pm

I am planning to do so, but don't hold your breath - I expect to release that only around new year's.

OC2PS
OC 2.3.0.2, vQmod 2.6.2, Journal2 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by upgrader » Sun Dec 07, 2014 12:01 am

Hi
I am getting the following error in webmaster tools for products with no reviews.
"Missing: best or worst rating"

Is it possible to only show review snippets when there is a one or more reviews, but disable when 0 reviews?

Newbie

Posts

Joined
Sat Dec 06, 2014 11:58 pm
Who is online

Users browsing this forum: No registered users and 5 guests