Post by Qphoria » Thu Apr 30, 2015 12:25 am

That doesn't happen for me. What version of OpenCart? It is also possible you have another vQmod altering that file causing a conflict.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by BOBKIM7080 » Thu Apr 30, 2015 3:28 am

OC 1.5.6
Do I have to look for which Vqmod works for
catalog/model/checkout/order.php

User avatar
New member

Posts

Joined
Fri Aug 26, 2011 12:53 am


Post by bhraqnet » Thu May 07, 2015 3:25 pm

Qphoria wrote:
DWWD wrote:Just installed this mod, thanks.

Can I assume it's OK to delete older orders that have a status of 0?
Yes you can
How is it that
Is there an extension to do so
I use version open card 2.0.2.0

Active Member

Posts

Joined
Thu Dec 26, 2013 11:16 pm

Post by EvolveWebHosting » Mon Jun 01, 2015 10:32 pm

BOBKIM7080 wrote:Thank you for reply.
--NO--
I just tried dynamic version but get error
Parse error: syntax error, unexpected '[' in /home/public_html/vqmod/vqcache/vq2-catalog_model_checkout_order.php on line 40
I have the same error. Using OC 1.5.6.4, Q Uber Checkout, First Data from Q and the UPS deluxe add on from Q. The error is on checkout_two.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by rlasmar » Sun Jun 07, 2015 5:16 am

Could you help me? Not work correctly for me.

OC 2.0.2.0

I added 1 product (USD 10.00) to cart and go to step 6, it generates the ID temp #1. Now, I decided to change the product, so I add a new one product with different price (USD 20.00), and delete the old product (USD 10.00). I go to checkout and finalized the order. The temp order still #1 correctly. But, when I go to the order history, it is showed the old product (USD 10.00) and the new one product (USD 20.00), but in total price only from the last product (USD 20.00). In confirmation e-mail from order sent to the client, it is described the old product (USD 10.00) and the new product (USD 20.00) but with total value only from the second product (USD 20.00).

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by Qphoria » Wed Jun 10, 2015 12:54 am

Fixed major goof up.... I left my db prefix hardcoded in the dynamic version so it wasn't deleting the data from other order tables. So it always worked fine on my store but not others. Fixed. :o

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by rlasmar » Wed Jun 10, 2015 11:43 am

Qphoria wrote:Fixed major goof up.... I left my db prefix hardcoded in the dynamic version so it wasn't deleting the data from other order tables. So it always worked fine on my store but not others. Fixed. :o
OC 2.0.3.1
Now I am getting this error on log:

2015-06-10 5:41:52 - PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_recurring_transaction` WHERE order_id = '12318' in C:\xampp\htdocs\system\library\db\mysqli.php on line 41
2015-06-10 5:41:52 - PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_status` WHERE order_id = '12318' in C:\xampp\htdocs\system\library\db\mysqli.php on line 41


And in order history in admin, the products are duplicate.

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by Qphoria » Wed Jun 17, 2015 9:45 pm

rlasmar wrote:
Qphoria wrote:Fixed major goof up.... I left my db prefix hardcoded in the dynamic version so it wasn't deleting the data from other order tables. So it always worked fine on my store but not others. Fixed. :o
OC 2.0.3.1
Now I am getting this error on log:

2015-06-10 5:41:52 - PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_recurring_transaction` WHERE order_id = '12318' in C:\xampp\htdocs\system\library\db\mysqli.php on line 41
2015-06-10 5:41:52 - PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_status` WHERE order_id = '12318' in C:\xampp\htdocs\system\library\db\mysqli.php on line 41


And in order history in admin, the products are duplicate.
That was already patched.. get the latest

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Mortymer » Sat Jun 20, 2015 5:38 pm

Hello,
I have same problem but every time, every orders go to "Missing Order"
I don't use paypal just COD and Free Shipping, but every orders is Missing Orders.
I couldn't edit and couldn't delet, just with SQL from order table.
What's wrong?

Please Help Me!
Thank you for any Help!

Newbie

Posts

Joined
Thu Jun 18, 2015 9:26 pm

Post by Qphoria » Fri Jun 26, 2015 1:35 am

ok I just fixed an issue that caused an error when a dbprefix was in use on the dynamic version. This should be solid now.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by rlasmar » Sun Jun 28, 2015 7:40 am

Qphoria wrote:ok I just fixed an issue that caused an error when a dbprefix was in use on the dynamic version. This should be solid now.
Now it works!! Thank you very much.

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by BOBKIM7080 » Fri Jul 03, 2015 11:16 am

Just Reinstall Dynamic Version.
Parse error: syntax error, unexpected '[' in /home/public_html/vqmod/vqcache/vq2-catalog_model_checkout_order.php on line 40
is gone but can't confirm step:6 confirm order and
PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_amazon_product` WHERE order_id = '17394' in /home/public_html/system/database/mysql.php on line 50

User avatar
New member

Posts

Joined
Fri Aug 26, 2011 12:53 am


Post by Qphoria » Sun Jul 05, 2015 11:54 pm

BOBKIM7080 wrote:Just Reinstall Dynamic Version.
Parse error: syntax error, unexpected '[' in /home/public_html/vqmod/vqcache/vq2-catalog_model_checkout_order.php on line 40
is gone but can't confirm step:6 confirm order and
PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_amazon_product` WHERE order_id = '17394' in /home/public_html/system/database/mysql.php on line 50
Added support for the amazon table to be ignored. Redownload.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by BOBKIM7080 » Fri Jul 10, 2015 1:42 pm

Thank you for try but same thing
PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_amazon_product` WHERE order_id = '17560' in /home/public_html/system/database/mysql.php on line 50

User avatar
New member

Posts

Joined
Fri Aug 26, 2011 12:53 am


Post by Qphoria » Sat Jul 11, 2015 11:37 am

BOBKIM7080 wrote:Thank you for try but same thing
PHP Notice: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `oc_order_amazon_product` WHERE order_id = '17560' in /home/public_html/system/database/mysql.php on line 50
Sorry typo.. fixed

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by sunsys » Mon Jul 13, 2015 6:10 pm

Q sir you have listed 2 files on page 1:
A. Dynamic Version - Tested up to 2.0.3.1
and
B. THIS IS THE OLDER LEGACY. TESTED UP TO 1.5.6
now can file A be used in oc-1564 or I must use file B only in oc-1564 ???

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by Qphoria » Tue Jul 14, 2015 5:19 am

"up to" means it was tested with older versions too.. all version will work with it

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by sunsys » Tue Jul 14, 2015 11:45 am

Qphoria wrote:"up to" means it was tested with older versions too.. all version will work with it
Thank you Q for prompt and clear answer.

Regards,
Sun Systems
Industrial Electronics and Instrumentation


User avatar
Active Member

Posts

Joined
Tue Jan 27, 2015 5:19 am

Post by BOBKIM7080 » Fri Jul 17, 2015 8:14 am

just reinstall and having problem.
If customer
change mind at paypal page.
go back to my site and empty cart
select different product and checking out.
step1 ~step5 works but can not ending "step6" because nothing shows.

User avatar
New member

Posts

Joined
Fri Aug 26, 2011 12:53 am


Post by Qphoria » Mon Jul 20, 2015 9:46 pm

BOBKIM7080 wrote:just reinstall and having problem.
If customer
change mind at paypal page.
go back to my site and empty cart
select different product and checking out.
step1 ~step5 works but can not ending "step6" because nothing shows.
Hmm is there an error in the system error log? I cannot think of any reason this wouldn't work.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 4 guests