Post by rocketero » Thu Mar 24, 2011 4:40 pm

rocketero wrote:I replace my /admin/view/template/sale/osc_order-invoice.tpl with yours, and now I get more notices, when I press print shipping invoice or print payment I get all these:

For Print Shipping Invoice, I get now these 3 Notices in the same page:, the url ends on:
/admin/index.php?route=sale/order/osc_invoice&token=3cc546b95faee48ff249719cf5c3384e

Code: Select all

Undefined index: history in /home2/MYWEBSITE/public_html/admin/view/template/sale/osc_order_invoice.tpl on line 253

Code: Select all

Notice: Undefined variable: column_sku in /home2/MYWEBSITE/public_html/admin/view/template/sale/osc_order_invoice.tpl on line 189

Code: Select all

Notice: Undefined index: sku in /home2/MYWEBSITE/public_html/admin/view/template/sale/osc_order_invoice.tpl on line 204

for the other button, print invoice, the url ends on:
/admin/index.php?route=sale/order/invoice&token=3cc546b95faee48ff249719cf5c3384e

Code: Select all

Notice: Undefined index: order_id in /home2/MYWEBSITE/public_html/admin/controller/sale/order.php on line 928
=========================
Update: After taking off this osc_order_invoice.tpl and replacing it by the privious osc_order_invoice.tpl that I had before any changes about this whole issue 'web admin comments', Now the invoices and shipping receipts show fine with no Notices at all. And to be honest I don't even see that did any impact to what I was looking at once I clicked on Sales / Orders in backoffice.
Update: Seems like I was messing adding some code from OC v.1.4.9.4 to the /admin/controler/sale/order.php and that was the cause of this: NOTICE: UNDEFINED INDEX messages.

After exploring the cause and adding some $this-> statements to this file, I fixed most everything, except that I keep getting flagged by this statement in your code:

Code: Select all

$order_histories = $this->model_sale_order->getOrderHistory($this->request->get['order_id']);
When I press the button to see the invoice (the regular button, not the one you posted in this osc_invoice and shipping code), I get the invoice but at the top I get the notice:

Code: Select all

Notice: Undefined index: order_id in /home2/MYWEBSITE/public_html/admin/controller/sale/order.php on line 962
regards.
Last edited by rocketero on Sun Mar 27, 2011 3:53 pm, edited 2 times in total.

New member

Posts

Joined
Tue Feb 01, 2011 9:22 pm

Post by FTW » Sun Mar 27, 2011 4:25 am

well waiting for the update for oc v1.4.9.4 :P

also I would to know what code to add on the template to have a background image in the middle of the invoice?

I didn't test the admin comment in the yellow line because I installed the update of oc v1.4.9.4 before I saw the code so hope you put out the update soon :)

FTW
Newbie

Posts

Joined
Sat Nov 06, 2010 11:27 am

Post by dinmc » Mon Mar 28, 2011 1:55 pm

As an old Oscommerce user I really like this, but I have some problems.
When marking an Osc-Invoice from order already in the database, subtotal, tax, shipping, fee stuff is NOT on the invoice??

I'm using OC ver.1.4.9.4 - and danish laungege package

Any hints?

Regards
Lars

New member

Posts

Joined
Tue Mar 22, 2011 5:01 pm

Post by speida » Fri Apr 01, 2011 5:23 am

So I am trying to use this but I can only use half of what it offers...

So i download the vQmod and put it in the right folder. I have also moved all the files to the correct places, and I have changed the code as it says in the readme file. However I only see the button for invoices but not the packing slip... where can I find it?!?

thanks!

Newbie

Posts

Joined
Wed Mar 30, 2011 5:53 pm

Post by speida » Fri Apr 01, 2011 5:36 am

Nevermind!

Re-installed vQmod and now it shows correctly!

Just a quick question: how can I quickly select if a packing slip or an invoice should be in english or in another language?

Thanks

Newbie

Posts

Joined
Wed Mar 30, 2011 5:53 pm

Post by i2Paq » Fri Apr 01, 2011 9:08 pm

speida wrote:Nevermind!

Re-installed vQmod and now it shows correctly!

Just a quick question: how can I quickly select if a packing slip or an invoice should be in english or in another language?

Thanks
Not, only when changing the Admin language.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Rainforest » Fri Apr 15, 2011 12:22 am

Thank you so much for taking the time to make what i hope will be a wonderful and useful mod.

I must say, your instructions are very, very confusing and I don't see why you don't include the modified files? The instructions don't mention how to add your own logo too or where to edit some text. If you want help making a proper read me file I'd be willing to help.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by medici » Sat May 28, 2011 6:13 pm

Hi,
how to remove the following columns from invoice ?

Unit Price (excl.)
Total (excl.)
Tax

Newbie

Posts

Joined
Sat May 28, 2011 6:12 pm

Post by kgerken » Thu Jun 09, 2011 10:56 pm

Thanks for posting! I have it installed and it looks/works great.
I want to get rid of the yellow text line and two images at the bottom of the packing slip, but can't seem to find what page they are on to remove them. ???

Newbie

Posts

Joined
Fri May 27, 2011 7:03 am

Post by Melanie » Fri Jun 10, 2011 10:28 am

Hi, will this work in version 1.48?

Thanks, Mel

New member

Posts

Joined
Tue Mar 30, 2010 9:39 am

Post by i2Paq » Tue Jun 14, 2011 5:44 am

Melanie wrote:Hi, will this work in version 1.48?

Thanks, Mel

I'm not sure.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Melanie » Tue Jun 14, 2011 5:46 am

hmmmm can i test it and it id doesnt work un do it.
What do you think?
please inform me.
Thanks,.
Mel

New member

Posts

Joined
Tue Mar 30, 2010 9:39 am

Post by FTW » Tue Jun 14, 2011 5:55 am

are you intend to make a version for OC v1.5.0.x??

FTW
Newbie

Posts

Joined
Sat Nov 06, 2010 11:27 am

Post by i2Paq » Wed Jun 15, 2011 1:58 am

FTW wrote:are you intend to make a version for OC v1.5.0.x??
The guy I made it with has been absent for quite a while, when 1.5 is stable I will try and update it or have it updated.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by kgerken » Tue Jun 21, 2011 9:13 pm

Tiger1937 wrote:
As for page breaks... in the tpl files, I added :-

<?php foreach ($orders as $order) { ?>
<div style="page-break-after: always;"> <<<<----Added This Line
<!-- body_text //-->

&

</table>
<!-- body_text_eof //-->
</div> <<<<----Added This Line
<?php } ?>

------
Thanks for providing the Page break Solution. I can't get this to work on the Packing slip when multiple are selected. It still puts them on one page. Any other suggestions? ???

Newbie

Posts

Joined
Fri May 27, 2011 7:03 am

Post by PetracheNicolae » Wed Aug 10, 2011 5:46 pm

i2Paq wrote:
FTW wrote:are you intend to make a version for OC v1.5.0.x??
The guy I made it with has been absent for quite a while, when 1.5 is stable I will try and update it or have it updated.
this will be nice to have in opencart 1.5.1.1. it is great

New member

Posts

Joined
Tue May 24, 2011 5:40 am

Post by Ozfarmer » Mon Sep 19, 2011 4:37 pm

Has this been updated to 1.5.1.1 as yet?

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by Xciso » Mon Sep 26, 2011 12:34 am

When can we see this to 1.5.1.x?

Active Member

Posts

Joined
Fri Jul 15, 2011 5:20 am

Post by madlime » Wed Oct 12, 2011 3:28 am

work 1.5.1.1 thank you....

http://www.madlime.com
Always Free Shipping


User avatar
New member

Posts

Joined
Sat May 28, 2011 5:56 pm
Location - Hong Kong

Post by markman-b » Wed Oct 12, 2011 7:14 pm

madlime wrote:work 1.5.1.1 thank you....

Is that a question or a confirmation to us all, it is really working on OC 1.5.X?
I'm curious too.

OC version 1.5.4.1


Active Member

Posts

Joined
Wed Aug 24, 2011 7:13 pm
Who is online

Users browsing this forum: No registered users and 4 guests