Post by JNeuhoff » Mon Dec 28, 2009 7:48 am

sean wrote::) that is not that bad. We can all use some extra money ;)

I have a problem now! Everything works fine with sandbox account; but when I transfered to live account, it's giving me "Please specify weight of items in LB." error. Error shows up in OC after I click on GC link. I tried to use the same product and checkout with sandbox, it worked. There is only one item in the cart, and weighs 1LB (made sure the weight is in LB but still getting this error).
Can you do this: Add this code before line 304 in file catalog/controller/checkout/gcheckout.php:

Code: Select all

error_log( "\$cartGoogle = ".$cartGoogle->GetXML()."\n",3,DIR_SYSTEM."logs/error.txt" );
Then repeat the cart submission, and you should see the exact XML submitted to Google in your error log. What does it show? Is it using 'LB' or something else for the weight unit?

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by sean » Mon Dec 28, 2009 8:06 am

<item-weight unit="KG" value="0.4536" />

looks like it's converting it to KG

New member

Posts

Joined
Mon Aug 10, 2009 4:56 am

Post by JNeuhoff » Mon Dec 28, 2009 7:26 pm

I have now changed the code to make sure it always converts it into LB. It seems no other weight unit is officially accepted according to Google's Checkout API documentation.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by sean » Tue Dec 29, 2009 12:56 pm

Thanks J, this was a really big contribution, and thank you for fixing it in timely manner.
I've tested it and it's working (at leas for me and my install ;) )
Thank you!

New member

Posts

Joined
Mon Aug 10, 2009 4:56 am

Post by CEOself » Tue Dec 29, 2009 3:10 pm

Great to see this. I am setting up a new cart. I have about 12 hours of experience with OpenCart. Sorry for the newbee question.

I wish the 'Continue' button on the 'Payment' page would instigate the push to Google Checkout I would like to use Google Checkout as my only payment option. I'm concerned my customer will just keep hitting 'Continue', and become frustrated.

Any ideas for fixing this? Again, newbee, so is there a way to fix this?

ps: cart I am working on http://www.ubadge.com

Newbie

Posts

Joined
Tue Dec 29, 2009 3:05 pm

Post by JNeuhoff » Tue Dec 29, 2009 8:39 pm

For those who wish to use Google Checkout as their only payment option I suggest to comment out the regular Checkout links in the following templates:

catalog/view/theme/my-theme/template/common/header.tpl
catalog/view/theme/my-theme/template/checkout/cart.tpl

Also, to place the Google Checkout box in a more prominent place, e.g. as a right column box below the shopping cart box.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Thu Jan 07, 2010 12:35 am

I have updated the Google Checkout module with some bugfixes, to make it work more nicely with the Ajax enabled cart module.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ThePath » Thu Jan 07, 2010 3:36 am

Hi all, Im getting these errors after installing this:

Notice: Undefined index: warning in /home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php on line 48Notice: Undefined index: error_merchantid in /home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php on line 49Notice: Undefined index: error_merchantkey in /home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php on line 50

I know it coz the variables are undefined but I dont know why when I have installed this as per instructions on v1.3.4

What am I missing (except brain cells)?

Also I noticed this:

In install instructions it reads: system/library/google/library/googlerequest.php

In the downloaded files the file structure is: system/google/library/googlerequest.php

Cheers

Image

OpenCart Theme Options - See All My Extensions - OpenCart Themes and Mods


User avatar
Active Member

Posts

Joined
Fri Jun 26, 2009 11:53 pm
Location - Scotland

Post by thelightbay » Thu Jan 07, 2010 4:06 am

Hi, I'm just sandboxing at the moment however when I add items to my basket Google Checkout greys out and says not available for these items, does anyone know what this might be?

I have read previous posts about tax rules and tax class and as far as I can see I'm using the same settings throughout.

Any help appreciated, probably something simple and I missed it.

Newbie

Posts

Joined
Thu Jan 07, 2010 3:43 am

Post by ThePath » Thu Jan 07, 2010 4:12 am

My prob seems to be a deaper one I get the undefined error anytime I try and edit a payment option. Got a similar error for Paypal module too! Waaa

All the errors being thrown from similar lines to this: $this->data['error_email'] = @$this->error['email'];

I have re-uploaded error folder, which hasnt worked.
Last edited by ThePath on Thu Jan 07, 2010 4:28 am, edited 1 time in total.

Image

OpenCart Theme Options - See All My Extensions - OpenCart Themes and Mods


User avatar
Active Member

Posts

Joined
Fri Jun 26, 2009 11:53 pm
Location - Scotland

Post by thelightbay » Thu Jan 07, 2010 4:26 am

ThePath wrote:Hi all, Im getting these errors after installing this:

Notice: Undefined index: warning in /home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php on line 48Notice: Undefined index: error_merchantid in /home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php on line 49Notice: Undefined index: error_merchantkey in /home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php on line 50

I know it coz the variables are undefined but I dont know why when I have installed this as per instructions on v1.3.4

What am I missing (except brain cells)?

Also I noticed this:

In install instructions it reads: system/library/google/library/googlerequest.php

In the downloaded files the file structure is: system/google/library/googlerequest.php

Cheers
Yeah, the

/home/sites/nonae.com/public_html/admin/controller/payment/gcheckout.php

shouldn't be there. During the install I copied all the files into the actual defined structure and the listed file structures just in case. It worked for me. Although I'm still not sure which one it's using.

Newbie

Posts

Joined
Thu Jan 07, 2010 3:43 am

Post by ThePath » Thu Jan 07, 2010 4:33 am

Yup you are right. I think what Ive done is copied and pasted v1.3.4 over the existing files. I see that Google Checkout is activated in Modules now!! DOH! Told you I had no braincells!!

Image

OpenCart Theme Options - See All My Extensions - OpenCart Themes and Mods


User avatar
Active Member

Posts

Joined
Fri Jun 26, 2009 11:53 pm
Location - Scotland

Post by Qphoria » Thu Jan 07, 2010 5:05 am

those don't work any more because opencart is using a custom error handler. Most of those should have been removed back in 1.3.2 when the error handler was added.

things like this:

Code: Select all

$this->data['error_email'] = @$this->error['email'];
should be changed to this:

Code: Select all

if (isset($this->error['email'])) { 
    $this->data['error_email'] = $this->error['email'];
}

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JNeuhoff » Thu Jan 07, 2010 5:09 am

In install instructions it reads: system/library/google/library/googlerequest.php

In the downloaded files the file structure is: system/google/library/googlerequest.php
The Google library files should be in: system/google/library/*.php

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ThePath » Thu Jan 07, 2010 8:31 am

Yeh the whole carts fecked. I dunno what Ive done but managed to mix about three versions like an idiot. Just starting from scratch. What a great arse.

Image

OpenCart Theme Options - See All My Extensions - OpenCart Themes and Mods


User avatar
Active Member

Posts

Joined
Fri Jun 26, 2009 11:53 pm
Location - Scotland

Post by ThePath » Thu Jan 07, 2010 9:32 pm

OK I started completely fresh with new install of v1.3.4 etc and I thought I had it working but like thelightbay the Google checkout image is always grayed out...plus a weird thing is when I go to checkout, I clicked on guest. Part the way down the page I see this error:

Error: Could not load model payment/gcheckout!

This is displayed underneath the shipping section????????? ???

www.nonae.com

Image

OpenCart Theme Options - See All My Extensions - OpenCart Themes and Mods


User avatar
Active Member

Posts

Joined
Fri Jun 26, 2009 11:53 pm
Location - Scotland

Post by thelightbay » Mon Jan 11, 2010 7:15 am

I have altered all the settings for the shipping modules to get google checkout working, nothing seems to work. Whenever I add items to the basket it greys out. CAN ANYONE tell me why this might be happening.

I have followed all the instructions as given. Both "free shipping" and "flat rate" are active, flat rate is using the tax class (VAT), however there is obviously no tax class in "free shipping".

Each time I add an item the following is added to the error log. Am I missing something with the shipping methods?

ControllerModuleGCheckout::available: Shipping methods use different tax classes
ControllerModuleGCheckout::available: Shipping methods use different tax classes

OK - Sussed out the problem,

The problem lies with FREE SHIPPING and FLAT RATE, if you have them both active then you need to disable VAT in the FLAT RATE>TAX CLASS, this seems to make the two shipping methods different. This will cause a problem for me in that I cannot now calculate VAT on orders with FLAT RATE shipping. I presume I can only use GC by disabling one until this bug is fixed.

Newbie

Posts

Joined
Thu Jan 07, 2010 3:43 am

Post by JNeuhoff » Mon Jan 11, 2010 6:30 pm

thelightbay wrote: The problem lies with FREE SHIPPING and FLAT RATE, if you have them both active then you need to disable VAT in the FLAT RATE>TAX CLASS, this seems to make the two shipping methods different. This will cause a problem for me in that I cannot now calculate VAT on orders with FLAT RATE shipping. I presume I can only use GC by disabling one until this bug is fixed.
Do you charge VAT at all for the shipping? Normally shipping isn't taxed. If it has to be, what would happen if you set the free shipping to the same VAT tax class as used in your other shipping methods? 17.5% on a zero shipping rate still is zero, so it shouldn't make a difference.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ThePath » Mon Jan 11, 2010 9:03 pm

This doesnt work for me. No tax is set on flat rate, I have even disabled it, but Google image is still grayed out and still weird error message in checkout shipping page. ???

PS. Daniel can this be built in for next release please?

Image

OpenCart Theme Options - See All My Extensions - OpenCart Themes and Mods


User avatar
Active Member

Posts

Joined
Fri Jun 26, 2009 11:53 pm
Location - Scotland

Post by Xsecrets » Mon Jan 11, 2010 9:58 pm

ThePath wrote: PS. Daniel can this be built in for next release please?
Daniel was working on it for 1.3.3 and kept having problems. Gave up and said he wouldn't finish it.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US
Who is online

Users browsing this forum: No registered users and 4 guests