Post by qahar » Wed Apr 08, 2015 3:26 pm

Yes, may be end of this month if I'm not busy

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by qahar » Fri May 01, 2015 10:39 pm

System Information v2.0.0 released

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by exit15 » Tue Jun 02, 2015 9:09 am

thanks for the v2. Will you add phpinfo?

New member

Posts

Joined
Sun Mar 03, 2013 2:05 am


Post by qahar » Wed Jun 03, 2015 9:50 am

yes, may be on next update
not sure when, still busy right now

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by notzened » Tue Jul 07, 2015 3:52 pm

(solved) hi,
just installed your extension on oc 2.0.2.0 and vqmod 2.5.1. I get permission denied when I click on system info in tools. In vqmod/xml I changed the admin folder name in the xml file in two places and the permissions are where ever I checked 644. What else do I need to do to get it working?
Last edited by notzened on Tue Jul 07, 2015 6:53 pm, edited 1 time in total.

New member

Posts

Joined
Sat Apr 04, 2015 7:35 am

Post by qahar » Tue Jul 07, 2015 5:16 pm

You doesn't have permission to view the ext. Did you check User Group permission?

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by notzened » Tue Jul 07, 2015 6:52 pm

Thank you,
user group permissions was what I needed to do.

New member

Posts

Joined
Sat Apr 04, 2015 7:35 am

Post by qahar » Wed Sep 16, 2015 9:59 pm

System Information v2.1.0 released with addition of phpinfo()

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by qahar » Fri Oct 09, 2015 4:51 pm

System Information v2.1.1 released

Change:
- Just move the sysinfo link directly under system

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by codywood » Mon Oct 12, 2015 1:02 pm

Clicking refresh button on the Modifications page causes of the error below. I go to Extensions> Modifications and click the Refresh button on the upper right corner of the page to get the error.

But when I disable the system information extension the error goes away.

Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1 in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 139Notice: Trying to get property of non-object in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 142
Fatal error: Call to a member function getElementsByTagName() on a non-object in /home/techeq/public_html/store01/admin/controller/extension/modification.php on line 152

New member

Posts

Joined
Mon Sep 15, 2014 10:42 am

Post by qahar » Mon Oct 12, 2015 1:31 pm

System Information use the extension installer only for uploading the file.
While for modification, we use vQmod instead of OcMod.
So System Information shouldn't be listed and cannot disabled at Modification page. Clicking refresh at modification page not affecting system information.

Do you mean by disabling the System Information is the vQmod file?

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by ForgetfulGuru » Tue Dec 01, 2015 8:02 pm

Good afternoon wondering if you could help with my issue?
I uploaded the module Opencart System Information through oc-extension installer and set permissions in system>users>user groups. When I click the link in the Tools menu I get this error message.

Fatal error: Call to undefined method light_db::getServerInfo() in /home/********/public_html/vqmod/vqcache/vq2-system_library_db.php on line 31

I cleared the cache in vqmod manager and even manually deleted the cached files through ftp. I am still getting the error.

Any suggestion? I access my sql database with the sqli settings AFAIK.

Life is for the taking. It's everything else you need to pay for.
Anne Makes Lovely Candles


User avatar
New member

Posts

Joined
Sun Jul 22, 2012 11:12 pm
Location - Left hand corner as you enter the room, better feng shui.

Post by qahar » Wed Dec 02, 2015 12:03 am

@forgetfulGuru

sorry for earlier message, I send to wrong forum :D

Related to your issue, possibly the cause is that you use "light_db" class where Sysinfo only add getServerInfo() to mysql.php and mysqli.php

I suggest you to add getServerInfo to light_db class you use. You can refer to the code at system_information.xml vqmod file

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by ForgetfulGuru » Wed Dec 02, 2015 3:33 pm

Thanks for the input I'll have a look into that later. Not sure if I am using light_db or not. Pretty sure it is mysqli, but what do I know, that is what was selected at set up and here in config.php

define('DB_DRIVER', 'mysqli');

Is there somewhere else I can check?

Life is for the taking. It's everything else you need to pay for.
Anne Makes Lovely Candles


User avatar
New member

Posts

Joined
Sun Jul 22, 2012 11:12 pm
Location - Left hand corner as you enter the room, better feng shui.

Post by qahar » Wed Dec 02, 2015 3:56 pm

Since your config use mysqli, then possibly the light_db use modification (ocmod/vqmod) to intercept Opencart db library.

You can search "light_db" word at ocmod or vqmod cache.
If it's come from vQmod file than it's easy to adjust it, you just need to open the file and add the getServerInfo method.
But if it's on OcMod modification cache, you need to know what ext it is then modificate the file, disabled the current one, reupload the new one and generate new cache.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by mtjhost » Tue Feb 16, 2016 12:20 pm

Fatal error: Call to undefined method light_db::getServerInfo() in /home/mysite/public_html/vqmod/vqcache/vq2-system_library_db.php on line 31

I am getting this error. Kindly help me out. When click on the System Information link getting the Blank white page.

New member

Posts

Joined
Wed Apr 30, 2014 12:37 am

Post by qahar » Fri Feb 19, 2016 3:44 pm

You need to add getServerInfo manually to light_db class.
Please see my message here

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by qahar » Mon Mar 21, 2016 1:22 am

Updates

=== v.2.3.0 - OpenCart 2.2.x
+ Timezone info, with current date and time

=== 2.1.2 - OpenCart 2.1.x
+ Timezone info, with current date and time
+ Database name at Server Info

I also make tutorial on how to change OpenCart timezone that use this new Timezone information as refference.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by qahar » Tue Mar 22, 2016 2:48 pm

Updates

=== v.2.1.3
^ OpenCart 2.0.x and 2.1.x Compatibility

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by sistawig » Mon Apr 18, 2016 11:10 pm

I am getting 500 server error

www.xxxxxxxxxx.com is currently unable to handle this request.

No errors logged anywhere Vqmod logs, opencart error logs empty.

New member

Posts

Joined
Tue Nov 25, 2014 1:37 am
Who is online

Users browsing this forum: No registered users and 3 guests