Post by qahar » Wed Jun 20, 2012 2:34 am

System Information provide server info, system summary and folder permission that required or recomended by Opencart. It's also help you to check PHP setting and extension; and make sure your Opencart site meet the requirements to work well. And we hope that this small extensions will help you to provide extra information related to your site during support request you submit in Opencart forum.

You can download the System Information:
  1. From Opencart Marketplace: System Information
  2. From EchoThemes: System Information Product Info
    Note: No need to register to download.
System Information for OpenCart 2x
sysinfo.jpg

sysinfo.jpg (48.25 KiB) Viewed 6231 times

System Information for OpenCart 1.5.x
system-information.jpg

system-information.jpg (44.39 KiB) Viewed 14271 times

Roadmap
- phpinfo()

Image

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by rph » Wed Jun 20, 2012 3:56 am

Very cool. I've been working on adding some similar ideas to VQMod Manager to help devs troubleshooting issues so they don't have to play 20 questions when a user runs into issues with their script.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by qahar » Tue Jul 24, 2012 3:33 am

Update System Information v.1.1 released.

Now also check the permission of Error and vQmod logs file.
And we put full phpInfo report.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by madimar » Tue Jul 24, 2012 7:56 am

Great, really useful, finally a simple and clear tool to assist customers with problems with their servers.

Great job, thank you,

M

Sent from my DesireHD.

-----------------------------------------------------------------------
My last mods: Partita IVA e CF | Pro EU VAT Number | Sales Agents | Pricelist Pro
-----------------------------------------------------------------------


User avatar
Active Member

Posts

Joined
Thu Sep 24, 2009 6:27 pm


Post by matteoraggi » Sun Nov 18, 2012 9:29 pm

It work great! is all right on oc 1.5.3.1 it just say: file /vqmod/vqmod.log missing.
what it mean? How I an restore it?

http://www.restaurantsupplies.eu Restaurant Supplies
Opencart 1.5.6.4 VQMOD 2.4.1
Languages: Italian, French, German, Hungarian, English, Russian, Polish and Spanish


Active Member

Posts

Joined
Fri Apr 10, 2009 8:16 pm

Post by madimar » Sun Nov 18, 2012 10:28 pm

Hi Matteo, vqmod.log is usually present only when there are some errors... So you should be happy you don't have any.
Maybe that one is only a warning from system information tool.

M

-----------------------------------------------------------------------
My last mods: Partita IVA e CF | Pro EU VAT Number | Sales Agents | Pricelist Pro
-----------------------------------------------------------------------


User avatar
Active Member

Posts

Joined
Thu Sep 24, 2009 6:27 pm


Post by qahar » Sat Nov 24, 2012 12:22 pm

lance2012 wrote: 1.upload vqmod to vqmod on server
2. upload admin to admin-oc on server(because i rename admin to admin-oc)
3. clean the vqmod cache

but the system information tab was not display on the manu in backend, i suppose i should adjust
admin/view/template/common/header.tpl by manual
This step should help you:
  • Open vqmod/xml/system_info_admin.xml
  • Find <file name="admin/view/template/common/header.tpl">
  • Change admin to admin-oc

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by qahar » Thu Apr 18, 2013 10:28 pm

Updated to v.1.2

Changelog:
* Double check for Fsock
* Table pushed when the path is to long
^ Hide vQmod file permission report if the file/ folder is not available
+ mCrypt check for OpenCart v1.5.4 and forward.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by rana saheh » Sun Jan 19, 2014 2:33 am

very cool, very useful tool, really it was so great

My personal trainer poeme d amour proverbes français arabic seo seo arabic arabic translation services


Newbie

Posts

Joined
Sun Jan 19, 2014 2:25 am

Post by NVDon » Fri Mar 21, 2014 6:18 am

System Information works just fine but, I do have a question. I see a couple entries that show my PHP settings are not correct but on one of them, the green check mark is present and on the other, the red X is present.

The settings are as follows:

-- Setting ----------- Required --- Server --------- Status
Safe Mode ------------- Off -------- On ------- [green check mark]
Allow Url Fopen ------- On --------- Off ------ [red X]

See the attached screen capture for a better view of the situation.

Is this a problem with the System Information extension software or am I not understanding what this is telling me?
sysinfo-2014-03-20_1458.png

sysinfo-2014-03-20_1458.png (79 KiB) Viewed 9767 times


Newbie

Posts

Joined
Sat Jan 19, 2013 3:19 am

Post by qahar » Fri Mar 21, 2014 9:14 pm

Thank you for reporting, I think it's issue with the status mark.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by qahar » Tue Mar 25, 2014 2:04 am

System Information 1.3.1 update released

Changelog:
Fix typo of safe mode status

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by erlee » Sat Jul 26, 2014 2:17 pm

something is not quite right with the install procedure - if i upload the folder vqmod onto the root of my store - won't that overwrite my existing vqmod folder which is full of stuff..??

Newbie

Posts

Joined
Sat Jul 12, 2014 9:17 pm

Post by qahar » Tue Jul 29, 2014 3:50 am

SysInfo vQmod folder only contain two xml belong to System Information.

To ensure you not overide existing file, go to upload\vqmod\xml\ and upload two xml file belong to System Information to your site vQmod folder.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by schiggi » Sun Aug 10, 2014 1:14 am

I've got an issue with your awesome mod. After moving servers, I always get kicked out of the admin panel (sent me to the login admin page) when I click to php settings or pemission settings. Furthermore, on the main page at the line "Database Server version" there is a fatal error: "Call to undefined method DB::getServerInfo() in /var/www/vhosts/xxx/httpdocs/admin/view/template/tool/system_info.tpl on line 71"

Do you have an idea, what could be the problem?

New member

Posts

Joined
Tue May 13, 2014 4:23 am

Post by qahar » Mon Aug 11, 2014 4:21 pm

Does your vQmod working?
The issue indicate that System Information vQmod is fail to add getServerInfo() method to OpenCart database driver.

Ensure the vQmod is working and or clear vQmod cache.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by marcdat » Wed Feb 11, 2015 1:16 am

Opencart Version : 1.5.3.1

Got this error:

Database Server Version :
Fatal error: Call to undefined method MySQL::getServerInfo() in /home/webzzz/public_html/vqmod/vqcache/vq2-system_library_db.php on line 29

line 29: return $this->driver->getServerInfo();

Thanks in advance!

Newbie

Posts

Joined
Wed Feb 11, 2015 1:04 am

Post by qahar » Fri Feb 27, 2015 8:29 am

marcdat you have same issue as schiggi, and the error appear because the modification is not executed.

Ensure the vQmod is working and or clear vQmod cache.

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by akosidencio » Mon Apr 06, 2015 4:32 pm

is there any version compatible with OC2.0?

Newbie

Posts

Joined
Mon Apr 06, 2015 4:31 pm

Post by akosidencio » Mon Apr 06, 2015 4:39 pm

I would like to ask is there a plan to works this on OC 2?

Newbie

Posts

Joined
Mon Apr 06, 2015 4:31 pm
Who is online

Users browsing this forum: No registered users and 7 guests