Post by hawkish » Wed Apr 17, 2013 9:41 pm

Many thanks for this tool. Incremental import would be amazing - is it a possibility, I know it has been touted in the past as on the roadmap.

Newbie

Posts

Joined
Fri Oct 14, 2011 3:38 am

Post by kelemvor » Sat May 11, 2013 11:02 am

Does this export a hard coded list of fields or does it do a select *? My DB has an extra product field or two that don't seem to get exported. Is there a certain file I can modify to add it in or tweak the query?

Active Member

Posts

Joined
Fri Oct 12, 2012 6:58 am

Post by Destrifer » Mon Jun 03, 2013 7:43 pm

Hello JNeuhoff!
May you make export xlsx fles format?
Xls have limitation a 65000 lines.
The exported file is truncated to 65,000 lines.

Newbie

Posts

Joined
Mon Jun 03, 2013 7:37 pm

Post by oshrib » Thu Jun 06, 2013 7:54 pm

Hello JNeuhoff!
I want to use the great export/import tool with new field as "cptitle" (custom titles).

I been readen all the last pages, and tried to make it like you suggest there..but without succsseed.

Can you publish here export.php file with all the lines of "cptitle" for export\import ?

Thanks !

Newbie

Posts

Joined
Sun May 12, 2013 5:32 pm

Post by TriumphDesign » Wed Jun 12, 2013 11:06 pm

Hey there,

First and foremost, thanks a lot for this great extension, I'm using this tool for a few clients of mine.

Now I stumbled upon an error for the first time. I'm using OpenCart version 1.5.5.1 and the 1.5.5.1 version of the import / export tool.

Weirdly enough, I just copied a working opencart website to another server, copied the database too and on the older website the export goes fine but it borks on the new version.

I can't open the XLSX file when you click export and you download the XLSX file.

When I try to open it I get the following error:

Error: excel cannot open the file .xlsx because the file format or file extension is not valid, check if the file is damaged etcetc.

I CAN open it in openoffice but then I just get gibberish, I didn't change anything in the code so I'm really puzzled about this.

New member

Posts

Joined
Mon Jun 03, 2013 8:51 pm

Post by ranairfan » Wed Jun 26, 2013 3:53 pm

Fatal Error: Call to undefined method PHPExcel_Reader_CSV::setReadDataOnly() in D:\wamp\www\cheapBlank\admin\model\tool\export.php on line 1644,

i got this error while i importing file after successfully export by using this extension

Newbie

Posts

Joined
Thu Jun 13, 2013 3:03 pm

Post by JNeuhoff » Wed Jun 26, 2013 4:58 pm

ranairfan wrote:Fatal Error: Call to undefined method PHPExcel_Reader_CSV::setReadDataOnly() in D:\wamp\www\cheapBlank\admin\model\tool\export.php on line 1644,

i got this error while i importing file after successfully export by using this extension
Use XLS or XLSX file format for imports, with the same worksheets and columns.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by drewbagel423 » Tue Jul 23, 2013 8:25 am

Thanks for the great tool, has saved me a lot of time. The problem I'm having is that none of my product options are linking to the appropriate products. All the options are there in Catalog > Options, but then don't appear on the product pages.

Newbie

Posts

Joined
Thu Jul 18, 2013 9:53 am

Post by lucky2004alex » Fri Oct 04, 2013 3:17 am

Hello guys,
nice free module .I instaled and i want to use it.
But i get this error message.
Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 32 bytes) in /home/brisell/public_html/system/PHPExcel/Classes/PHPExcel/Style/Color.php on line 501
I have 1700 products.
I have tested with memory_linit=64/126/512/2048m
NOthing.pls help me.i need it

New member

Posts

Joined
Fri Aug 23, 2013 9:03 pm

Post by Ljubo » Sat Oct 19, 2013 3:59 am

I am using this fine tool for some time now.

I have a problem now.
Downloaded, made some changes and uploaded to the server.
Result is that all is working except display of articles in the last subcategory.
Although in brackets on front showing there are some articles in that ending subcategory, upon click on it, nor products could be found.
Admin side shows products in fine order.
Weird...

any hints?

Active Member

Posts

Joined
Mon Jan 31, 2011 10:07 pm
Location - Serbia

Post by butte » Sat Oct 19, 2013 7:56 am

Ljubo, anything odd about cells in those fields (columns), particularly "general" or other odd formats even though entries are okay? Where spreadsheet cells usually have ', ", ^ to format horizontal alignment, some of those might pass and cause problems; any odd cells in that way?

lucky2004alex, your php.ini values (mem only) are insufficient to support the tool, peek at http://forum.opencart.com/viewtopic.php ... 00#p447627 .

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Ljubo » Sat Oct 19, 2013 5:01 pm

thanks butte,
something is definitely wrong with formatting... because when I revert to old data via this tool, everyhing is OK.
something is wrongly formatted in my excell file.

Active Member

Posts

Joined
Mon Jan 31, 2011 10:07 pm
Location - Serbia

Post by butte » Sat Oct 19, 2013 11:42 pm

Okay, there are at least a couple of practical approaches.

if you can find a known good row, anywhere below the row 1 labels, just block copy that and block paste it into all rows below the row 1 labels. You may need to use a prior good file as source of the block to paste into a current file. Even if an older source file differs across the top. you can still pluck and plop selected cells or row segments spanning a few cells. Just be certain that all column labels are the same (what they say, and which columns are which), when you pluck and plop whole rows or row segments.

Check your preferences/settings/etc. (whatever they're called in your version), for the global formats, and for the spreadsheet/worksheet formats, to see whether defaults ("General" where you wouldn't want it, etc.) are interfering. For example, a plain bald integer can be forced to that, where the tool should not be loaded with "General" baggage or garbage (asking Excel to think is pushing the envelope anyway). Settings like that a-r-e nice for entering telephone numbers and addresses on the fly, where formalities of numbering are automatically made people-friendly as soon as alphanumeric mix shows up in a "General" cell. Databases are not for people-friendliness, and people-friendly cells can screw them up.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Ljubo » Sun Oct 20, 2013 3:29 am

I have found the problem...
it is SEO related.
when I disable it, everything is OK.
I guess I would have to delete all the caches, enable the SEO and check again.

Active Member

Posts

Joined
Mon Jan 31, 2011 10:07 pm
Location - Serbia

Post by butte » Sun Oct 20, 2013 3:55 am

That may be pinpointing which field's or fields' format(s) are goofy. Go ahead and kill caches, then retry with SEO, then look at SEO-related entries' cell formats.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Ljubo » Wed Oct 23, 2013 6:57 pm

well, it seems to me the problem is within the same SEO keywords on different sucategories and it is not related with Export/Import tool at all.

Active Member

Posts

Joined
Mon Jan 31, 2011 10:07 pm
Location - Serbia

Post by butte » Thu Oct 24, 2013 12:56 am

A trick for unique keywords or SKUs is to tie_the_terms_together_if_there_are_several. In the extensions store some authors go overboard with that, _ing entire paragraphs. You might give that a whirl -- in your spreadsheet you can ChangeAll spaces to underscores (" " to "_") and then in a twinkling you can try the result.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by Ljubo » Thu Oct 24, 2013 1:07 am

good idea, thanks!

Active Member

Posts

Joined
Mon Jan 31, 2011 10:07 pm
Location - Serbia

Post by j0cher90 » Mon Oct 28, 2013 3:33 am

Hello, i have a problem when i'm tring to import xls. I export the products from an opencart 1.4.9.3 and i want to import it into an opencart 1.5.4. When i click to import, i receive this message: Uploaded file is not a valid spreadsheet file or its values are not in the expected formats! I want to say that i installed the specific version for each opencart.
How can i solve this problem? Thank You Very Much.

New member

Posts

Joined
Wed Aug 01, 2012 11:19 pm

Post by butte » Mon Oct 28, 2013 4:19 am

j0cher90, you have two OC versions, each with the right tool version, BUT the two (sets of) TABLES are not laid out the same way, so the error is telling you that the "values are not in the expected formats!" for that reason. That is a significant version jump, it straddles significant core and database changes. One way around that is to make a perfect clone of the old one and upgrade it to 1.5.4.1 CE RC1 (see both http://forum.opencart.com/viewtopic.php ... 82#p444959 and http://forum.opencart.com/viewtopic.php ... 20#p445975).

Another wrinkle is your file format (you may have mistyped but that still raises the point). There are several versions of the .xls and .xlsx formats themselves, and not all Excel versions can open all of the others' files. You must SaveAs or Export into a format the the tool recognizes AND uses. Here you didn't get that far, because the two OC versions' tables are too different anyway.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am
Who is online

Users browsing this forum: No registered users and 4 guests