Post by remixer » Wed Sep 26, 2012 5:34 am

Thank you!

Newbie

Posts

Joined
Sun Mar 04, 2012 2:37 am

Post by wonderland » Mon Oct 01, 2012 8:05 pm

Thank you for all your hard work!

I also would like to know about multi-language, is it planned in near future ?

I remember that there was similair extension to yours a while back with multi-language support. But it has disappeared now, I'm guessing there were some copyright problems ?!

This was asked in this topic before, but there was no answer to that, so I would also like to find out is it possible to import products partly ? I'm on shared hosting and I'm experiencing memory problems after few thousand products.

Could I maybe split up excel file and import using few files instead of one , or would it overwrite current products?

New member

Posts

Joined
Wed Jun 15, 2011 8:25 pm

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by wonderland » Thu Oct 04, 2012 3:47 pm

Those are fantastic news !

New member

Posts

Joined
Wed Jun 15, 2011 8:25 pm

Post by soonkai » Wed Oct 10, 2012 1:35 pm

Hi JNeuhoff

Thanks for creating this extension. I have installed the module and the export working flawlessly. However when i added some products and try to import, after clicking the import button, it load up a blank white page, any advise?

Thanks!

Newbie

Posts

Joined
Wed Oct 10, 2012 1:33 pm

Post by JNeuhoff » Thu Oct 11, 2012 8:00 pm

soonkai wrote:Hi JNeuhoff

Thanks for creating this extension. I have installed the module and the export working flawlessly. However when i added some products and try to import, after clicking the import button, it load up a blank white page, any advise?

Thanks!
Unable to reproduce your error.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by jdoe » Sat Oct 13, 2012 9:49 pm

Installed without issue on 1.5.4.1 but the exported xls has no data - just a blank spreadsheet. Only have 3 products in the store currently (just starting up) if that has any influence. Any idea what is causing this?

Newbie

Posts

Joined
Sat Oct 13, 2012 9:25 pm

Post by JNeuhoff » Sun Oct 14, 2012 6:58 am

jdoe wrote:Installed without issue on 1.5.4.1 but the exported xls has no data - just a blank spreadsheet. Only have 3 products in the store currently (just starting up) if that has any influence. Any idea what is causing this?
Unable to re-produce your error, you are simply not giving enough details. Check all your logs, e.g. server's error_log, OpenCart's system/error.txt, and vqmod/vqmod.log.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by jdoe » Mon Oct 15, 2012 1:09 am

Hi - don't know where to look for my server's error log and cannot find vqmod.log file in vqmod folder

have however attached a file showing a large number of errors detected in the store log

hope this sheds more light on it for you

any help greatly appreciated

Newbie

Posts

Joined
Sat Oct 13, 2012 9:25 pm

Post by JNeuhoff » Mon Oct 15, 2012 4:22 am

jdoe wrote:Hi - don't know where to look for my server's error log and cannot find vqmod.log file in vqmod folder

have however attached a file showing a large number of errors detected in the store log

hope this sheds more light on it for you

any help greatly appreciated
You are using the wrong version of the Export/Import tool, use one that matches your OpenCart version.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by opencartnew » Mon Oct 15, 2012 3:37 pm

Hi there,

I'm on 1.5.2.1. And using "opencart-1-5-2-x-export-import-11".
I think this extension caused the following error to my site. It also stopped / blocked access for the users when they register a new account during checkout:

2012-10-15 5:00:03 - PHP Notice: Undefined index: wishlist in /home/xxxxxxx/public_html/xxxxxxxx/system/library/customer.php on line 70
2012-10-15 5:00:03 - PHP Notice: Error: Unknown column 'wishlist' in 'field list'<br />Error No: 1054<br />UPDATE customer SET cart = 'a:1:{i:100;i:1;}', wishlist = 'a:1:{i:0;s:3:\"100\";}', ip = '110.32.91.243' WHERE customer_id = '152' in /home/xxxxxxx/public_html/xxxxxxx/system/database/mysql.php on line 49
(repeating around 10 times)
..
..
..
2012-10-15 5:14:03 - PHP Notice: Error: Unknown column 'wishlist' in 'field list'<br />Error No: 1054<br />UPDATE customer SET cart = 'a:0:{}', wishlist = '', ip = 'xxx.xx.xx.xxx' WHERE customer_id = '152' in /home/xxxxxxx/public_html/xxxxxxx/system/database/mysql.php on line 49
(repeating around 10 times)
..
..
..
2012-10-15 5:15:10 - PHP Notice: Undefined index: wishlist in /home/xxxxxxx/public_html/xxxxxxx/system/library/customer.php on line 70
..


Any ideas how I could fix it? Thanks..
A

Newbie

Posts

Joined
Sun Oct 14, 2012 9:26 am

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by rukhairy » Sun Oct 21, 2012 10:15 pm

Hi,

I added a number of custom field for my store and tried to modify the import/export tool as well so that I can simply update all the details at once. I've attached the file that I'm using currently.

There is nothing wrong with exporting the data. Everything's fine except when I want to import the file again. It will follows by a blank white page. And here is the recorded error log:
2012-10-21 13:55:24 - PHP Notice: Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Takada',',',',',',',',',',176',Malay',April, 1999',Manga',Comics House',Kodansha' at line 1<br />Error No: 1064<br />INSERT INTO `product` (`product_id`,`quantity`,`sku`,`upc`,`location`,`stock_status_id`,`model`,`artist1`,`artist2`,`artist3`,`artist4`,`artist5`,`author1`,`author2`,`author3`,`author4`,`author5`,`pages`,`langs`,`year_published`,`book_type`,`publisher`,`original_publisher`,`url`,`material`,`capacity`,`printed`,`distributor`,`genre`,`editor`,`edition`,`issn`,`isbn`,`isbn10`,`isbn13`,`manufacturer_id`,`image`,`shipping`,`price`,`points`,`date_added`,`date_modified`,`date_available`,`weight`,`weight_class_id`,`status`,`tax_class_id`,`viewed`,`length`,`width`,`height`,`length_class_id`,`sort_order`,`subtract`,`minimum`) VALUES (1,100,'','','',5,'CDCHSZE001',Yuzo Takada',',',',',',',',',',176',Malay',April, 1999',Manga',Comics House',Kodansha ',',',',',',Action, Adventure, Drama, Fantasy, Mature, Romance, Seinen, Supernatural  ',',',1511-5569',',',',11,'data/cover/comics-house/3x3eyes/3x3eyes001.jpg',1,4.8,4800,'2011-10-03 13:30:16','2012-08-17 03:51:29','2011-10-03',0.2,1,1,10,853,0,0,0,'1','1','0','1'); in /home/comicsdi/public_html/system/database/mysql.php on line 49
I've no idea how to solve it. Is there anybody who can help me with this issue?
Thank you.

Attachments

Modified export.php


Newbie

Posts

Joined
Tue Jun 07, 2011 1:21 am

Post by rukhairy » Mon Oct 22, 2012 12:38 am

Never mind. I've solved the problem which I forgot to place apostrophe on each value.

Newbie

Posts

Joined
Tue Jun 07, 2011 1:21 am

Post by Saile » Mon Nov 05, 2012 5:13 am

I am using Export/Import Tool you made for 1.5.4.1

Is is possible to delete the CURRENT products on the xls file and only add the NEW products you want to import?

This would avoid OVERWRITING the products that are already on the website and only add the NEW products.

I have custom fields in my products that every time i upload the XLS and gets rid of the data that i have in them. If there was a way to upload only the new products you want on the site.

Your help is appreciated.

Active Member

Posts

Joined
Thu Jan 19, 2012 8:19 am

Post by PhoneMainiac » Mon Nov 05, 2012 6:15 am

Hi there,

I'm using the extension for version 1.5.4.1 and it works great but with my store i have over 21000 products and keep running out of memory, will there be an update to allow you to do staggered imports so that its not as memory intensive?

Other than that its a great module!! :)

Newbie

Posts

Joined
Mon Nov 05, 2012 6:12 am

Post by meggabecca » Tue Nov 06, 2012 5:28 pm

Hi

Because of memory issues, I spilt my spreadsheets into sections, but the problem is everytime I upload a spreadsheet, it gets rid of all the other products, so now back to square one, it seems most have memory problems this rubbish, can anyone suggest something else other than paying out £30 per month for dedicated server, which seems extreme, and can not validate paying that, so any other suggestions of finding a work around, to solve these memory issues...

Thanks in Advance

Newbie

Posts

Joined
Sun Jul 29, 2012 1:21 am

Post by wonderland » Wed Nov 14, 2012 8:47 pm

Hello!

I noticed one thing and was hoping you could help me solve it.

When importing products, all letters "š" are converted to "&scaron;" in database.
In store front this doesn't matter, but when receiving information about product in e-mail "&scaron;" is displayed instead of "š"
If I save product from store back-end "&scaron;" gets converted to "š" in database, but resaving all products would take way too much time.

Is there something I can do to change this behaviour ?

New member

Posts

Joined
Wed Jun 15, 2011 8:25 pm

Post by baillie11 » Mon Dec 03, 2012 11:06 am

Hi,

I have downloaded opencart-1-5-4-x-export-import-13.zip for OpenCart 1.5.4.1 and have been able to export without any problems, however, when I import products, I receive a message saying it has worked, however, none of the products appear in the admin-catalog-products area, nor on the front end.

I have checked and error logs in VQModManager & System-Error Logs and have even cleared them.

I have opened cart in different browser (in case the cache hasn't cleared properly). I even exported the data back out and it still doesn't appear in the spreadsheet.

Any suggestions on what I could be doing wrong (im presuming it me, not your software - lol).

Thanks

Andrew

User avatar
Newbie

Posts

Joined
Sun May 27, 2012 6:23 pm

Post by JNeuhoff » Mon Dec 03, 2012 6:49 pm

baillie11 wrote:Hi,

I have downloaded opencart-1-5-4-x-export-import-13.zip for OpenCart 1.5.4.1 and have been able to export without any problems, however, when I import products, I receive a message saying it has worked, however, none of the products appear in the admin-catalog-products area, nor on the front end.

I have checked and error logs in VQModManager & System-Error Logs and have even cleared them.

I have opened cart in different browser (in case the cache hasn't cleared properly). I even exported the data back out and it still doesn't appear in the spreadsheet.

Any suggestions on what I could be doing wrong (im presuming it me, not your software - lol).

Thanks

Andrew
Take a look at your PHP settings, as listed in the readme.txt, might be a timeout issue with your Import, or simply a file size issue for the upload during an Import.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 3 guests