Post by mihaidd » Sat Jun 06, 2015 10:49 pm

Hello Neuhoff, please, do you have any idea why a simple product import might not be working on OC 2.0.3.1 ? I get the success message, but products aren't imported... nothing in error log, only VQ mod & VQ mod manager installed, no extensions yet.
I tried to solve excel formatting issues, everything is text... still no luck.

Newbie

Posts

Joined
Sun Feb 19, 2012 2:25 am

Post by mihaidd » Tue Jun 09, 2015 10:51 pm

Please ignore me, I was being stupid, or the extension too smart :) I used the "export" file to paste values in there, and BAM! All my products imported! Thank you!!!!!

Newbie

Posts

Joined
Sun Feb 19, 2012 2:25 am

Post by jazzystahh » Tue Oct 06, 2015 6:57 am

I keep getting this error: 2015-10-05 22:53:41 - Export/Import: Invalid header in the Products worksheet

I am importing from 1.5.5.1 to 2.0.3.1

Where am I going wrong?

Newbie

Posts

Joined
Sat May 17, 2014 7:45 pm

Post by Cue4cheap » Tue Oct 06, 2015 8:49 am

jazzystahh wrote:I keep getting this error: 2015-10-05 22:53:41 - Export/Import: Invalid header in the Products worksheet

I am importing from 1.5.5.1 to 2.0.3.1

Where am I going wrong?

That^.

Did you do an export of your 2.0.3.1 store and then match the columns in the spreadsheet? They changed from 1.5.x to 2.x.

Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by Vizzuals » Thu Oct 08, 2015 11:33 pm

I get the same problem. I did the export. The store has one item and I copied all data into the exported fields so I can't see how the header is invalid.

Newbie

Posts

Joined
Thu Oct 08, 2015 11:21 pm

Post by JNeuhoff » Tue Oct 13, 2015 9:04 pm

Vizzuals wrote:I get the same problem. I did the export. The store has one item and I copied all data into the exported fields so I can't see how the header is invalid.
Use OpenOffice or LibreOffice, not MS Office, the latter has known bugs which MS won't fix.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by daniil_oc » Tue Oct 20, 2015 2:46 pm

Hello! Could I suggest a new feature for the module?
I have 6 special prices types, so it's quite hard to maintain. Could you change special tab
from

Code: Select all

product_id	customer_group	priority	price	date_start	date_end
to

Code: Select all

customer_group_1_name	priority	price	date_start	date_end	customer_group_2_name	priority	price	date_start	date_end	customer_group_3_name	priority	price	date_start	date_end	

Newbie

Posts

Joined
Mon Aug 19, 2013 4:05 am

Post by nurselotsaluv » Tue Jan 19, 2016 12:01 pm

I need some help! I see someone above had the same problem but was able to correct it.... I am able to get a Successful message with my import, however I am unable to get the products to actually show up.

To begin with I was unable to get the file to Import. I found that someone else with the same issue found that by saving the .xlsx as a .csv to begin with and then converting the .csv back to .xlsx fixed the error "Export/Import: Missing product_ids in worksheet 'Products'!".

Now I get a Successfully Imported message, but no products to be seen.

I opened the export file I downloaded prior to creating the import file and it was able to Import with the products appearing.

I updated the information in the export file to reflect a small (4 item) selection of the products I want to eventually add. Attempted to Import but got the "Export/Import: Missing product_ids in worksheet 'Products'!" error again. After saving in .csv and back to .xlsx I got the Successfully Imported... but alas... no products to do anything with.

I am in OC Version 2.1.0.1

Help!!! I am desperate and pulling my hair out :-(

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States

Post by JNeuhoff » Tue Jan 19, 2016 9:59 pm

nurselotsaluv wrote:I need some help! I see someone above had the same problem but was able to correct it.... I am able to get a Successful message with my import, however I am unable to get the products to actually show up.

To begin with I was unable to get the file to Import. I found that someone else with the same issue found that by saving the .xlsx as a .csv to begin with and then converting the .csv back to .xlsx fixed the error "Export/Import: Missing product_ids in worksheet 'Products'!".

Now I get a Successfully Imported message, but no products to be seen.

I opened the export file I downloaded prior to creating the import file and it was able to Import with the products appearing.

I updated the information in the export file to reflect a small (4 item) selection of the products I want to eventually add. Attempted to Import but got the "Export/Import: Missing product_ids in worksheet 'Products'!" error again. After saving in .csv and back to .xlsx I got the Successfully Imported... but alas... no products to do anything with.

I am in OC Version 2.1.0.1

Help!!! I am desperate and pulling my hair out :-(
This question has been answered many times over. For a start, stop using MS Excel, use LibreOffice or OpenOffice, and make sure you don't have empty lines in your worksheets (a common issue when using MS Excel!). Also, check for the obvious things such as: 1) Are the imported products in the database (PHPMyAdmin will help you to answer this). 2) Is your admin backend language also one of the supported frontend languages? 3) have you set the store_id column with the correct value? 4) Are there any warning or error messages in Opencart's system error log? Or in your server's error_log?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by nurselotsaluv » Wed Jan 20, 2016 10:30 am

JNeuhoff wrote:
This question has been answered many times over. For a start, stop using MS Excel, use LibreOffice or OpenOffice, and make sure you don't have empty lines in your worksheets (a common issue when using MS Excel!). Also, check for the obvious things such as: 1) Are the imported products in the database (PHPMyAdmin will help you to answer this). 2) Is your admin backend language also one of the supported frontend languages? 3) have you set the store_id column with the correct value? 4) Are there any warning or error messages in Opencart's system error log? Or in your server's error_log?
I apologize for overlooking the solution, I wasn't able to find it anywhere... I honestly searched for a few days before I decided to post.

But THANK YOU A MILLION TIMES!!! I downloaded LibreOffice and it worked like a charm. Darn MS Excel anyway!

You have made my month.

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States

Post by ilias » Tue Feb 02, 2016 8:03 pm

Hello, i am using OC Version 1.5.6.1.

Export is wroking fine but when i try to import, i get this error: Uploaded spreadsheet file has validation errors!

Error log : Export/Import: Invalid number of worksheets, 8 worksheets expected.

I have installed an Option Image module. Does it have something to do with it or is it something else?

Thank you.

Newbie

Posts

Joined
Tue Feb 02, 2016 7:56 pm

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by designbtw » Wed Feb 03, 2016 2:33 am

We are using Open Cart 1.5.6 and downloaded the specific Export/Import tool for that version. And we are using PHP version 5.5.3 plus we have VQMOD installed.

We loaded your Export/Import tool as instructed. No problem there. And we set-up the top administrator in the user groups as specified. And it now shows up in the Administration area dropdown under the System tab.

We left the default selections, just to try it out. However, when we attempt to export an XLSX file we get the warning error: COULD NOT CLOSE ZIP FILE PHP://OUTPUT

Any help you could provide would be appreciated.

Newbie

Posts

Joined
Wed Feb 03, 2016 2:18 am

Post by ilias » Wed Feb 03, 2016 5:16 am

There are 9 worksheets.
1. Products, 2. AdditionalImages, 3. Specials, 4. Discounts, 5. Rewards, 6. ProductOptions, 7. ProductOptionValues, 8. ProductAttributes, 9. ProductFilters

Newbie

Posts

Joined
Tue Feb 02, 2016 7:56 pm

Post by JNeuhoff » Wed Feb 03, 2016 5:40 am

You are using the wrong version of the Export/Import tool. There no such error message like 'Invalid number of worksheets'.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ilias » Wed Feb 03, 2016 6:04 am

I have installed the: opencart-1-5-1-to-1-5-6-x-export-import-multilingual-2-28.zip as i have OC Version 1.5.6.1.
So there must be something else and not the version.

Newbie

Posts

Joined
Tue Feb 02, 2016 7:56 pm

Post by JNeuhoff » Wed Feb 03, 2016 6:33 am

As I said, there is no such error message in the Export/Import tool V2.28. So I am unable to help you.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by nurselotsaluv » Mon Feb 15, 2016 11:36 am

I am trying to Export 'Categories' and 'Products'. However, the file that is exported and either opened or saved then opened is "corrupt". When I got it to open 'Categories' in LibreOffice Calc I got the following text:

Fatal error: 'break' not in the 'loop' or 'switch' context in /customers/2/d/c/theluvoffice.com/httpd.www/lotsaluv/system/PHPExcel/Classes/PHPExcel/Calculation/Functions.php on line 581

This is the first time I have tried to use the Export function since the update, and it worked great before.

Import still works.

Any ideas?

I am in OC version 2.1.0.2 - Import/Export V2.29

New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States

Post by JNeuhoff » Mon Feb 15, 2016 6:16 pm

nurselotsaluv wrote:I am trying to Export 'Categories' and 'Products'. However, the file that is exported and either opened or saved then opened is "corrupt". When I got it to open 'Categories' in LibreOffice Calc I got the following text:

Fatal error: 'break' not in the 'loop' or 'switch' context in /customers/2/d/c/theluvoffice.com/httpd.www/lotsaluv/system/PHPExcel/Classes/PHPExcel/Calculation/Functions.php on line 581

This is the first time I have tried to use the Export function since the update, and it worked great before.

Import still works.

Any ideas?

I am in OC version 2.1.0.2 - Import/Export V2.29
These is no line 581 in the Functions.php file. Looks like you are using a corrupted installation. Also, you shouldn't use functions nor formulas in your spreadsheet, just data only.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by nurselotsaluv » Tue Feb 16, 2016 5:48 am

JNeuhoff wrote: These is no line 581 in the Functions.php file. Looks like you are using a corrupted installation. Also, you shouldn't use functions nor formulas in your spreadsheet, just data only.
I am only using data, no formulas or functions. Like I said the Import is just fine. It is the Export that is telling me it is corrupt. I have attached a screenshot of the error when I attempt to Export both Products and Categories.

I re-installed the extension and am still having issues. If it is indeed a corrupted installation, how do I get a non-corrupted installation since I downloaded your file from the Extensions Directory.

Please advise.

Attachments

CaptureImportExport.JPG

Error when Exporting Categories and Products - CaptureImportExport.JPG (30.63 KiB) Viewed 5484 times


New member

Posts

Joined
Tue Jan 12, 2016 6:16 am
Location - United States
Who is online

Users browsing this forum: No registered users and 3 guests