Post by aifel » Mon Apr 09, 2012 5:40 pm

JNeuhoff wrote:
aifel wrote:Hi

I got the following error
Fatal error: Class 'PHPExcel_Style' not found in /home/aifel/public_html/ocart/system/PHPExcel/Classes/PHPExcel.php on line 121

I am using
OpenCart v1.5.2.1 and using the opencart-1-5-2-x-export-import-6.zip

Any help is greatly appreciated

Thanks
The PHPExcel_Styleis defined on line 36 in the file /home/aifel/public_html/ocart/system/PHPExcel/Classes/PHPExcel.php, so clearly a wrong error message. What is your PHP version?
My PHP version is 5.2.17

Newbie

Posts

Joined
Sun Apr 08, 2012 9:48 am

Post by JNeuhoff » Mon Apr 09, 2012 6:24 pm

Does the following file exist on your server?

/home/aifel/public_html/ocart/system/PHPExcel/Classes/PHPExcel/Style.php

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Xciso » Mon Apr 09, 2012 11:59 pm

JNeuhoff wrote:
Xciso wrote:Hi.
Every time i import products with this great tool my "view" been reset.
What can i do to not reset this?

If i have a box like "most viewed" in the store, it will be a problem.

Thanks!
Are you talking of the Products.viewed column?
Hi. Yes thats what i mean..

Active Member

Posts

Joined
Fri Jul 15, 2011 5:20 am

Post by aifel » Tue Apr 10, 2012 12:13 pm

JNeuhoff wrote:Does the following file exist on your server?

/home/aifel/public_html/ocart/system/PHPExcel/Classes/PHPExcel/Style.php

Hi,

Thanks for the heads-up.
There are few files missing in my folder which is also missing from opencart-1-5-2-x-export-import-6.zip

However, I've downloaded and copied some missing files from http://phpexcel.codeplex.com/ and it now works perfectly.

Thanks again

Newbie

Posts

Joined
Sun Apr 08, 2012 9:48 am

Post by JNeuhoff » Tue Apr 10, 2012 5:11 pm

aifel wrote:
JNeuhoff wrote:Does the following file exist on your server?

/home/aifel/public_html/ocart/system/PHPExcel/Classes/PHPExcel/Style.php

Hi,

Thanks for the heads-up.
There are few files missing in my folder which is also missing from opencart-1-5-2-x-export-import-6.zip

However, I've downloaded and copied some missing files from http://phpexcel.codeplex.com/ and it now works perfectly.

Thanks again
Which files exactly were missing?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by kylelnsn » Tue Apr 17, 2012 3:56 am

I can export no problem, but if I reimport and unedited or edited version i get the following error?

can anyone help?

Notice: Trying to get property of non-object in /public_html/system/PHPExcel/Classes/PHPExcel/Reader/Excel2007.php on line 177

New member

Posts

Joined
Mon Apr 09, 2012 9:52 pm

Post by JNeuhoff » Tue Apr 17, 2012 4:36 pm

kylelnsn wrote:I can export no problem, but if I reimport and unedited or edited version i get the following error?

can anyone help?

Notice: Trying to get property of non-object in /public_html/system/PHPExcel/Classes/PHPExcel/Reader/Excel2007.php on line 177
Use the XLS format!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by kylelnsn » Wed Apr 18, 2012 5:34 am

I did/Am using xls from mac office 2011

They are fine, open on windows and mac? just get the same error.

New member

Posts

Joined
Mon Apr 09, 2012 9:52 pm

Post by JNeuhoff » Wed Apr 18, 2012 6:46 pm

kylelnsn wrote:I did/Am using xls from mac office 2011

They are fine, open on windows and mac? just get the same error.
Obviously I am unable to reproduce your error. The error message indicates that a wrong format is used. Try OpenOffice to see if you can generate a proper XLS file.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by AndyGaskell » Sat Apr 21, 2012 4:54 am

I've been having some problems with this. I've used previous versions of the extension before, and found it to be really great, so was keen to use it again.

My OC version is 1.5.2.1
My php version is 5.3.6
I'm using the extension "opencart-1-5-2-x-export-import-6.zip"

It all installed fine, but when I export, I just get a junk corrupted xls file. There is only one product in the shop at the moment, I was exporting to get a xls to fill with products.

I've had a good read through this thread, and it's not the php ini settings for memory, as I have mine set pretty high. I also checked if anything was missing from the libraries (as that'd been mentioned) compared to http://phpexcel.codeplex.com/releases/view/26479 , but it looks fine, diff-ing the contents of once against the other. There are no errors, warnings or notices, so nothing much to go on.

So... any ideas anyone?

Some more info on the nature of the corrupted file...

Message on opening the file in Excel:
Image

The corrupt file once opened in Excel:
Image

I'm a web developer at http://www.ssofb.co.uk in Aberdeen, Scotland.
Got a random blog at http://www.andygaskell.blogspot.com/.


User avatar
New member

Posts

Joined
Thu Dec 10, 2009 3:59 am
Location - Aberdeen UK

Post by JNeuhoff » Sat Apr 21, 2012 5:02 am

Have you tried opening the file with OpenOffice? MS Office 2007 or later has some bugs as regards the support for XLS BIFF8 format, and, needless to say, trying to get Microsoft fix bugs is a futile exercise.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by AndyGaskell » Sat Apr 21, 2012 8:15 am

JNeuhoff wrote:Have you tried opening the file with OpenOffice? MS Office 2007 or later has some bugs as regards the support for XLS BIFF8 format, and, needless to say, trying to get Microsoft fix bugs is a futile exercise.
Thanks for the quick reply. I tried opening the xls file in Excel 2007 but also in Libre Office Calc 3.4.4 and it was the same in both.

I thought of a work around for the short term, OpenCart 1.5.1 has a very similar data structure for products, so I installed OpenCart 1.5.1 and installed opencart-1-5-1-x-export-import-6. That combination worked fine, so I exported a xls, filled out my product data, and imported it. Then, with phpMyAdmin I dumped the relevant tables from 1.5.1 and loaded them into 1.5.2.1. I know, it's a pretty clunky work around, but at least I got the products in.

It's odd that on my server the older version work fine, and the newer one doesn't. Initially I'd put the issue down to being some environment issue on my server, though maybe that's not the case.

I'm a web developer at http://www.ssofb.co.uk in Aberdeen, Scotland.
Got a random blog at http://www.andygaskell.blogspot.com/.


User avatar
New member

Posts

Joined
Thu Dec 10, 2009 3:59 am
Location - Aberdeen UK

Post by JNeuhoff » Sat Apr 21, 2012 9:24 pm

AndyGaskell wrote: It's odd that on my server the older version work fine, and the newer one doesn't. Initially I'd put the issue down to being some environment issue on my server, though maybe that's not the case.
The Export/Import tools for OpenCart 1.5.1.x and 1.5.2.x are identical, so something else must be wrong with your new server. If it works on your old 1.5.1.x, then it should also work on 1.5.2.x.

It's always worth checking all the log files, e.g.OpenCart's system/logs/error.txt, your server's error_log etc, anything which could give you a clue as to why it goes wrong on 1.5.2.x.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by liamcaff » Mon Apr 23, 2012 4:22 am

Hey I'm using Export/Import on OC 1.5.2.1

Everything was working pewrfectly until I added 7,500 products to my shop... Now I have almost 10,000 products and when I try to export the .XLS file I get a "504 Gateway Time-out" error...

Any ideas?

This same error happened the first time I tried to upload my newly updated XLS file, but didn't happen the second try... So My new large database XLS file is imported but won't export....

Any help would be much appreciated as this really is a great extension!

Thanks in advance!

New member

Posts

Joined
Wed Mar 21, 2012 9:20 pm

Post by liamcaff » Mon Apr 23, 2012 5:05 am

One other thing - the new multi language version for 1.5.2.1 doesn' have any readme.txt...

New member

Posts

Joined
Wed Mar 21, 2012 9:20 pm

Post by JonathanR » Mon Apr 23, 2012 8:43 pm

A life-save module. However, when the db grows this error can appear: Notice: Error: The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if t etc etc....

I think I have found a fix (use with caution & back-up!). Open admin>model>tool>export.php

Around about line 1723 on this file, you will see the following line:
$query = "SELECT c.* , cd.*, ua.keyword FROM `".DB_PREFIX."category` c ";

*BEFORE* this add:
mysql_query("SET OPTION SQL_BIG_SELECTS=1");

I tested the module before making this change and I got the error. I applied the change and uploaded the file and the error went away - the entire db was downloaded as a csv file. Just to make sure, I uploaded the unchanged export.php file and the error came back. It certainly seems to be a reliable fix. I really hope that helps somebody.

New member

Posts

Joined
Sun Apr 15, 2012 4:34 pm

Post by AndyGaskell » Mon Apr 23, 2012 10:38 pm

JNeuhoff wrote:
AndyGaskell wrote: It's odd that on my server the older version work fine, and the newer one doesn't. Initially I'd put the issue down to being some environment issue on my server, though maybe that's not the case.
The Export/Import tools for OpenCart 1.5.1.x and 1.5.2.x are identical, so something else must be wrong with your new server. If it works on your old 1.5.1.x, then it should also work on 1.5.2.x.

It's always worth checking all the log files, e.g.OpenCart's system/logs/error.txt, your server's error_log etc, anything which could give you a clue as to why it goes wrong on 1.5.2.x.
Hi JNeuhoff, sorry, I should have worded that better, they are both on the same server, so same configuration. I checked the logs too, and there was nothing related to this.

I'm a web developer at http://www.ssofb.co.uk in Aberdeen, Scotland.
Got a random blog at http://www.andygaskell.blogspot.com/.


User avatar
New member

Posts

Joined
Thu Dec 10, 2009 3:59 am
Location - Aberdeen UK

Post by SDSkisDan » Thu Apr 26, 2012 2:36 am

First I want to say that this tool has been immensely helpful as long as I've been using Opencart.

I recently moved our 1.5.1.3 site from a shared hosting provider to a VPS, and it seems like the time it takes for the export/import tool to generate the backup_categories_products.xls file has quadrupled. The spreadsheet, once exported, comes out at about 2.5MB. Import is also taking longer than it was before. My guess is there's a setting or two that I've missed or is configured differently on the VPS.

Have any idea would could be causing it? Any suggestions on which settings to modify in php.ini or the like? What settings should I take a look at to help? Any help would be appreciated.

Thanks.

New member

Posts

Joined
Fri Nov 25, 2011 3:59 am

Post by JNeuhoff » Thu Apr 26, 2012 4:58 am

SDSkisDan wrote:First I want to say that this tool has been immensely helpful as long as I've been using Opencart.

I recently moved our 1.5.1.3 site from a shared hosting provider to a VPS, and it seems like the time it takes for the export/import tool to generate the backup_categories_products.xls file has quadrupled. The spreadsheet, once exported, comes out at about 2.5MB. Import is also taking longer than it was before. My guess is there's a setting or two that I've missed or is configured differently on the VPS.

Have any idea would could be causing it? Any suggestions on which settings to modify in php.ini or the like? What settings should I take a look at to help? Any help would be appreciated.

Thanks.
There could be many reasons as to why it's slower on your VPS. Perhaps the server has a slower CPU, or perhaps your PHP engine is slower, e.g. not a FastCGI engine.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by SDSkisDan » Thu Apr 26, 2012 5:02 am

Ok, so as long as it doesn't time out or blank page me I'm alright? phpinfo shows that the server API is CGI/FastCGI. I just wanted to check and see if there was something else I was missing.

Thanks for the quick response.

New member

Posts

Joined
Fri Nov 25, 2011 3:59 am
Who is online

Users browsing this forum: Bing [Bot] and 3 guests