Post by inovateqsa » Sat Jul 18, 2015 6:02 pm

Good day,

I am using Opencart 1.5.6.4, and have 2gb of memory set as a resource limit.

I have been having a frustrating problem with the Import/Export tool by Jneuhoff for the past few days, and could really use some help as I have been unable to fix it myself - and I currently have a blank website because of it.
I really need some urgent help here, reverting to a previous backup of Opencart is an option - but it would set me back weeks of work.

3 Days ago I ran the product export and got the excel file ("backup_categories_products.xlsx").
I needed to change some product names that were using an abbreviation to the full word so I did a find and replace all (Replace "Xb360" with "Xbox 360"), then re-uploaded the file.

Upon the file being uploaded I was met with a blank screen, and I only had the 1st item in the list added - everything else was gone. I have tried removing items, re-ordering them, and a whole host of other changes, but in every single circumstance the same thing happens (Blank screen, only the 1st item is added, and nothing else). After cutting it down to a single item and removing the Language_id from the item I can get it to import without errors (so no blank screen) - but the item is missing. I was using version 2.24 at the time.

In frustration I updated to use the latest version (2.26), but I now have another problem as it appears as though the format of the excel file has changed so I cannot upload even a single item any more. I am unable to export as I have no items nor categories, and I get the error "Undefined offset: 0" when trying to export.

The excel file is too large for me to attach, I can however email to anyone willing to help.

Please can someone help me troubleshoot the cause of the problem?

I would really appreciate it.

New member

Posts

Joined
Wed Mar 19, 2014 8:22 pm

Post by inovateqsa » Sat Jul 18, 2015 7:23 pm

UPDATE.

Exact same problem with the new version as well. In fact, it happens even if I make no edits at all to the file.
After syncing* my items with Opencart, I downloaded the product list, then re-uploaded without editing anything and the exact same problem occurs.

I have attached the xls just in case there is something I am missing, please can someone help me resolve this?

*I use a php script to keep item's on my POS synced with Opencart, so I can get my item list back at least - but no descriptions, images, categories etc.

Error Log for the upload (at least, I believe this is related to the upload):

Code: Select all

2015-07-18 11:22:16 PHP Notice: Error: Duplicate entry '48756-0' for key 'PRIMARY'
Error No: 1062
INSERT INTO `product_to_store` (`product_id`,`store_id`) VALUES (48756,0); in /home/heroesof/public_html/system/database/mysql.php on line 50

Attachments


New member

Posts

Joined
Wed Mar 19, 2014 8:22 pm

Post by inovateqsa » Sun Jul 19, 2015 9:33 pm

This has been resolved.

New member

Posts

Joined
Wed Mar 19, 2014 8:22 pm

Post by saltsalty » Mon Jul 27, 2015 10:43 pm

Hey i have the same issue with this i have emailed you via website.

New member

Posts

Joined
Fri Mar 16, 2012 5:32 pm

Post by IP_CAM » Mon Jul 27, 2015 11:50 pm

>> I am using Opencart 1.5.6.4, and have 2gb of memory set as a resource limit. <<
JUST TO MAKE SURE:
Did you set the Memory Limit in your Server PHP Configuration Settings as well ?
Ernie
hitline.info/shop

Attachments

Opencart_memory_limit_error.jpg

memory set as a resource limit - Opencart_memory_limit_error.jpg (82.9 KiB) Viewed 3150 times


Contact: jti@jacob.ch
---
Demos:
OpenCart LIGHT 1.5.6.5: http://www.openshop.li/light/
OpenCart V-PRO 1.5.6.5: http://www.velomech.ch/shop/
V-PRO Multi Theme View: http://www.openshop.li/shop/
---
Downloads:
Free Github OC Downloads: https://github.com/IP-CAM
1'900+ FREE OC Extensions from the world's largest Github OC Archive.
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by saltsalty » Tue Jul 28, 2015 6:24 pm

Hi yeah all those settings are fine, the mod was working great until other night when i started to get duplicate errors.

New member

Posts

Joined
Fri Mar 16, 2012 5:32 pm

Post by RyanS1 » Thu Aug 06, 2015 12:59 am

I installed the Export/Import Tool for OpenCart 2.0x. The problem is, It does not update or add products to my store when I import (.xls) files. To ensure I had the right formatting I modified the file I exported from it and then imported it, and it still did not update the store. Is there something I can modify to fix this problem?

Newbie

Posts

Joined
Thu Aug 06, 2015 12:27 am

Post by BobDH » Thu Aug 06, 2015 6:00 pm

HI, I have this installed . OC 2.0.2 and it exports OK but, when I try to import it says '2015-08-06 9:39:37 - Export/Import: Missing product_ids in worksheet 'Products'!

Even though the product_id fields are filled.

Any idea as to why this should be please?

Tough products for an outdoor lifestyle
http://www.dhustone.com


User avatar
New member

Posts

Joined
Fri Dec 06, 2013 5:18 am
Location - Shropshire

Post by saltsalty » Sun Aug 16, 2015 11:48 pm

inovateqsa wrote:UPDATE.

Exact same problem with the new version as well. In fact, it happens even if I make no edits at all to the file.
After syncing* my items with Opencart, I downloaded the product list, then re-uploaded without editing anything and the exact same problem occurs.

I have attached the xls just in case there is something I am missing, please can someone help me resolve this?

*I use a php script to keep item's on my POS synced with Opencart, so I can get my item list back at least - but no descriptions, images, categories etc.

Error Log for the upload (at least, I believe this is related to the upload):

Code: Select all

2015-07-18 11:22:16 PHP Notice: Error: Duplicate entry '48756-0' for key 'PRIMARY'
Error No: 1062
INSERT INTO `product_to_store` (`product_id`,`store_id`) VALUES (48756,0); in /home/heroesof/public_html/system/database/mysql.php on line 50

Hey has anybody got the solution to this issue?

Thanks

New member

Posts

Joined
Fri Mar 16, 2012 5:32 pm

Post by amitverma12679 » Fri Aug 21, 2015 3:55 am

Hi Support,

We are using your extension and its working perfectly, just let us know that how we set the value of "REQUIRED SHIPPING" field in the OPENCART, because there is not option to set this value in the CSV File.

Please suggest ASAP.

Amit Verma


Posts

Joined
Fri Aug 21, 2015 3:30 am
Who is online

Users browsing this forum: No registered users and 5 guests