Post by Kirthi » Thu Mar 26, 2015 12:47 pm

I tried to install extension using extension installer in opencart 2.0.1.1 but I get error message like

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
OK
<b>Warning</b>: ftp_login(): Sorry, cleartext sessions are not accepted on this server. in <b>/mystore.com/admin/controller/extension/installer.php</b> on line <b>295</b>{"error":"Could not login as mystore"}

But the FTP details are correct.

Please help.

Newbie

Posts

Joined
Wed Mar 18, 2015 4:45 pm

Post by trickyzxr » Tue Mar 31, 2015 7:20 pm

Hi I think this could be the way the password is maybe being passed. If you install via the extensions installer the QickFix-1.1.1 (current version) and then disable the ftp in your systems settings it will allow you to upload extensions. Also means one less ftp account password floating around.

I just had this problem and resolved it with above thanks to QuickFix.

New member

Posts

Joined
Tue Mar 06, 2012 11:46 am

Post by Kirthi » Mon Apr 06, 2015 5:26 pm

But when I install QuickFix and disable ftp it shows ftp must be enabled.

Newbie

Posts

Joined
Wed Mar 18, 2015 4:45 pm

Post by GoldenTongs » Tue Oct 13, 2015 3:20 pm

go to:
admin/controller/extension/installer.php

change:

Code: Select all

$connection = ftp_connect($this->config->get('config_ftp_hostname'), $this->config->get('config_ftp_port'));
to:

Code: Select all

$connection = ftp_ssl_connect($this->config->get('config_ftp_hostname'), $this->config->get('config_ftp_port'));
or make a vqmod/ocmod to do this change

http://Lilphones.com
Image


Active Member

Posts

Joined
Sun Jul 29, 2012 5:26 pm
Who is online

Users browsing this forum: No registered users and 2 guests