Page 2 of 4

Re: EXPORT / IMPORT version

Posted: Mon Mar 10, 2014 8:31 pm
by butte
civelek08, it was telling you that 64M was not high enough -- raise that to 512M (as shown above).

Pat251, for "open_basedir restriction" ask host support to check your tmp directory and sessions storage.

EmcoDerp, allowed memory size is set (best in powers of 2, such as 128M, 256M, 512M) in php.ini (yours or the server's master), regardless of the physical ram installed.

overkill and dragos.m, try resetting your php.exe to 5.3.x in your control panel.

greenk, what do your system and vqmod error logs, and what do your server error logs (if you have the in directories or in control panel) show?

shalianahe, which version of the tool did you install?

Re: EXPORT / IMPORT version

Posted: Wed Mar 19, 2014 8:40 pm
by inovateqsa
Having a slight issue i can't seem to resolve:

I installed the Export/Import extension as per the instructions - Upload the Admin and System folders, then the VQmod folder, then tick them in the top administrator account.

i can access the import/export tool from the system menu now, but I originally had a problem with memory allocation, - I fixed it by editing the PHP.ini's to allow more memory as per your previous suggestions.

Now I have found a new problem that I can't seem to resolve:
Whenever i try to import I get the following error:

"Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's Toolkit Logo.png', 72, 0, 1, 0, '2014-03-12 13:55:48','2014-03-12 14:19:32', 1' at line 1
Error No: 1064
INSERT INTO `category` (`category_id`, `image`, `parent_id`, `top`, `column`, `sort_order`, `date_added`, `date_modified`, `status`) VALUES ( 160, 'data/MTG/Deckbuilder's Toolkit Logo.png', 72, 0, 1, 0, '2014-03-12 13:55:48','2014-03-12 14:19:32', 1);
See also 'System > Error Logs' for more details."

As I do not understand MySQL syntax this is something i do not know how to fix.

Any help would be greatly appreciated.


Re: EXPORT / IMPORT version

Posted: Thu Mar 20, 2014 8:37 pm
by Cue4cheap
Your answer is in the error. It says: 's Toolkit Logo.png'

It is part of this: 'data/MTG/Deckbuilder's Toolkit Logo.png'

the 's on Deckbuilder's is screwing with the values. Remove the ' and it will work.


Re: EXPORT / IMPORT version

Posted: Fri Mar 21, 2014 1:28 am
by butte
Agreed. Delete ' BUT IN ALL occurrences -- including the directory name where you see Deckbuilder's, otherwise there will be mismatch between database and disc paths. The alternative of escaping the ' with \, as in Deckbuilder\'s, is best avoided, just change every Deckbuilder's to Deckbuilders.

Re: EXPORT / IMPORT version

Posted: Sat Mar 22, 2014 12:27 am
by openact
I downloaded and installed version for 1.5.6.

Just after I edited window with multichoice dropdown lists for 'Access' and 'Modify' rights and checked 'them' - all within the System/Users/User Groups - Top Administrator Tab, I got:
You do not have permission to access this page, please refer to your system administrator.

I did read the readme.txt - obviously - I always do.

Please note: I did already have vqmod and override already installed and I have uploaded 'all' folders within upload folder to the root [as per usual] correctly with no error reported by Filezilla.

Protection [chmod] is correct and although I use a file/folder protection system, it was set to 'pants-down level'

Any help appreciated.


PST just remembered I can see 2 instances of Export/Import within the System Menu drop down and only those 2 links work, all others I get the Permission problem!

Re: EXPORT / IMPORT version

Posted: Sat Mar 22, 2014 12:50 am
by openact

I just tested the to Export/Import duplicated links and I get with both links, when I try to export:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 81 bytes) in /home/.../.../system/PHPExcel/Classes/PHPExcel/Style/Supervisor.php on line 123


Re: EXPORT / IMPORT version

Posted: Sat Mar 22, 2014 9:33 am
by cbake6807
Adding the following Indexes to the database tables decreased export time to about 10s, as compared to several minutes..

TABLE: oc_product_option
product_option_id product_option_id 2 btree
product_id product_id 1 btree
option_id option_id 1 btree

TABLE: oc_product_option_value
product_option_value_id product_option_value_id 2 btree
option_value_id option_value_id 1 btree

AWS, Ubuntu Linux, PHP-FPM 5.5
Downgraded Export plugin to 1.5.4 as per previous comments

2784 oc_product_option records
5204 oc_product_option_value records

Re: EXPORT / IMPORT version

Posted: Sat Mar 22, 2014 12:49 pm
by Cue4cheap

Please do a search for that allowed memory.... "error". You will find bunches and bunches of posts about it, and how to fix.


Re: EXPORT / IMPORT version

Posted: Sat Mar 22, 2014 4:38 pm
by openact
Hi Mike

OK, will do.

M ;)

ADDITION: I just remembered the reason why I asked - I always check Forums first, before I ask for help.
I already had a look at the error and the limit is fine! But I will continue to see if there are/were other in MY particular situation.

Resource Limits memory_limit 192M

By the way, my version is for OC 1.5.6 and not and I was only exporting, not importing!
I contacted host to raise that value, but it seems strange - really.
It was not a 'new' install of Export/Import - I already had version 16 [ I believe] installed.

Re: EXPORT / IMPORT version

Posted: Sat Mar 22, 2014 5:54 pm
by openact
I believe a better post for 'my' problem is this one:

I now can Export, but still have same permission error as the post_max_size is actually 8M [using phinfo.php]!
Therefore I asked my Host to check if there is 'another' php.ini [their own] interfering with mine, as I have added the line I asked Host to check if there is a php.ini interfering with mine as I added the line:

post_max_size = 256M; and no change.

I wishED we could 'choose' how to export/import - example XLS instead of XLSX !
That would Help A Lot! and then there was in the same post!
I do agree with scr33ky [as suspected!] and I am not a coder, but having a good logical mind I can see by the 'simple' behaviour of this MOD, it is not well written - obviously!

I wish I had more time to get back into learning PHP 'better' than I know it. I fixed so many PHP files in the years without being a coder [as PHP is pretty clear, if you get into it] - but this one was the hardest and had to seek help around OC forums.

Still, thanks for the Export/Import MOD - it certainly helps when it works.

I do not have a memory error any-more - although I wish this MOD would not use a HUGE amount of memory for a mere 150kb file I have at present!
I can now Export/Import using XLS instead of XLSX [main reason why I upgraded hoping they did add it ...].

But it stills give me PERMISSION problem on ALL other Links within System - AAAAGH!

I cannot RESTORE the site as the PERMISSION problem stops me!
Ridiculous, one thing is having problems once in a while - understandable, another is THIS problem.

I will have to manually check ALL files within this MOD and reinstate the culprit one - It has probably 'nothing' to do with Memory size!

################################## CONCLUSION ? - NOT ###############################################

I have even uploaded a backup of the website - replacing the faulty one - same results.
config.php files are fine and I have also tried without SSL on config files and htaccess - although all was fine under SSL.
Never had one problem.



Posted: Mon Mar 24, 2014 9:02 pm
by openact
After having tried first various things [before I attempted the following] with no result, I finally attempted 'the obvious'

I went to phpMyAdmin and checked out the table xxx_user_group and in particular the TOP ADMINISTRATOR section - i.e. the PERMISSION field - because it is obviously 'it' the one that controls the Permissions!

I copied/pasted/saved somewhere in my computer, the original data in it and I copied/pasted in the permission field one I had of 2 months ago - extrapolated from a DataBase back, to see if it would work.

Well, it did and almost everything worked but vqmod [which I also tried to re-install, etc. - but without over-writing on vqmod folder for 'safe' keeping.

So, at this point I was ok and I asked my host if they had a [recurrent] server backup of my Database from a certain date backwards and they did.

So, I simply asked to write over the xxx_user_group table and it worked.

Anybody in similar situation can use this method.

Be careful of what you do and only do it if it is the last resort - having a 'fresh' backup is the best thing and will probably avoid you to re-install all or most Extensions/modules and waste a lot of time!


Re: EXPORT / IMPORT version

Posted: Thu Mar 27, 2014 7:01 pm
by inovateqsa
@Cue4Cheap - Thanks! Realized shortly after posting what the problem was.
I'm going with the "I was tired" Excuse.

There is another problem now though, and this time I am utterly exasperated:
99% of the time I try to export my products I get th "Error 404 - Page not found" error.
I have gotten the export to work exactly 3 times so far, but having to repeatedly try the export multiple times is becoming a huge waste of time - The last time I needed to click the export button in excess of 50 times before it would export, while the one time it worked straight away.

Does anyone have any idea what can cause this so i can try to fix it?

Thanks again!

Re: EXPORT / IMPORT version

Posted: Fri Mar 28, 2014 5:12 am
by Cue4cheap
What are your settings in your php.ini file?


Re: EXPORT / IMPORT version

Posted: Fri Mar 28, 2014 8:05 pm
by inovateqsa
I am using the recommended setting from the Import/Export page but I left everything else as default so:

The PHP.ini in the root directory:

Code: Select all

magic_quotes_gpc = Off;
register_globals = Off;
default_charset	= UTF-8;
memory_limit = 512M;
max_execution_time = 300;
post_max_size = 999M;
upload_max_filesize = 998M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 172800;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;
And The PHP.ini in my Admin folder:

Code: Select all

magic_quotes_gpc = Off;
register_globals = Off;
default_charset	= UTF-8;
memory_limit = 512M;
max_execution_time = 300;
post_max_size = 999M;
upload_max_filesize = 998M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
allow_url_fopen = on;

Re: EXPORT / IMPORT version

Posted: Tue Apr 01, 2014 3:43 pm
by dragos.m
I have the same problem with export, import works good, but export returns error 99.9% of the time, no matter how much I have in php.ini settings.I even tried it on local machine without any limit and still returns 404 page.

Re: EXPORT / IMPORT version

Posted: Fri Apr 04, 2014 7:51 pm
by Chased13
First thing... this extension rocks! Can't believe it's free!

Second thing... when I try to import product options for "half sizes" for instance shoe sizes where the option value has a decimal point, upon importing all my .5 decimal places seem to round up. This creates duplicate sizes.

For example, 9.5 rounds up to 10 so on importing I get duplicate options with the value 10.

When I export my decimal places show up correctly in the excel file, so this issue only happens when I import.

Does anyone know how I can fix this? It seems like the import forces my option value to be an integer and automatically rounds the decimal place. Should be an easy fix, I just don't know where to look/edit. I've tried searching but I don't see anyone else with this issue... but I would think anyone importing shoe sizes (or any option with a decimal point value) would have this issue.

Currently I have to manually adjust all my shoe sizes values every time I use the tool, which is a pain. A fix would be a gift from the gods!!!

Re: EXPORT / IMPORT version

Posted: Fri Apr 11, 2014 1:27 am
by wjhazel
Running OC - installed Export/Import to match version. Abel to export the database, but importing I seem to be having issues with. Throws the following error:

Code: Select all

2014-04-10 10:18:47 - Export/Import: Invalid header in the Rewards worksheet
I've even exported the file and then immediately tried to import it but still getting the same error. Any ideas?

Re: EXPORT / IMPORT version

Posted: Mon Apr 14, 2014 7:53 pm
by bignana60
First thank-you for this mod. If i get it to work I will be so grateful. My problem is when exporting so that I can get the correct format to import with it only exports one sheet. I have about 70 products on my site that I loaded manually,but it won't export those. I am a newbie , but I am a quick study. Could someone please point me in the right direction? I am using opencart v. and I downloaded the correct file, changed memory limit via instructions on site and permissions are all changed to 755.

Re: EXPORT / IMPORT version

Posted: Tue Apr 15, 2014 12:07 am
by bignana60
Sorry, problem was in my excel program.

Re: EXPORT / IMPORT version

Posted: Sun Apr 27, 2014 7:25 pm
by xavierwong
Hi, I encountered this error after i installed opencart-1-5-6-x-export-import-17.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Did anyone encountered this and has a solution for this?