Post by ajojavi » Mon Dec 02, 2013 8:38 pm

Hi, I read a lot of thing about this but I don´t find the clue to fix it.

This is what appear: Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 3145728 bytes) in /home/ajojavi/public_html/www.fluid-house.com/ocart/system/PHPExc ... ksheet.php on line 1123

This is my settings in .htaccess

<IfModule mod_php5.c>
# limit the maximum memory consumed by the php script to 256 MB
php_value memory_limit 256M
# register_globals is deprecated as of PHP 5.3.0 - disable it for security reasons.
php_value register_globals 0
# post_max_size is the maximum size of ALL the data that is POST'ed to php at a time (800 MB)
php_value post_max_size 838860800
# upload_max_filesize is the maximum size of a single uploaded file (500 MB)
php_value upload_max_filesize 524288000
# on development servers, set to 1 to display errors. Set to 0 on production servers.
php_value display_errors 0

¿What I can do?

Thanks

New member

Posts

Joined
Thu Oct 24, 2013 8:51 pm
Location - Spain

Post by butte » Tue Dec 03, 2013 1:32 am

Try starting with these lines in your php.ini files:

memory_limit = 512M;
post_max_size = 999M;
max_execution_time = 300;
upload_max_filesize = 998M;

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by ajojavi » Tue Dec 03, 2013 1:50 am

I have these...

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 512M;
max_execution_time = 36000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 172800;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;

New member

Posts

Joined
Thu Oct 24, 2013 8:51 pm
Location - Spain

Post by butte » Tue Dec 03, 2013 2:05 am

Stick with the 36000 since you are getting away with it.

These two should both be there, and the post value MUST EXCEED the upload value (nullified, if = or vice-versa):

post_max_size = 999M;
upload_max_filesize = 998M;

.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by ajojavi » Tue Dec 03, 2013 2:28 am

Ok I change and add the lines, and no changes...

New member

Posts

Joined
Thu Oct 24, 2013 8:51 pm
Location - Spain

Post by butte » Tue Dec 03, 2013 2:57 am

You will quite literally need to consider changing servers. The server is ignoring your php.ini files. If you cannot set any php.ini values in your host control panel, then you can ask support to change them for you. If support will not do that, then no matter what you try you will hit the piddly 64M memory limit. It was, however, nice of them to have register globals, magic quotes, and safe mode all off. Some hosts cannot get even that much right.

Which version is it? The question is not trivial and it is expected that people will start with that.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by ajojavi » Tue Dec 03, 2013 3:29 am

Sorry, it is true.
My opencart is 1.5.6. , the module is 1.5.6 , I have two php.ini One in the www folder and other in the main folder of my hosting, I just changed both. And the issue is there...

These are my settings in the php panel in my server...

File Uploads file_uploads Whether to allow HTTP file uploads. On
File Uploads upload_max_filesize Maximum allowed size for uploaded files. (MB) 998
Resource Limits max_execution_time Maximum execution time of each script, in seconds 300
Resource Limits max_input_time Maximum amount of time each script may spend parsing request data. (seconds) 60
Resource Limits memory_limit Maximum amount of memory a script may consume (MB) 2190
Data Handling magic_quotes_gpc Magic quotes for incoming GET/POST/Cookie data. On
Data Handling magic_quotes_runtime Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc. Off
Data Handling post_max_size Maximum size of POST data that PHP will accept. (MB) 999
Data Handling register_globals You should do your best to write your scripts so that they do not require register_globals to be on; Using form variables as globals can easily lead to possible security problems, if the code is not very well thought of. Off
Safe Mode safe_mode Safe mode is a diagnostic mode. Do not enable if you are unsure what you are doing Off
Language Options output_buffering Output buffering allows you to send header lines (including cookies) even after you send body content, at the price of slowing PHP's output layer a bit. You can enable output buffering during runtime by calling the output buffering functions. You can also enable output buffering for all files by setting this directive to On. If you wish to limit the size of the buffer to a certain size - you can use a maximum number of bytes instead of 'On', as a value for this directive (e.g., output_buffering=4096). Off
Error handling and logging display_errors Print out errors (as a part of the output). For production web sites, you're strongly encouraged to turn this feature off, and use error logging instead (see below). Keeping display_errors enabled on a production web site may reveal security information to end users, such as file paths on your Web server, your database schema or other information. On

New member

Posts

Joined
Thu Oct 24, 2013 8:51 pm
Location - Spain

Post by butte » Tue Dec 03, 2013 3:38 am

Bingo, at least in part.

This one is wrong, Magic quotes gpc should be OFF:
Data Handling magic_quotes_gpc Magic quotes for incoming GET/POST/Cookie data. On
Data Handling magic_quotes_runtime Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc. Off

This one is liberal, it would probably be well to change it to 2048:
Resource Limits memory_limit Maximum amount of memory a script may consume (MB) 2190

These are right:
Data Handling post_max_size Maximum size of POST data that PHP will accept. (MB) 999
File Uploads upload_max_filesize Maximum allowed size for uploaded files. (MB) 998
Resource Limits max_execution_time Maximum execution time of each script, in seconds 300
Resource Limits max_input_time Maximum amount of time each script may spend parsing request data. (seconds) 60

These are right:
Data Handling register_globals You should do your best to write your scripts so that they do not require register_globals to be on; Using form variables as globals can easily lead to possible security problems, if the code is not very well thought of. Off
Safe Mode safe_mode Safe mode is a diagnostic mode. Do not enable if you are unsure what you are doing Off

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by ajojavi » Tue Dec 03, 2013 3:58 am

Ok, I will check tomorrow.. here in Spain is near 9 Pm, 12 hours in front of my computer.. my brain is going to blow out..
Thanks for your advices.

New member

Posts

Joined
Thu Oct 24, 2013 8:51 pm
Location - Spain

Post by butte » Tue Dec 03, 2013 4:38 am

Okay, :40 elapsed, supper break is over. Actually, we certainly don't want a meltdown. Sleep well.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by ajojavi » Fri Dec 06, 2013 8:01 pm

The issue is the same.
Maybe is a problem with some of the extensions I have installed.
Two weeks ago, (and 200 products) It works perfect but now not.. maybe I exceed the excell rows engine...
I change the magic quote to off.
I couldn´t change the esource Limits memory_limit Maximum amount of memory a script may consume (MB) 2190 to 2049 because I can not write more than three numbers in the box (weird).

Thanks for your help to everybody

New member

Posts

Joined
Thu Oct 24, 2013 8:51 pm
Location - Spain

Post by fastkguy » Sun Dec 22, 2013 12:06 pm

I am now having the same issue and same error message. When I uploaded 500 or items it worked flawless but after adding several thousand I have the same issue. Did you figure anything out?

Newbie

Posts

Joined
Thu Sep 19, 2013 6:28 am

Post by butte » Mon Dec 23, 2013 2:59 pm

You should not need to raise mem above 512M, but if you do use 1024M -- binary progression (2,4,8,16,...). Be sure that in addition to magic_quotes, both global_variables and safe_mode are OFF.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by frankleng » Thu Aug 14, 2014 7:41 pm

I just added post_max_size = 999M; for php.ini in both root and admin folders.
It works.
Now, it is like this for root/php.ini:
magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
post_max_size = 999M;
max_execution_time = 36000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 172800;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;


For admin/php.ini
it's:
magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
post_max_size = 999M;
max_execution_time = 18000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
allow_url_fopen = on;

www.tayoutec.com


Active Member

Posts

Joined
Sun Apr 22, 2012 5:49 pm
Who is online

Users browsing this forum: No registered users and 3 guests