Post by JNeuhoff » Sat Sep 11, 2021 1:27 am

Any ideas? TIA!
Yes, read the documentation which says this:

Requirements and Limitations
Use version 4.10 of the Export/Import tool for systems with PHP Version 7.2 or later.
Older PHP versions are still supported by our older version 3.22 of the Export/Import tool.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by h4gen » Thu Sep 23, 2021 6:40 pm

Hello
I`m trying to install opencart-1-5-1-to-1-5-6-x-export-import-multilingual on my ocstore 1.5.5.1.2
As I see in your redme, your extension needs PHP 7.2 but OCStore 1.5.5.1.2 uses PHP5.3. When I`m trying to update PHP I get error 500 so I have to return PHP 5.3
How to make your extension work on PHP 5.3?

Newbie

Posts

Joined
Wed Jan 29, 2020 11:29 pm

Post by JNeuhoff » Thu Sep 23, 2021 10:05 pm

Use opencart-1-5-1-to-1-5-6-x-export-import-multilingual-3-22.zip for your older PHP version.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by saeed1000 » Wed Dec 15, 2021 12:10 am

hello
I use Export/Import Tool v 4 for opencart 3.0.3.7 running on php8
every thing works fine
but i see this notification on opencart error log

Code: Select all

PHP Unknown:  Function libxml_disable_entity_loader() is deprecated in /home/*******/public_html/shop/system/library/export_import/vendor/phpoffice/phpspreadsheet/src/PhpSpreadsheet/Reader/Security/XmlScanner.php on line 78
what is the problem? can you help me?

Newbie

Posts

Joined
Wed Dec 11, 2013 4:04 am

Post by JNeuhoff » Wed Dec 15, 2021 12:30 am

This issue is with the PHPOffice library used by the Export/Import tool and is described here:

https://githubmemory.com/repo/PHPOffice ... ssues/2125

We'll add a newer version of PHPOffice to the next version of the Export/Import tool. In the meantime, as you said, you can ignore these messages.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by lancestevenallison » Tue Dec 21, 2021 8:15 am

I am trying to install opencart-2-x-export-import-multilingual-4-10.ocmod.zip on OpenCart 2.0.2.0
When I upload the extension I get the following error;

SyntaxError: Unexpected token < in JSON at position 0 parseerror

FTP is all setup and we have uploaded other extensions. Any suggestions?

Thanks.


Posts

Joined
Tue Jul 13, 2021 8:12 pm

Post by FollaKy » Fri Dec 24, 2021 5:55 pm

Hi!

I'm developing a shop locally on XAMPP with PHP 7.4.21 and was trying to import some products using Export/Import Tool (V4.10) for OpenCart 3.x
I'm getting the following error message a bunch of times in the log:

PHP Unknown: Array and string offset access syntax with curly braces is deprecated in C:\xampp\htdocs\opencart3\system\library\export_import\Classes\PHPExcel\Shared\String.php on line 526

I read that other people had this issue as well with the mention of an update coming soon. As I understand it, I'm already using the updated version, or am I mistaken?

What to do? Any help is greatly appreciated.

Bets
Olli

Newbie

Posts

Joined
Thu Jun 13, 2019 2:33 pm

Post by JNeuhoff » Wed Dec 29, 2021 1:30 am

FollaKy wrote:
Fri Dec 24, 2021 5:55 pm
Hi!

I'm developing a shop locally on XAMPP with PHP 7.4.21 and was trying to import some products using Export/Import Tool (V4.10) for OpenCart 3.x
I'm getting the following error message a bunch of times in the log:

PHP Unknown: Array and string offset access syntax with curly braces is deprecated in C:\xampp\htdocs\opencart3\system\library\export_import\Classes\PHPExcel\Shared\String.php on line 526

I read that other people had this issue as well with the mention of an update coming soon. As I understand it, I'm already using the updated version, or am I mistaken?

What to do? Any help is greatly appreciated.

Bets
Olli
You are not using version 4.10 of the Export/Import tool, because this version doesn't have the folder system\library\export_import\Classes\PHPExcel\.
Version 4.10 uses PHPOffice, not the old PHPExcel library.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Thu Dec 30, 2021 9:54 pm

We have now released V4.11 of the Export/Import tool.
It contains an upgraded PHPOffice library with bugfixes and better performance.
And it also now has a new manufacturer export-filter.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by travkovs » Thu Jan 13, 2022 12:33 pm

Question! Why doesn't this module export the H1 header ?
Maybe I'm doing something wrong?
1) Did the export
2) Corrected the data
3) I do import
4) I look at the goods, and all H1 are deleted there

Newbie

Posts

Joined
Tue Mar 12, 2019 2:09 pm

User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 5 guests