Post by renegade2020 » Wed Feb 17, 2021 6:23 am

Hi all!
I am new to the forum and have what I hope to be any easy question. I am using opencart 3.0.3.6 with the Export/Import Tool by JNeuhoff. I have it all installed and have ran into a snag. Upon import of my spreadsheet it does not import, not sure why. Here's what I have done so far: test export and modified the header and columns in accordance with what it's looking for. Made sure all columns exist (used or not). Still does not seem to import anything, no errors and no results. I'm at a loss since there's no logs to point me in the right direction, any advice would be appreciated. Thanks!

Newbie

Posts

Joined
Wed Feb 17, 2021 6:05 am

Post by wktp76 » Sat Mar 27, 2021 1:43 pm

When exporting, the description is doubled!
http://joxi.ru/D2PJQn5tJ7RoNr

1 Language
Opencart 3.0.3.2, 3.0.3.7
PHP 7.3.27

Newbie

Posts

Joined
Wed Feb 13, 2019 7:30 pm

Post by JNeuhoff » Sat Mar 27, 2021 8:31 pm

Use LibreOffice Calc instead of MS Excel. MS Excel has a number of known bugs.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by wktp76 » Sun Mar 28, 2021 2:27 pm

Thank you, it worked, LibreOffice Calc is fine.

Newbie

Posts

Joined
Wed Feb 13, 2019 7:30 pm

Post by choulio19 » Mon Jun 07, 2021 7:03 pm

Hi i just installed your plugin on opnecart 3.0.2.0 and when i try to export products i get this error

Trying to access array offset on value of type int

What i have to do? Thanks

Newbie

Posts

Joined
Fri Jan 31, 2020 9:45 pm

Post by JNeuhoff » Mon Jun 07, 2021 7:09 pm

choulio19 wrote:
Mon Jun 07, 2021 7:03 pm
Hi i just installed your plugin on opnecart 3.0.2.0 and when i try to export products i get this error

Trying to access array offset on value of type int

What i have to do? Thanks
As per the documentation:

Requirements and Limitations
PHP Version 7.2 or higher is required for the current version 4.9 of the Export/Import tool.
Older PHP Versions are only supported by our older version 3.22 of the Export/Import tool.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Russalpcs » Thu Jun 17, 2021 12:14 am

Hi there

I am installing the latest version of Opencart. I have previously ran my store on OSCommerce and then on Zencart. On both of those I used Easy Populate to list my 12 000+ products as they create categories "on-the-fly"
I would like to know if this add-on does the same, meaning I just have to modify my existing CSV spreadsheets to your format to populate my site?

Thx
Russel

Newbie

Posts

Joined
Wed Jun 16, 2021 11:38 pm

Post by JNeuhoff » Thu Jun 17, 2021 12:58 am

Our Export/Import tool does not create categories on the fly. Categories have to be defined first, which can be done by our Export/Import tool, before importing the products.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Russalpcs » Fri Jun 18, 2021 3:44 pm

Hi there
I installed it but it does not want to export. Error "Trying to access array offset on value of type int " OC ver 3.0.3.7, PHP 7.4.20?
Russel

Newbie

Posts

Joined
Wed Jun 16, 2021 11:38 pm

Post by JNeuhoff » Fri Jun 18, 2021 8:14 pm

Russalpcs wrote:
Fri Jun 18, 2021 3:44 pm
Hi there
I installed it but it does not want to export. Error "Trying to access array offset on value of type int " OC ver 3.0.3.7, PHP 7.4.20?
Russel
Please read the documentation:

Requirements and Limitations
Use version 4.9 of the Export/Import tool for systems with PHP Version 7.2 or later.
Older PHP versions are still supported by our older version 3.22 of the Export/Import tool.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by jrr » Thu Jun 24, 2021 7:29 am

Not adding/creating incremental product_ids...

I'm getting the following error message:
2021-06-23 16:03:09 - Export/Import: Missing product_ids in worksheet 'Products'!
I am importing using the incremental setting:
Use incremental Import
Yes (Update and/or add data)
I thought the extension's job was to create the product_id if said id did not exist in the xls file?

I have enabled permissions in users.

Running OC 3.0.3.6, PHP 7.2.x, and am using the opencart-3-x-export-import-multilingual-4-9-cloud.ocmod version.

Also, I have Categories and then sub-categories of products. The Export function only works if I use a category sub-directory, not the parent category name.
EG, Category "Semiconductors" has the sub-categories "-Transistors" and "-Diodes". If I export the Semiconductor-Transistors category, then it works fine, if I try to export the category Semiconductors I get a spreadsheet with the descriptions, etc, just no products at all, where I would expect all the transistors and all the diodes instead.

jrr
Active Member

Posts

Joined
Mon Nov 20, 2017 1:48 pm

Post by JNeuhoff » Thu Jun 24, 2021 5:02 pm

Product IDs are always required. Incremental Import only means that existing products are updated, not newly created, and that no products will be deleted before the Import.

As regards categories: I don't know what your are on about, the Export/Import of categories works just fine, both for main and sub-categories.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by jrr » Fri Jun 25, 2021 1:33 am

I was under the impression that using the import/export would be a way to easily add new products to the store. Granted one can simply find the last number in the database and start with the next number. I guess that should work.
As for exporting categories, I want to export all the subcategories' products that are under a main product category. Not just a list of sub-categories. That was what I thought would happen if I listed the parent category under
Products (including product data, options, specials, discounts, rewards, attributes and filters)

jrr
Active Member

Posts

Joined
Mon Nov 20, 2017 1:48 pm

Post by OC2PS » Sun Jul 11, 2021 3:41 am

When I try to export (I have tried exporting products, categories, and customers), I get the following error:

Code: Select all

Trying to access array offset on value of type int
Chosen options: By batch size (999), batch number (1).
Settings:
Use option_id instead of option name in worksheets 'ProductOptions' and 'ProductOptionValues'
Use phpTemp cache for large Exports (will be slightly slower)

P.S. Same error when I try to export by id range.

Version: opencart-3-x-export-import-multilingual-3-22

OC2PS
OC 3.0.3.1, vQmod 2.6.4, Journal3 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary

Post by JNeuhoff » Sun Jul 11, 2021 4:05 pm

Requirements and Limitations
Use version 4.9 of the Export/Import tool for systems with PHP Version 7.2 or later.
Older PHP versions are still supported by our older version 3.22 of the Export/Import tool.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by OC2PS » Mon Jul 12, 2021 4:23 pm

JNeuhoff wrote:
Sun Jul 11, 2021 4:05 pm
Requirements and Limitations
Use version 4.9 of the Export/Import tool for systems with PHP Version 7.2 or later.
Older PHP versions are still supported by our older version 3.22 of the Export/Import tool.
That did it.

Looks like my heuristic of looking for the download date had failed me here ;)

OC2PS
OC 3.0.3.1, vQmod 2.6.4, Journal3 theme
Arcfesték, Csillámtetoválás, Henna
Image
Check out: All my extensions | My FREE extensions


User avatar
Active Member

Posts

Joined
Wed Jul 22, 2009 4:15 am
Location - Hungary
Who is online

Users browsing this forum: No registered users and 2 guests