Post by tav105 » Tue Nov 17, 2020 12:19 pm

JNeuhoff wrote:
Wed Nov 11, 2020 7:49 pm
I think php7.4-fpm on nginx is the main culprit here, judging by the many user reports on this according to a Google search.
After installing package php7.4-mbstring, the speed of Import on php7.4-fpm & nginx 1.18.0-0 became identical to the speed of php7.4.3-4 & apache2.4.41-4.
Installing php7.4-mbstring does not affect performance with php7.4.3-4 & apache2.4.41-4.
Apparently php7.4.3-4 & apache2.4.41-4 can work with long strings by default without degrading performance.
And for php7.4-fpm & nginx 1.18.0-0 you need to install php7.4-mbstring for fast work with long strings.

Thanks again for the module

Newbie

Posts

Joined
Tue Nov 10, 2020 6:07 pm

Post by JNeuhoff » Tue Nov 17, 2020 7:08 pm

Glad to hear you managed to solve the performance issue. The PHP mbstring library should be part of a standard PHP setup anyway!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Cue4cheap » Sat Nov 21, 2020 11:14 pm

Here is an interesting one... my webhost upgraded to php 7.4 before I expected it so I rushed to upgrade this extension. I thought I upgraded to V4.6 version 2.3.0.2 because it works well BUT... I now have a HUGE log with a lot of these:
2020-11-19 7:49:23 - PHP Warning: error_log(/REMOVED/juergen/REMOVED/opencart-3-0-3-6/system/storage/logs/error.log): failed to open stream: No such file or directory in /system/library/export_import/vendor/phpoffice/phpspreadsheet/src/PhpSpreadsheet/Style/Style.php on line 196

Did I get a version that was beta or ?
Before I shotgun this and try to download the latest version (which I thought I had) and try again I thought I would ask here.
Thank you,
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by JNeuhoff » Sat Nov 21, 2020 11:51 pm

Did I get a version that was beta or ?
Before I shotgun this and try to download the latest version (which I thought I had) and try again I thought I would ask here.
You are right, there was some old debug code in there which I have now removed. Please download again the file 'opencart-2-x-export-import-multilingual-4-6-1.ocmod' from https://www.opencart.com/index.php?rout ... sion_id=17

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Cue4cheap » Sun Nov 22, 2020 12:34 am

JNeuhoff wrote:
Sat Nov 21, 2020 11:51 pm
You are right, there was some old debug code in there which I have now removed. Please download again the file 'opencart-2-x-export-import-multilingual-4-6-1.ocmod' from https://www.opencart.com/index.php?rout ... sion_id=17
Ok now another.
I went into modifications and disabled, removed and refreshed the old export/import extension.
I downloaded opencart-2-x-export-import-multilingual-3-22.ocmod.zip I then used extension installer to install.
I did an export of 1 - 99 and now I am getting this in the log....

Code: Select all

2020-11-21 9:21:09 - PHP Unknown:  Array and string offset access syntax with curly braces is deprecated in /system/PHPExcel/Classes/PHPExcel/Shared/String.php on line 526
2020-11-21 9:21:09 - PHP Unknown:  Array and string offset access syntax with curly braces is deprecated in /system/PHPExcel/Classes/PHPExcel/Cell.php on line 812
2020-11-21 9:21:09 - PHP Unknown:  Array and string offset access syntax with curly braces is deprecated in /system/PHPExcel/Classes/PHPExcel/Cell/DefaultValueBinder.php on line 82
2020-11-21 9:21:09 - PHP Unknown:  Array and string offset access syntax with curly braces is deprecated in /system/PHPExcel/Classes/PHPExcel/Calculation.php on line 2551
2020-11-21 9:21:09 - PHP Unknown:  Array and string offset access syntax with curly braces is deprecated in /system/PHPExcel/Classes/PHPExcel/Worksheet/AutoFilter.php on line 720
2020-11-21 9:21:09 - PHP Unknown:  Array and string offset access syntax with curly braces is deprecated in /system/PHPExcel/Classes/PHPExcel/ReferenceHelper.php on line 884

2020-11-21 9:21:10 - PHP Notice:  Trying to access array offset on value of type null in /admin/model/tool/export_import.php on line 62
This is an interesting one to me because this should be simple but I appear to be doing something wrong??

Thank you,
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by JNeuhoff » Sun Nov 22, 2020 12:50 am

You have to use Version 4.6, the older version 3.22 doesn't support newer PHP versions!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Cue4cheap » Sun Nov 22, 2020 12:59 am

JNeuhoff wrote:
Sun Nov 22, 2020 12:50 am
You have to use Version 4.6, the older version 3.22 doesn't support newer PHP versions!
Thank you for your patience. It is working now without issue.
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am
Who is online

Users browsing this forum: No registered users and 4 guests