Post by jonimustakallio » Mon Jan 24, 2022 7:08 pm

Minulla on webhotelli Xetnetiltä ( https://www.xetnet.fi/webhotelli/ ) ja cPanel-hallintatyökalusta löytyy vaihtoehtoina esim. PHP 7.4 ja PHP 8.0. OpenCartin omat sivut kertovat että PHP 5.4 versio tai uudempi käy: https://docs.opencart.com/requirements/. Käsittääkseni PHP 5.4 on kivikautinen ja mitään 7.X versiota vanhempaa ei kannata käyttää. Onko teillä kokemusta mikä PHP versio kannattaa valita sekä ruutukaappausta esimerkiksi mitkä PHP asetukset/optiot kannattaa kytkeä päälle? Onko hyötyä esim. OPCache? Palvelin on LiteSpeed.


Posts

Joined
Mon Jan 24, 2022 7:02 pm

Post by pm-netti » Wed Jan 26, 2022 4:04 pm

Ottaen huomioon tuon sinun palvelimesi vaihtoehdot, suosittelen käyttämään Php 7.4, kasista minulla ei ole kokemuksia.
Toki mikään nykyisistä Opencart versioista ei täysin tue kaikki version 7.4 ominaisuuksia, mutta näkyy tuo minun sivulla toimivan tyydyttävästi.

User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by jonimustakallio » Mon Feb 07, 2022 6:48 pm

Kiitos tästä! PHP 7.4 tukikaan ei siis ole aukoton eli jos törmää ongelmiin, voi kokeilla 7.3 tai 7.2 versioita?


Posts

Joined
Mon Jan 24, 2022 7:02 pm

Post by pm-netti » Sat Feb 19, 2022 3:24 am

Kyllä sen kanssa pärjää, samoin php 7.2. Ei kannata laittaa mitään sellaista versiota, jonka ominaisuuksia ei cpanelissa voi muuttaa. Muuten voi tulla ongelmia, jos jokin omaisuus jää vajaaksi (esim. oikeus muokata tiedostoja).
Nämä kerää jatkuvasti ilmoituksia error.logiin, joten se kannattaa muistaa tyhjentää säännöllisesti, jotta se ei turhaan vie levytilaa.

User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland
Who is online

Users browsing this forum: No registered users and 2 guests